Loading ...
Sorry, an error occurred while loading the content.

Re: :make fails

Expand Messages
  • björn
    ... Are you the same person that started this thread or this another report of the same problem (I can t tell from the email address)? ... The :h
    Message 1 of 9 , May 13, 2009
    • 0 Attachment
      2009/5/12 Skammer:
      >
      >> Maybe you just need to change the pwd?
      >>
      >> Inside Vim:
      >>   1. See what the pwd is by typing ":pwd"
      >>   2. If it is not what you wanted it to be, type ":cd path/to/dir"
      >>
      >> Björn
      >
      > Same problem.
      > :pwd gives the right path.

      Are you the same person that started this thread or this another
      report of the same problem (I can't tell from the email address)?


      > I use this since I couldn't find where to remap Cmd-B:

      The ":h macvim-menus" section outlines how to bind to a Cmd-key if it
      is in use by a menu already -- see example 4 at the end of that
      section. (I'm going to update the help on this issue to make it
      easier to find.)

      I still seems to me that this problem has something to do with your
      setup. Have you tried moving your .[g]vimrc files and .vim folder out
      of the way to see if some setting/plugin is causing the problem?

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Skammer
      ... No. I m not mark.burge. ... Yes, it was the first thing came to mind. Clean MacVim installation, ... v324113/1 make: *** No targets specified and no
      Message 2 of 9 , May 14, 2009
      • 0 Attachment
        > Are you the same person that started this thread or this another
        > report of the same problem (I can't tell from the email address)?

        No. I'm not mark.burge.

        > I still seems to me that this problem has something to do with your
        > setup.  Have you tried moving your .[g]vimrc files and .vim folder out
        > of the way to see if some setting/plugin is causing the problem?

        Yes, it was the first thing came to mind. Clean MacVim installation,
        with no plugins/vimrc produses this error:
        :!make 2>&1| tee /var/folders/19/19PQcERJFCCsvf1lsMFSuk+++TI/-Tmp-/
        v324113/1
        make: *** No targets specified and no makefile found. Stop.
        (1 of 1): make: *** No targets specified and no makefile found. Stop.

        This is how a working command looks like:
        :!make main 2>&1| tee /var/folders/19/19PQcERJFCCsvf1lsMFSuk+++TI/-
        Tmp-/v324387/1

        There is no Makefile, so a target is specified.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Nico Weber
        Are you using the stable version of MacVim, or the snapshot? If stable, can you try the snapshot? (If snapshot, try stable). We changed the forking logic after
        Message 3 of 9 , May 14, 2009
        • 0 Attachment
          Are you using the stable version of MacVim, or the snapshot? If
          stable, can you try the snapshot? (If snapshot, try stable). We
          changed the forking logic after releasing the stable, perhaps that
          helped.

          Nico
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Skammer
          ... I use the latest snapshot. I ve tried to do make with stable version but it produces the same error. --~--~---------~--~----~------------~-------~--~----~
          Message 4 of 9 , May 14, 2009
          • 0 Attachment
            > Are you using the stable version of MacVim, or the snapshot? If
            > stable, can you try the snapshot? (If snapshot, try stable). We
            > changed the forking logic after releasing the stable, perhaps that
            > helped.
            I use the latest snapshot. I've tried to do make with stable version
            but it produces the same error.
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • björn
            ... I have two more things for you to try: 1. Run in console mode by starting from Terminal using /Applications/MacVim.app/Contents/MacOS/Vim 2. Toggle the
            Message 5 of 9 , May 18, 2009
            • 0 Attachment
              2009/5/15 Skammer:
              >
              >> Are you using the stable version of MacVim, or the snapshot? If
              >> stable, can you try the snapshot? (If snapshot, try stable). We
              >> changed the forking logic after releasing the stable, perhaps that
              >> helped.
              > I use the latest snapshot. I've tried to do make with stable version
              > but it produces the same error.

              I have two more things for you to try:

              1. Run in console mode by starting from Terminal using
              /Applications/MacVim.app/Contents/MacOS/Vim

              2. Toggle the "login shell" option in advanced prefs

              Does either of these make any difference?

              Björn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Skammer
              ... Cmd-b simply doesn t work in Terminal. My custom mapped Control-b worked fine. ... Nothing changed. ... I believe, as it keeps telling No targets
              Message 6 of 9 , May 23, 2009
              • 0 Attachment
                > I have two more things for you to try:
                >
                > 1. Run in console mode by starting from Terminal using
                >     /Applications/MacVim.app/Contents/MacOS/Vim

                Cmd-b simply doesn't work in Terminal. My custom mapped Control-b
                worked fine.

                > 2. Toggle the "login shell" option in advanced prefs

                Nothing changed.

                > Does either of these make any difference?

                I believe, as it keeps telling "No targets specified" no matter what I
                try, there is some error in make script toggled by Cmd-b.

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              Your message has been successfully submitted and would be delivered to recipients shortly.