Loading ...
Sorry, an error occurred while loading the content.

Re: Compiling vim on OSX Leopard

Expand Messages
  • Tony Mechelynck
    ... This is not the right group for such a specific question. This group is about problems related with _using_ already compiled versions of Vim. Problems
    Message 1 of 2 , May 10, 2009
    • 0 Attachment
      On 07/05/09 00:09, R. Hicks wrote:
      >
      > I just tried with the following configure (after getting the latest from
      > svn):
      >
      > ./configure --enable-cscope --enable-multibyte --with-features=huge
      >
      > I get a whole bunch of gui_mac warnings and errors and at the end it
      > reports:
      >
      > make[1]: *** [objects/gui_mac.o] Error 1
      > make: *** [install] Error 2
      >
      >
      > Is this a known problem?
      >
      > Robert

      This is not the right group for such a specific question.

      This group is about problems related with _using_ already compiled
      versions of Vim.

      Problems related with _compiling_ Vim in general should go to the
      vim_dev group, and specific problems about Vim on the Mac (including
      compiling Macvim) should go to the vim_mac group, so I'm trying to
      redirect the replies to this email. Please subscribe to those two groups
      if you haven't yet.

      In general, you should make sure to have the include files for every
      software that you want to compile into Vim. This usually means
      installing the corresponding "development" packages. You should go
      through all those configure errors one by one and see if there are
      installable modules, possibly "development" packages, that you could
      install to make them disappear.

      For the MacVim build, I don't know the details, but I think that an
      unofficial patch is necessary. I could, however, quite easily be wrong
      in that respect since I am on Linux myself and previously I've been on
      Windows but never on a Mac.

      In general, I believe that my HowTo page
      http://users.skynet.be/antoine.mechelynck/vim/compunix.htm might still
      be helpful to you (since OS X is a "Unix-like" OS), but I also believe
      that on the Mac it is not the full story.


      Best regards,
      Tony.
      --
      "The Schizophrenic: An Unauthorized Autobiography"

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Steve Huff
      ... to build MacVim, follow the procedure documented here: http://code.google.com/p/macvim/wiki/Building once you ve verified that you can do that, you can
      Message 2 of 2 , May 11, 2009
      • 0 Attachment
        On 07/05/09 00:09, R. Hicks wrote:
        >
        > I just tried with the following configure (after getting the latest
        > from
        > svn):
        >
        > ./configure --enable-cscope --enable-multibyte --with-features=huge

        to build MacVim, follow the procedure documented here:

        http://code.google.com/p/macvim/wiki/Building

        once you've verified that you can do that, you can certainly try
        adding additional options to your ./configure invocation and see if
        you succeed.

        -steve

        --
        http://five.sentenc.es


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.