Loading ...
Sorry, an error occurred while loading the content.
 

Re: MacVim Latex Indentation

Expand Messages
  • Ted Pavlic
    If this patch is general (i.e., it doesn t break Vim-LaTeX on other systems), you should definitely post it to the vim-latex-devel list: Vim-Latex Mailing List
    Message 1 of 5 , May 3, 2009
      If this patch is general (i.e., it doesn't break Vim-LaTeX on other
      systems), you should definitely post it to the vim-latex-devel list:

      Vim-Latex Mailing List <vim-latex-devel@...>

      with "[PATCH]" in the subject. One of the Vim-LaTeX admins will merge it
      into the SVN.

      --Ted

      On 5/1/09 8:18 PM, Maximilian Nickel wrote:
      > Hi,
      > Regarding the vim-latex menus: I had the same problem and ended up
      > editing the vim-latex files as a workaround.
      > It seems MacVim has a problem with vim-latex's use of <tab> in amenu lines.
      > The attached patch removes them for templates and macros.
      > Apply it with "patch -p0 < macvim-latex.diff" in ~/.vim and you should
      > see the filenames for templates and macros.
      >
      > Regarding the identation problem: you can try adding something like
      > "autocmd FileType tex setlocal indentexpr="
      > to your .vimrc
      >
      > /max
      >
      > On Tue, Apr 28, 2009 at 5:22 AM, boozler <kcd001@...
      > <mailto:kcd001@...>> wrote:
      >
      >
      > The first problem is that the vim-latex templates do not have file
      > names in the MacVim menu (Tex-Suite -> Templates) only numbers. So I
      > have to guess at which template to load or load from the command line
      > "TTemplate" which displays the correct names.
      >
      > Second problem: When I load my templates they are automatically
      > indented. Can I turn off indentation just for while loading templates?
      > If not can I turn off indentation just for the latex plugin? I need to
      > keep indentation going for other file types (c/c++/ruby/etc)...
      >
      > FYI my vimrc:
      > filetype plugin indent on
      > set grepprg=grep\ -nH\ $*
      > let g:tex_flaver='latex'
      > let g:Tex_ViewRule_pdf = 'Preview'
      >
      >
      >
      >
      > >

      --
      Ted Pavlic <ted@...>

      Please visit my ALS association page:
      http://web.alsa.org/goto/tedpavlic
      My family appreciates your support in the fight to defeat ALS.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      I agree with Ted -- send it on to the Vim-Latex list. Assuming that the text after will show on the menus of all systems is a bad assumption. The text
      Message 2 of 5 , May 3, 2009
        I agree with Ted -- send it on to the Vim-Latex list.

        Assuming that the text after <tab> will show on the menus of all
        systems is a bad assumption. The text after <tab> is supposed to be
        used to give the user a hint as to how this menu can be called using
        only the keyboard (e.g. "Split-Open..." says ":sp") -- it is not
        supposed to be used as a way of "typesetting" the menu labels (the way
        vim-latex does).

        On MacVim the text after <tab> is shown in a tooltip that pops up
        after letting the mouse hover over the menu item for a second or two.
        There is no support in the Cocoa APIs to have some menu text
        right-aligned the way it works for gvim on other platforms -- hence
        the use of tooltips.

        Björn

        2009/5/3 Ted Pavlic <ted@...>:
        >
        > If this patch is general (i.e., it doesn't break Vim-LaTeX on other
        > systems), you should definitely post it to the vim-latex-devel list:
        >
        > Vim-Latex Mailing List <vim-latex-devel@...>
        >
        > with "[PATCH]" in the subject. One of the Vim-LaTeX admins will merge it
        > into the SVN.
        >
        > --Ted
        >
        > On 5/1/09 8:18 PM, Maximilian Nickel wrote:
        >> Hi,
        >> Regarding the vim-latex menus: I had the same problem and ended up
        >> editing the vim-latex files as a workaround.
        >> It seems MacVim has a problem with vim-latex's use of <tab> in amenu lines.
        >> The attached patch removes them for templates and macros.
        >> Apply it with "patch -p0 < macvim-latex.diff"  in ~/.vim and you should
        >> see the filenames for templates and macros.
        >>
        >> Regarding the identation problem: you can try adding something like
        >> "autocmd FileType tex setlocal indentexpr="
        >> to your .vimrc
        >>
        >> /max
        >>
        >> On Tue, Apr 28, 2009 at 5:22 AM, boozler <kcd001@...
        >> <mailto:kcd001@...>> wrote:
        >>
        >>
        >>     The first problem is that the vim-latex templates do not have file
        >>     names in the MacVim menu (Tex-Suite -> Templates) only numbers. So I
        >>     have to guess at which template to load or load from the command line
        >>     "TTemplate" which displays the correct names.
        >>
        >>     Second problem: When I load my templates they are automatically
        >>     indented. Can I turn off indentation just for while loading templates?
        >>     If not can I turn off indentation just for the latex plugin? I need to
        >>     keep indentation going for other file types (c/c++/ruby/etc)...
        >>
        >>     FYI my vimrc:
        >>     filetype plugin indent on
        >>     set grepprg=grep\ -nH\ $*
        >>     let g:tex_flaver='latex'
        >>     let g:Tex_ViewRule_pdf = 'Preview'
        >>
        >>
        >>
        >>
        >> >
        >
        > --
        > Ted Pavlic <ted@...>
        >
        >   Please visit my ALS association page:
        >         http://web.alsa.org/goto/tedpavlic
        >   My family appreciates your support in the fight to defeat ALS.
        >
        > >
        >

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.