Loading ...
Sorry, an error occurred while loading the content.

Re: :help freezing

Expand Messages
  • björn
    ... Great! I m glad you figured it out. ... I tried recreating the crash using the contents of your tags file, but I only get this error: E431: Format error
    Message 1 of 11 , Apr 15, 2009
    • 0 Attachment
      2009/4/13 Kenneth Reid Beesley:
      >
      > Got it!
      >
      > Many thanks for persevering with me.  You, Derek Wyatt and others in
      > the vim community are very supportive, and this is much appreciated.

      Great! I'm glad you figured it out.

      > If I mv my-doc back to doc, and rename 'tags', then again the problem
      > goes away.  Here's the content of .vim/doc/tags
      >
      > !_TAG_FILE_ENCODING     utf-8   //
      > xml-plugin-callbacks    xml-plugin.txt  /*xml-plugin-callbacks*
      > xml-plugin-html xml-plugin.txt  /*xml-plugin-html*
      > xml-plugin-mappings     xml-plugin.txt  /*xml-plugin-mappings*
      > xml-plugin-settings     xml-plugin.txt  /*xml-plugin-settings*
      >
      > I don't understand it all, to be sure, but it looks like something to
      > do with the 'tags' and 'xml-plugin.txt' files that I got somewhere.  I
      > can't remember where I got them, or why I placed them in .vim/docs/
      > I was probably trying to customize (g)vim for better editing of XML
      > files.

      I tried recreating the crash using the contents of your "tags" file,
      but I only get this error:

      E431: Format error in tags file "/Users/winckler/.vim/doc/tags"
      Before byte 35
      E149: Sorry, no help for help.txt

      So I'm not sure why it would lock up on your machine...but this is
      more of a Vim (as opposed to MacVim) and I don't understand much of
      the Vim source code anyway.

      By the way: the "tags" file is just an index for all the help files
      that you have installed "locally" (in your ~/.vim folder). So it is
      updated e.g. when you install a new plugin with VimBall. You can also
      call ":helptags ~/.vim/doc" to update the "tags" file manually (this
      will overwrite the old "tags" file).

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.