Loading ...
Sorry, an error occurred while loading the content.
 

Cursorline as line not shadow

Expand Messages
  • Brian McKee
    Hi All Recent posts on the list have made me look at the cursorline and cursorcolumn options. If you set cursorline and use vim in the terminal, the line is a
    Message 1 of 8 , Mar 24, 2009
      Hi All

      Recent posts on the list have made me look at the cursorline and
      cursorcolumn options. If you set cursorline and use vim in the
      terminal, the line is a thin underline. In the regular GUI interface
      it's a background shading. (I'm using the Pablo colour scheme) I'd
      prefer to have the terminal style underline everywhere. How do I do
      that? Poking around I think it has something to do with CurrentLine,
      but I don't know where to set that...
      Suggestions appreciated,
      Brian

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      Hi Brian, ... Björn --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more information, visit
      Message 2 of 8 , Mar 24, 2009
        Hi Brian,

        2009/3/24 Brian McKee\:
        >
        > Recent posts on the list have made me look at the cursorline and
        > cursorcolumn options.  If you set cursorline and use vim in the
        > terminal, the line is a thin underline.  In the regular GUI interface
        > it's a background shading.  (I'm using the Pablo colour scheme)   I'd
        > prefer to have the terminal style underline everywhere.  How do I do
        > that?  Poking around I think it has something to do with CurrentLine,
        > but I don't know where to set that...
        > Suggestions appreciated,

        Try the following two lines:

        :hi clear CursorLine
        :hi CursorLine gui=underline

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Brian McKee
        ... Yep - that does it, but now I m not sure I like it :-( the bright yellow in the terminal works, but it s just the std grey in the GUI. I ll muck about
        Message 3 of 8 , Mar 24, 2009
          On Tue, Mar 24, 2009 at 1:12 PM, björn <bjorn.winckler@...> wrote:
          > 2009/3/24 Brian McKee\:
          >>
          >> Recent posts on the list have made me look at the cursorline and
          >> cursorcolumn options.  If you set cursorline and use vim in the
          >> terminal, the line is a thin underline.  In the regular GUI interface
          >> it's a background shading.  (I'm using the Pablo colour scheme)   I'd
          >> prefer to have the terminal style underline everywhere.  How do I do
          >> that?  Poking around I think it has something to do with CurrentLine,
          >> but I don't know where to set that...
          >> Suggestions appreciated,
          >
          > Try the following two lines:
          >
          > :hi clear CursorLine
          > :hi CursorLine gui=underline

          Yep - that does it, but now I'm not sure I like it :-( the bright
          yellow in the terminal works, but it's just the std grey in the GUI.
          I'll muck about some more.

          Brian

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tobia Conforto
          ... Excellent! This is so going in my .vimrc -Tobia --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac
          Message 4 of 8 , Mar 24, 2009
            björn wrote:
            > Try the following two lines:
            >
            > :hi clear CursorLine
            > :hi CursorLine gui=underline

            Excellent!
            This is so going in my .vimrc

            -Tobia
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • björn
            ... You can set the color with guisp (see :h highlight-guisp and :h ... Please note that MacVim currently does not underline spaces nor does it support
            Message 5 of 8 , Mar 28, 2009
              2009/3/24 Brian McKee:
              >>
              >> Try the following two lines:
              >>
              >> :hi clear CursorLine
              >> :hi CursorLine gui=underline
              >
              > Yep - that does it, but now I'm not sure I like it :-(  the bright
              > yellow in the terminal works, but it's just the std grey in the GUI.
              > I'll muck about some more.

              You can set the color with "guisp" (see ":h highlight-guisp" and ":h
              underline"), so change those two lines to:

              :hi clear cursorline
              :hi cursorline gui=underline guisp=yellow

              Please note that MacVim currently does not underline spaces nor does
              it support undercurls. These issues will be fixed in the Core Text
              renderer (I will try to release a patch for people to try out soon).

              Björn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tobia Conforto
              ... To paint a more complete picture, this depends on whether you have enabled the ATSUI renderer in MacVim preferences (⌘,) - with ATSUI, the underline
              Message 6 of 8 , Apr 1, 2009
                björn wrote:
                > You can set the color with "guisp" (see ":h highlight-guisp" and ":h
                > underline"), so change those two lines to:
                >
                > :hi clear cursorline
                > :hi cursorline gui=underline guisp=yellow
                >
                > Please note that MacVim currently does not underline spaces

                To paint a more complete picture, this depends on whether you have
                enabled the ATSUI renderer in MacVim preferences (⌘,)
                - with ATSUI, the underline spans the whole window, but you can't set
                its color;
                - with the Cocoa renderer (meaning with ATSUI turned off) leading and
                trailing spaces aren't underlined, but you can set the underline color
                as mentioned by Björn.
                The new experimental Core Text renderer will probably have yet another
                feature set.

                What I was calling "excellent" is the ATSUI behaviour, where it
                displays a bright underline across the whole MacVim window!

                HTH
                Tobia
                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • björn
                ... Ok, I see this bug. I ll fix it straight away. (I didn t check whether ATSUI underlined spaces or not, thanks for pointing this out.) ... It underlines
                Message 7 of 8 , Apr 1, 2009
                  2009/4/1 Tobia Conforto:
                  >
                  >> You can set the color with "guisp" (see ":h highlight-guisp" and ":h
                  >> underline"), so change those two lines to:
                  >>
                  >> :hi clear cursorline
                  >> :hi cursorline gui=underline guisp=yellow
                  >>
                  >> Please note that MacVim currently does not underline spaces
                  >
                  > To paint a more complete picture, this depends on whether you have
                  > enabled the ATSUI renderer in MacVim preferences (⌘,)
                  > - with ATSUI, the underline spans the whole window, but you can't set
                  > its color;

                  Ok, I see this bug. I'll fix it straight away. (I didn't check
                  whether ATSUI underlined spaces or not, thanks for pointing this out.)

                  > - with the Cocoa renderer (meaning with ATSUI turned off) leading and
                  > trailing spaces aren't underlined, but you can set the underline color
                  > as mentioned by Björn.
                  > The new experimental Core Text renderer will probably have yet another
                  > feature set.

                  It underlines spaces and setting "guisp" works.

                  Björn

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Brian McKee
                  ... I ll keep that in mind - I m back on stable since I need the mount network shares via alias feature and the snapshots haven t got it.... Brian
                  Message 8 of 8 , Apr 1, 2009
                    On Wed, Apr 1, 2009 at 4:12 AM, Tobia Conforto <tobia.conforto@...> wrote:
                    > What I was calling "excellent" is the ATSUI behaviour, where it
                    > displays a bright underline across the whole MacVim window!

                    I'll keep that in mind - I'm back on stable since I need the mount
                    network shares via alias feature and the snapshots haven't got it....

                    Brian

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  Your message has been successfully submitted and would be delivered to recipients shortly.