Loading ...
Sorry, an error occurred while loading the content.

Re: macroman/latin-1 encoding

Expand Messages
  • Axel Kielhorn
    ... Why don t you use GTK-Vim on MacOX. There is a native GTK for Carbon: http://gtk-osx.sourceforge.net/index.html Axel
    Message 1 of 11 , Jun 20, 2003
    • 0 Attachment
      At 19:07 Uhr +0200 2003-06-19, S├ębastien Pierre wrote:
      >Maybe we could hope to switch to kvim, now that Qt is announced to
      >be GPL'ed on OSX.

      Why don't you use GTK-Vim on MacOX. There is a native GTK for Carbon:
      http://gtk-osx.sourceforge.net/index.html

      Axel
    • The Shrubber
      Hi, Being impatient, i tried your binary directly :-), but did not get a nice result. ... If it helps, i have attached test files, who should display in Carbon
      Message 2 of 11 , Jun 20, 2003
      • 0 Attachment
        Hi,

        Being impatient, i tried your binary directly :-), but did not get
        a nice result.

        :set encoding=MacRoman
        :set fileencoding=latin-1
        :r accents.latin1.test

        If it helps, i have attached test files, who should display in
        Carbon Vim exactly as terminal and gvim.

        Oh well. Hopefully you folks will get this one figured out eventually.

        Best,

        (-S-)

        P.S in case this helps any european latex users,
        my temporary solution is

        \usepackage[applemac]{inputenc}


        On Fri, Jun 20, 2003 at 02:54:20 +0900, MURAOKA Taro koron-at-tka.att.ne.jp |vim-mac@.../1.0-Allow| wrote:
        > I have newer patches. In it, iconv emulation is improved. But it
        > includes all my experimental features and Japanese document only. If
        > you want to try it, it availables at here:
        > http://www.kaoriya.net/dist/vim-6.2.014-difj.tar.bz2
      • The Shrubber
        sorry... test files attached
        Message 3 of 11 , Jun 20, 2003
        • 0 Attachment
          sorry... test files attached

          On Fri, Jun 20, 2003 at 18:18:40 +0200, Eric Y. Kow wrote:
          > If it helps, i have attached test files, who should display in
          > Carbon Vim exactly as terminal and gvim.
        • MURAOKA Taro
          Thanks for your testing and test-file. ... I hope it will bring better result for you. ... MURAOKA Taro
          Message 4 of 11 , Jun 20, 2003
          • 0 Attachment
            Thanks for your testing and test-file.

            > Being impatient, i tried your binary directly :-), but did not get
            > a nice result.
            >
            > :set encoding=MacRoman
            > :set fileencoding=latin-1
            > :r accents.latin1.test

            Please try these commands, with same binary:
            :set gfn=Courier:h12
            :set encoding=macroman
            :e ++enc=latin1 accents.latin1.test

            I hope it will bring better result for you.
            ----
            MURAOKA Taro <koron@...>
          • The Shrubber
            ... This does work! Out of curiosity, why doesn t it work if i try the same thing with utf-8? It says [not converted] . Thanks, (-S-) P.S still have not had
            Message 5 of 11 , Jun 23, 2003
            • 0 Attachment
              > :set encoding=macroman
              > :e ++enc=latin1 accents.latin1.test

              This does work!

              Out of curiosity, why doesn't it work if i try the same thing with
              utf-8? It says "[not converted]".

              Thanks,

              (-S-)

              P.S still have not had time to try building the src
            • Axel Kielhorn
              ... After removing these files everything works fine. But I m surprised they caused problems. I instaled a Japanese user and tried to run your Vim in her
              Message 6 of 11 , Jun 23, 2003
              • 0 Attachment
                At 22:37 Uhr +0900 2003-06-20, MURAOKA Taro wrote:
                >Thanks for your report.
                >
                >In my patch, there are some plugin files which have Japanese characters.
                >It may cause some troubles. Please remove those files and try again.
                >
                >Example commands to remove:
                > cd vim62/runtime/plugin
                > rm -f autodate.vim
                > rm -f cmdex.vim
                > rm -f dicwin.vim
                > rm -f format.vim
                > rm -f hz_ja.vim
                > rm -f scrnmode.vim
                > rm -f verifyenc.vim

                After removing these files everything works fine.
                But I'm surprised they caused problems. I instaled a Japanese user
                and tried to run your Vim in her account, but still no success, the
                menu appear and after that an endless beachball.

                I have still problems with Osaka-Mono, Osaka works but is unusable
                because it is not fixed width.

                Axel,
                who is very happy that the shortcuts are the same in Japanese MacOS,
                otherwise I would still be trying to log out.
              Your message has been successfully submitted and would be delivered to recipients shortly.