Loading ...
Sorry, an error occurred while loading the content.

Re: / Control-Tab broken in snapshot 43?

Expand Messages
  • björn
    Hi Simo, ... Indeed, it seems like a regression... doesn t even work on 10.5 anymore. I will look into it. Thanks for reporting this issue, Björn
    Message 1 of 7 , Mar 13, 2009
    • 0 Attachment
      Hi Simo,

      2009/3/13 Simo Salminen:
      >
      > I was running official MacVim 7.2 before, and my mappings using <C-
      > Tab> worked. Now I'm running snapshot 43, and the mappings are not
      > responding.
      >
      > My system is Tiger 10.4.11.
      >
      > I read on this newsgroup that this was issue before and was fixed [1],
      > so maybe this is regression?

      Indeed, it seems like a regression...<C-Tab> doesn't even work on 10.5
      anymore. I will look into it.

      Thanks for reporting this issue,
      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Ok, it is fixed. The regression was introduced here: http://repo.or.cz/w/MacVim.git?a=commit;h=c79be7f927aff8b2b52a6d8d917b899154ab0ff9 Thanks, Björn
      Message 2 of 7 , Mar 13, 2009
      • 0 Attachment
        2009/3/13 björn:
        > Hi Simo,
        >
        > 2009/3/13 Simo Salminen:
        >>
        >> I was running official MacVim 7.2 before, and my mappings using <C-
        >> Tab> worked. Now I'm running snapshot 43, and the mappings are not
        >> responding.
        >>
        >> My system is Tiger 10.4.11.
        >>
        >> I read on this newsgroup that this was issue before and was fixed [1],
        >> so maybe this is regression?
        >
        > Indeed, it seems like a regression...<C-Tab> doesn't even work on 10.5
        > anymore.  I will look into it.

        Ok, it is fixed. The regression was introduced here:

        http://repo.or.cz/w/MacVim.git?a=commit;h=c79be7f927aff8b2b52a6d8d917b899154ab0ff9

        Thanks,
        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Johan Liseborn
        ... I am not sure if it is related, but it seems CTRL-] (jump to definition) does not work on Swedish keyboards in snapshot 43 (on a Swedish keyboard, you will
        Message 3 of 7 , Mar 14, 2009
        • 0 Attachment
          On Fri, Mar 13, 2009 at 22:44, björn <bjorn.winckler@...> wrote:
          >
          > 2009/3/13 björn:
          >> Hi Simo,
          >>
          >> 2009/3/13 Simo Salminen:
          >>>
          >>> I was running official MacVim 7.2 before, and my mappings using <C-
          >>> Tab> worked. Now I'm running snapshot 43, and the mappings are not
          >>> responding.
          >>>
          >>> My system is Tiger 10.4.11.
          >>>
          >>> I read on this newsgroup that this was issue before and was fixed [1],
          >>> so maybe this is regression?
          >>
          >> Indeed, it seems like a regression...<C-Tab> doesn't even work on 10.5
          >> anymore.  I will look into it.
          >
          > Ok, it is fixed.  The regression was introduced here:
          >
          > http://repo.or.cz/w/MacVim.git?a=commit;h=c79be7f927aff8b2b52a6d8d917b899154ab0ff9

          I am not sure if it is related, but it seems CTRL-] (jump to
          definition) does not work on Swedish keyboards in snapshot 43 (on a
          Swedish keyboard, you will get "]" by pressing alt-9). Or do I have to
          do something to "activate" it?


          /johan

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • björn
          ... I looked into this and there doesn t seem to be much that I can do about this. On a Swedish keyboard, Ctrl-Alt-9 is sent to MacVim as 9 -- the fact that
          Message 4 of 7 , Mar 15, 2009
          • 0 Attachment
            2009/3/14 Johan Liseborn:
            >
            > I am not sure if it is related, but it seems CTRL-] (jump to
            > definition) does not work on Swedish keyboards in snapshot 43 (on a
            > Swedish keyboard, you will get "]" by pressing alt-9). Or do I have to
            > do something to "activate" it?

            I looked into this and there doesn't seem to be much that I can do
            about this. On a Swedish keyboard, Ctrl-Alt-9 is sent to MacVim as
            "9" -- the fact that Alt-9 should be "]" is completely lost. Contrast
            this with a German keyboard where if you press Ctrl-Alt-6 MacVim
            receives Ctrl plus "]".

            MacVim relies on the selected keyboard input method to translate keys
            -- in this case the Swedish layout does the translation "wrong" so
            there isn't much MacVim can do about this. I know that this is a
            completely unsatisfactory answer, but I really don't know how this can
            be fixed. (By the way, it is not only a problem with snap 43 ... I'm
            pretty sure all versions of MacVim can't deal with this key on a
            Swedish layout.)

            Björn

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Johan Liseborn
            ... Ah, I see. I am pretty recent convert to both Vi and MacVim, that s why I was a bit unsure whether I was doing something wrong, or if this was a problem
            Message 5 of 7 , Mar 15, 2009
            • 0 Attachment
              On Sun, Mar 15, 2009 at 14:27, björn <bjorn.winckler@...> wrote:
              >
              > 2009/3/14 Johan Liseborn:
              >>
              >> I am not sure if it is related, but it seems CTRL-] (jump to
              >> definition) does not work on Swedish keyboards in snapshot 43 (on a
              >> Swedish keyboard, you will get "]" by pressing alt-9). Or do I have to
              >> do something to "activate" it?
              >
              > I looked into this and there doesn't seem to be much that I can do
              > about this.  On a Swedish keyboard, Ctrl-Alt-9 is sent to MacVim as
              > "9" -- the fact that Alt-9 should be "]" is completely lost.  Contrast
              > this with a German keyboard where if you press Ctrl-Alt-6 MacVim
              > receives Ctrl plus "]".
              >
              > MacVim relies on the selected keyboard input method to translate keys
              > -- in this case the Swedish layout does the translation "wrong" so
              > there isn't much MacVim can do about this.  I know that this is a
              > completely unsatisfactory answer, but I really don't know how this can
              > be fixed.  (By the way, it is not only a problem with snap 43 ... I'm
              > pretty sure all versions of MacVim can't deal with this key on a
              > Swedish layout.)

              Ah, I see. I am pretty recent convert to both Vi and MacVim, that's
              why I was a bit unsure whether I was doing something wrong, or if this
              was a problem with MacVim (or, as it appear, a problem further down
              the "stack").

              Anyway, I have one additional piece of information which I am not sure
              if it will be useful to you or not, but anyway: It seems there is some
              sort of difference between pressing "Ctrl-Alt-9" and just pressing
              "9"; in the latter case, MacVim interprets the "9" as the number
              before a command (i.e. the "9" appears at the bottom of the screen,
              and MacVim waits for additional input, e.g. a movement command),
              wheras in the former case MacVim "beeps", like the keycombo is not
              defined or something like that.

              I am not familiar with the inner workings here, so I can't tell what
              really is happening, but it appears MacVim sees some sort of
              difference between "Ctrl-Alt-9" and just "9".

              Anyway, I still want to say thanks for the good work; other than this,
              I really enjoy MacVim, and if it turns out unfeasible to fix the
              Ctrl-] issue, I guess I just have to remap it to something else!


              Cheers,

              /johan

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • björn
              ... The difference is that in the former case Vim gets the Ctrl and Alt modifier flags as well as the 9 and then Vim performs its own Alt translation and
              Message 6 of 7 , Mar 15, 2009
              • 0 Attachment
                2009/3/15 Johan Liseborn:
                >
                > On Sun, Mar 15, 2009 at 14:27, björn <bjorn.winckler@...> wrote:
                >>
                >> 2009/3/14 Johan Liseborn:
                >>>
                >>> I am not sure if it is related, but it seems CTRL-] (jump to
                >>> definition) does not work on Swedish keyboards in snapshot 43 (on a
                >>> Swedish keyboard, you will get "]" by pressing alt-9). Or do I have to
                >>> do something to "activate" it?
                >>
                >> I looked into this and there doesn't seem to be much that I can do
                >> about this.  On a Swedish keyboard, Ctrl-Alt-9 is sent to MacVim as
                >> "9" -- the fact that Alt-9 should be "]" is completely lost.  Contrast
                >> this with a German keyboard where if you press Ctrl-Alt-6 MacVim
                >> receives Ctrl plus "]".
                >>
                >> MacVim relies on the selected keyboard input method to translate keys
                >> -- in this case the Swedish layout does the translation "wrong" so
                >> there isn't much MacVim can do about this.  I know that this is a
                >> completely unsatisfactory answer, but I really don't know how this can
                >> be fixed.  (By the way, it is not only a problem with snap 43 ... I'm
                >> pretty sure all versions of MacVim can't deal with this key on a
                >> Swedish layout.)
                >
                > Ah, I see. I am pretty recent convert to both Vi and MacVim, that's
                > why I was a bit unsure whether I was doing something wrong, or if this
                > was a problem with MacVim (or, as it appear, a problem further down
                > the "stack").
                >
                > Anyway, I have one additional piece of information which I am not sure
                > if it will be useful to you or not, but anyway: It seems there is some
                > sort of difference between pressing "Ctrl-Alt-9" and just pressing
                > "9"; in the latter case, MacVim interprets the "9" as the number
                > before a command (i.e. the "9" appears at the bottom of the screen,
                > and MacVim waits for additional input, e.g. a movement command),
                > wheras in the former case MacVim "beeps", like the keycombo is not
                > defined or something like that.
                >
                > I am not familiar with the inner workings here, so I can't tell what
                > really is happening, but it appears MacVim sees some sort of
                > difference between "Ctrl-Alt-9" and just "9".

                The difference is that in the former case Vim gets the Ctrl and Alt
                modifier flags as well as the "9" and then Vim performs its own "Alt
                translation" and the "9" turns into a "superscript 1" (try hitting
                Ctrl-Alt-9 in insert mode and you'll see what happens). This is
                somewhat unexpected but harmless as far as I can tell.

                > Anyway, I still want to say thanks for the good work; other than this,
                > I really enjoy MacVim, and if it turns out unfeasible to fix the
                > Ctrl-] issue, I guess I just have to remap it to something else!

                I'm afraid you will have to find some alternatives. I myself always
                type with an English keyboard layout -- if I need to type in Swedish I
                switch layouts with Ctrl+Space (set in System Preferences) whenever I
                enter insert mode. I've been thinking of expanding the 'iminsert'
                (and related) option(s) to automatically switch to a user specified
                layout when insert mode is entered and back to English whenever it is
                exited again, but I am not sure how welcome such a change would be.
                (This would be relatively simple to implement, but it requires the use
                of 10.5 only APIs.)

                Björn

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              Your message has been successfully submitted and would be delivered to recipients shortly.