Loading ...
Sorry, an error occurred while loading the content.
 

Vim-LaTeX and F9 completion

Expand Messages
  • d.avitabile@gmail.com
    Hi all, I have posted this thread on the Vim-LaTeX mailing list and received no answer, so I have decided to try here. I do not know whether my problem is an
    Message 1 of 2 , Mar 8, 2009
      Hi all,

      I have posted this thread on the Vim-LaTeX mailing list and received
      no answer, so I have decided to try here. I do not know whether my
      problem is an incompatibility between MacVim and Vim-LaTeX or not.

      When I try to use F9 for completion, something weird happens. I am
      prompted correctly with all the possibile choices for the labels. Also
      the outline (or preview) is shown correctly. When I press ENTER to
      select one, though, I am brought back to the document I was editing,
      in the correct place, but the completion hasn't happened.

      Does F9 completion work for you?

      Best.

      Daniele

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... I ve never used this before so I had to read the docs on what it is supposed to do, but as far as I can tell F9 works fine for me. I enter some text, e.g.
      Message 2 of 2 , Mar 9, 2009
        2009/3/8 d.avitabile:
        >
        > I have posted this thread on the Vim-LaTeX mailing list and received
        > no answer, so I have decided to try here. I do not know whether my
        > problem is an incompatibility between MacVim and Vim-LaTeX or not.
        >
        > When I try to use F9 for completion, something weird happens. I am
        > prompted correctly with all the possibile choices for the labels. Also
        > the outline (or preview) is shown correctly. When I press ENTER to
        > select one, though, I am brought back to the document I was editing,
        > in the correct place, but the completion hasn't happened.
        >
        > Does F9 completion work for you?

        I've never used this before so I had to read the docs on what it is
        supposed to do, but as far as I can tell F9 works fine for me. I
        enter some text, e.g.

        A reference \ref{sec:

        and hit F9 and a new window called "__OUTLINE__" opens up. However,
        everything in this window has been folded so I first unfold the lines
        and then move the cursor to a line containing e.g. "sec:approx" and
        hit ENTER. After this the "outline" window closes and the line I
        started entering reads

        A reference \ref{sec:approx}

        If that doesn't work for you I am guessing something is wrong in your
        [g]vimrc files. Try removing all lines except the ones needed for the
        latex-suite ("set filetype plugin indent" is probably all you need)
        and see if that works.

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.