Loading ...
Sorry, an error occurred while loading the content.
 

Re: Problem building snapshot 43 +python

Expand Messages
  • expora
    Thank you for your help Björn. I think I m going to try uninstalling Python 3.0 as a last resort because right now I m trying to learn the differences between
    Message 1 of 11 , Mar 3, 2009
      Thank you for your help Björn.

      I think I'm going to try uninstalling Python 3.0 as a last resort
      because right now I'm trying to learn the differences between python
      2.5 and 3.0. The past MacVim snapshot hasn't given me any problems so
      I'll use it for a while before building again.

      Thanks!

      Edwin.

      On Mar 3, 3:59 pm, björn <bjorn.winck...@...> wrote:
      > 2009/3/3 expora:
      >
      >
      >
      > >> > Do you think my Xcode version has to do with this? I'm using 3.1.
      >
      > >> I doubt it since you're not actually using Xcode to compile the Vim
      > >> binary.  The problem is most likely the Python 3.0 that you installed
      > >> and somehow it is pulling the wrong library version when you try to
      > >> compile.
      >
      > > Oh sorry, I didn't mean my Xcode version directly but versions of
      > > software like gcc, autoconf and so.
      >
      > > Here's my export, although I don't see any relevant line... you should
      > > know better :)
      >
      > Hmmm...no I don't see anything in there either.  Could you by any
      > chance try to uninstall Python 3.0 to see if that eliminates the
      > problem (unless that is too much of a hassle)?
      >
      > Otherwise maybe somebody else could weigh in on this issue?  I am not
      > really the right person to answer these types of questions I'm afraid.
      > :-/
      >
      > Björn
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • dacresni
      is the build script in the git repo? ... --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more
      Message 2 of 11 , Mar 4, 2009
        is the build script in the git repo?

        On Mar 3, 5:03 pm, expora <exp...@...> wrote:
        > Thank you for your help Björn.
        >
        > I think I'm going to try uninstalling Python 3.0 as a last resort
        > because right now I'm trying to learn the differences between python
        > 2.5 and 3.0. The past MacVim snapshot hasn't given me any problems so
        > I'll use it for a while before building again.
        >
        > Thanks!
        >
        > Edwin.
        >
        > On Mar 3, 3:59 pm, björn <bjorn.winck...@...> wrote:
        >
        > > 2009/3/3 expora:
        >
        > > >> > Do you think my Xcode version has to do with this? I'm using 3.1.
        >
        > > >> I doubt it since you're not actually using Xcode to compile the Vim
        > > >> binary.  The problem is most likely the Python 3.0 that you installed
        > > >> and somehow it is pulling the wrong library version when you try to
        > > >> compile.
        >
        > > > Oh sorry, I didn't mean my Xcode version directly but versions of
        > > > software like gcc, autoconf and so.
        >
        > > > Here's my export, although I don't see any relevant line... you should
        > > > know better :)
        >
        > > Hmmm...no I don't see anything in there either.  Could you by any
        > > chance try to uninstall Python 3.0 to see if that eliminates the
        > > problem (unless that is too much of a hassle)?
        >
        > > Otherwise maybe somebody else could weigh in on this issue?  I am not
        > > really the right person to answer these types of questions I'm afraid.
        > > :-/
        >
        > > Björn
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • expora
        It seems I ve got it... The problem appeared to be with my Python 3.0 installation, indeed. I found two dirs for the Python framework: A)
        Message 3 of 11 , Mar 18, 2009
          It seems I've got it...

          The problem appeared to be with my Python 3.0 installation, indeed.
          I found two dirs for the Python framework:

          A) /System/Library/Frameworks/Python.framework/Versions
          Contains dirs 2.3, 2.5 and a symlink to 2.5 named Current.

          B) /Library/Frameworks/Python.framework/Versions
          Contains dir 3.0 and a symlink "Current" pointing to 3.0.

          So I tried changing the "Current" symlink in location B to point to
          dir "2.5" in location A and...

          ** BUILD SUCCEEDED **

          I hope I'm not breaking anything :)

          Cheers,

          On 3 mar, 15:59, björn <bjorn.winck...@...> wrote:
          > 2009/3/3 expora:
          >
          >
          >
          > >> > Do you think my Xcode version has to do with this? I'm using 3.1.
          >
          > >> I doubt it since you're not actually using Xcode to compile the Vim
          > >> binary.  The problem is most likely the Python 3.0 that you installed
          > >> and somehow it is pulling the wrong library version when you try to
          > >> compile.
          >
          > > Oh sorry, I didn't mean my Xcode version directly but versions of
          > > software like gcc, autoconf and so.
          >
          > > Here's my export, although I don't see any relevant line... you should
          > > know better :)
          >
          > Hmmm...no I don't see anything in there either.  Could you by any
          > chance try to uninstall Python 3.0 to see if that eliminates the
          > problem (unless that is too much of a hassle)?
          >
          > Otherwise maybe somebody else could weigh in on this issue?  I am not
          > really the right person to answer these types of questions I'm afraid.
          > :-/
          >
          > Björn
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.