Loading ...
Sorry, an error occurred while loading the content.

9369Re: Dynamically loading Python library

Expand Messages
  • George V. Reilly
    Nov 2, 2008
      2008/11/1 Jason Foreman <jason@...>:
      > On Nov 1, 2008, at 11:57 AM, björn wrote:
      >> How is this solved on Windows?
      >
      > I believe you must have installed the version of Python that your Vim
      > distribution was built with. For standard builds I think this is 2.3.
      > Cream builds use 2.5 or maybe 2.4. I can verify this on Monday at work.

      This is certainly correct for the Visual C++ build, Make_mvc.mak, and
      seems to be true of the MinGW build too.

      Try asking on http://mail.python.org/mailman/listinfo/capi-sig. That's
      where the experts on embedding Python hang out.

      If Python is dynamically loaded, then people running Python 2.3 on
      Tiger don't pay any cost until they use :python. I'm inclined to think
      that most people who want to use :python have Python 2.5 or 2.6
      installed.
      --
      /George V. Reilly george@...
      http://www.georgevreilly.com/blog http://blogs.cozi.com/tech

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Show all 15 messages in this topic