Loading ...
Sorry, an error occurred while loading the content.

608Re: Compiling vim 5.8.9 under non-carbon environment

Expand Messages
  • Mac Vim Support (Axel Kielhorn)
    Jun 4, 2002
    • 0 Attachment
      At 15:48 Uhr +0900 2002-05-30, Kenichi Asai wrote:
      >Dear vim-mac experts,
      >
      >I am trying to compile vim 5.8 (with patches 5.8.0 to 5.8.9) using
      >CodeWarrior Professional release 5 on PowerBook G3 with MacOS 8.1.
      >(I am trying to make the last version of *multibyte* vim before 6.0.)

      I have just checked, I can build 5.8 with CW Pro2 without problems.
      I will get the patches to 5.8.9 and try that as well.

      But this is probably not your problem.
      You need recent Universal Header definitons from Apple.
      I'm using 3.4 from the Carbon SDK.

      In my defs.h file I have:

      /* Dummy defs.h */
      /* Define if you have the strftime() function. */
      #define HAVE_STRFTIME


      /* Don't use old names */
      #define OLDROUTINENAMES 0

      /* Compile Carbon Application */
      #define TARGET_API_MAC_CARBON 0

      /* compile MacOS Application */
      #define TARGET_API_MAC_OS8 1

      which definetly builds a Classic Vim.

      Axel
    • Show all 3 messages in this topic