Loading ...
Sorry, an error occurred while loading the content.

13460Cannot run MacVim built with Xcode 4.5 on OS X 10.7.5

Expand Messages
  • George V. Reilly
    Nov 4 12:00 AM
    • 0 Attachment
      I have successfully built MacVim many times in the past from source.
      I am no longer able to do so.

      When I run the MacVim.app that I've built, it starts up,
      but no Vim window opens.
      If I do ⌘N, nothing happens.
      When I do ⌘Q, I get a dialog telling me that
      there are two open windows in MacVim.
      Removing my ~/.vim and ~/.vimrc
      (because I don't know how to run -u NONE),
      doesn't help.

      I'm running Xcode 4.5 (4G182) on OS X 10.7.5 on one machine,
      and Xcode 4.5.1 (4G1004) on 10.7.5 on another.
      I've installed the latest command-line tools via
      Xcode's Preferences > Downloads.

      I tried running MacVim.app under the Xcode debugger.
      Once, after pausing at a breakpoint in main() for a while,
      I actually saw the Vim window open.
      Unfortunately, I know nothing about Xcode, Objective-C, Cocoa,
      or the innards of MacVim,
      so I'm at a loss to go any further.

      I've attached a log of all the configure and make output.

      BTW, the MacVim repo is about 60 patches behind Vim.
      /George V. Reilly george@... Twitter: @georgevreilly
      http://www.georgevreilly.com/blog http://blogs.cozi.com/tech

      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 7 messages in this topic