Loading ...
Sorry, an error occurred while loading the content.

12947Re: no .vimrc when "Open with..."

Expand Messages
  • MacVlad
    Dec 6, 2011
      Hello again, Björn!


      I have to correct something: the .vimrc seems to work only when I open
      a file in a new tab (SHIFT-CMD-T) after MacVim was open with a new
      file.
      While opening through "Open with" or via CMD-O (after MacVim was open
      with a new file), my .vimrc seems not to be used anymore.

      Does this make more sense?

      Thanks again!


      Kind regards,
      Vlad Ghitulescu



      On 2 Dez., 18:14, björn <bjorn.winck...@...> wrote:
      > On 30 November 2011 19:28, MacVlad wrote:
      >
      >
      >
      > > I am using MacVim (snapshot 62) on my iMac 3.06 GHz Intel Core 2 Duo
      > > running Mac OS X 10.7.2.
      >
      > > Every time I open a file via the "Open with..." - context-menu from
      > > finder, my ~/.vimrc is NOT used.
      > > Not so when I open first MacVim and then the file (with "File - Open"
      > > or CMD-O).
      >
      > > Do you have any advice what could I do in order to have the .vimrc
      > > used with "Open with..." too?
      >
      > It should always source the ~/.vimrc.  What steps did you take in
      > order to come to the conclusion that it isn't being sourced?
      >
      > Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 6 messages in this topic