Loading ...
Sorry, an error occurred while loading the content.

smil with text tracks - sometimes not displaying until you rew to start of movie and playback?

Expand Messages
  • Kathy O'Donnell
    hiya, hoping someone might be able to point out a quirk I m seeing with quicktime & smil movies. I tried out Andreas Linukbator and then read some of the
    Message 1 of 1 , Jan 1, 2006
    • 0 Attachment
      hiya, hoping someone might be able to point out a quirk I'm seeing with quicktime & smil movies. I tried out Andreas' Linukbator and then read some of the quicktime docos & modified the file so it links to a couple of movies and audio and has some text (+ the bug from linkubator). I'm just testing at the moment to see how it works, but I don't know if it's just because I'm cached.. but sometimes the text just displays the text region rectangle with no text, but then if you reverse back to the start of the movie and hit play again it works. same thing happens when it changes text part way through the movie, if u rewind and play it comes good. has anyone else seen this? and is there a workaround? I've tried clearing my cache but it still does it. http://www.aliak.com/files/smile.mov has the problem (or see code below) if u have time/interest to take a look. (don't worry about the content, just testing atm)

      thanks for your help
      Kath

      =================================================================================================
      SMILtext<smil xmlns:qt=" http://www.apple.com/quicktime/resources/smilextensions" qt:autoplay="false" qt:time-slider="true" qt:immediate-instantiation="true">
          <head>
              <layout>

              <root-layout id="main" width="320" height="240" background-color="black" />

                      <region id="movie" width="309" height="206" />
              <region id="bug" width="24" height="24" left="296" top="216"  fit="meet" />
              <region id="txt" width="294" height="20" left="10" top="212" />
              </layout>
          </head>

          <body>


          <par>
              <audio src="http://www.aliak.com/mp3/big_banana_switch_vs_mcguyver.mp3 " id="song" end="54sec" />

              <video id="vid1" region="movie" src="http://www.archive.org/download/Bangalore_sport/bangalore_sport.mov " begin="0sec" end="34sec" />

              <text region="txt" src="data:text/plain,rush,rush,hurry,hurry" begin="2sec"end="id(vid1)(end)" />       
             
              <a href="http://www.aliak.com" show="new" qt:target="_blank">
                  <img src="data:image/gif;base64,R0lGODlhGAAYALMAAN3d3Xd3d1VVVaqqqu7u7hERESIiIkRERLu7u4iIiDMzM8zMzGZmZpmZmQAAAP///yH5BAAAAAAALAAAAAAYABgAAATI8Mk5UbqpAco5YE4ohkbTccnoHIcxKsv5gKEwPAgCAInrFDEOrYB4EBQiE2EYlKQchuAzVJg8DQQJofBrTkMUWsIZGk8A3FCAQnAVssiq52JChW4hRofFqp/LCCF+EyNmFC4HgQ5FHIV7K4qMFI4cB5BlHZQUXAcPNZkihhILmJYOWZOhHAEhRQ1qjapnXAYTPoOaR4IVVDcSlAQCIZ0Ur5ieqgtIDgqoxSIGAQcXDAzCIc0yCD4qIwHOMg2mIwYMGzInOTnnJxEAOw==" region="bug" begin="0sec" end="54sec" />
              </a>

              <video id="vid2" region="movie" src="http://www.archive.org/download/colours_of_Auckland/20051227_colours_of_auckland_320x240.mov " begin="31sec" end="54sec" />

                  <a href="http://www.aliak.com/blog/" show="new" >
                        <text region="txt" src="data:text/plain,slow right down" begin="35sec" end="54sec" />
                  </a>

          </par>
          </body>
      </smil>

      ================================================================================================================





















      --
      http://www.aliak.com
    Your message has been successfully submitted and would be delivered to recipients shortly.