Loading ...
Sorry, an error occurred while loading the content.
 

[madduck@debian.org: Bug#520895: does not escape comma in filenames when adding ignore pattern]

Expand Messages
  • martin f krafft
    Forwarding another bug report from http://bugs.debian.org/520895 : Package: unison Version: 2.27.57-2 Severity: normal Tags: upstream When I tell unison to
    Message 1 of 2 , Mar 23, 2009
      Forwarding another bug report from http://bugs.debian.org/520895 :

      Package: unison
      Version: 2.27.57-2
      Severity: normal
      Tags: upstream

      When I tell unison to ignore a file whose name has a comma in it,
      then unison adds to the preferences file a line like:

      ignore = Path{this file, has a comma}

      which gets interpreted as "this file" OR " has a comma".

      unison should be escaping that comma and write it as \, instead.

      -- System Information:
      Debian Release: squeeze/sid
      APT prefers unstable
      APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
      Architecture: amd64 (x86_64)

      Kernel: Linux 2.6.26-1-amd64 (SMP w/1 CPU core)
      Locale: LANG=en_GB, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
      Shell: /bin/sh linked to /bin/dash

      Versions of packages unison depends on:
      ii libc6 2.9-6 GNU C Library: Shared libraries

      Versions of packages unison recommends:
      ii openssh-client [ssh-client] 1:5.1p1-5 secure shell client, an rlogin/rsh

      unison suggests no packages.

      -- no debconf information

      --
      .''`. martin f. krafft <madduck@d.o> Related projects:
      : :' : proud Debian developer http://debiansystem.info
      `. `'` http://people.debian.org/~madduck http://vcs-pkg.org
      `- Debian - when you have better things to do than fixing systems
    • Benjamin Pierce
      I agree that this would be useful. I ve added it to the TODO list, but no promises about when it will happen (in general, things like this get done when
      Message 2 of 2 , Mar 23, 2009
        I agree that this would be useful. I've added it to the TODO list,
        but no promises about when it will happen (in general, things like
        this get done when someone feels the itch badly enough to contribute a
        patch).

        Best,

        Benjamin


        On Mar 23, 2009, at 8:30 AM, martin f krafft wrote:

        > When I tell unison to ignore a file whose name has a comma in it,
        > then unison adds to the preferences file a line like:
        >
        > ignore = Path{this file, has a comma}
        >
        > which gets interpreted as "this file" OR " has a comma".
        >
        > unison should be escaping that comma and write it as \, instead.
      Your message has been successfully submitted and would be delivered to recipients shortly.