Loading ...
Sorry, an error occurred while loading the content.
 

Disconnection after 3-5 min

Expand Messages
  • chiqui.mman
    Hi everyone, I installed twinkle 1.4.2 in ubuntu 9.10 I m having 2 problems, the first one is that after I start Twinkle, I only have around 5 min so people
    Message 1 of 4 , Mar 2, 2010
      Hi everyone, I installed twinkle 1.4.2 in ubuntu 9.10

      I'm having 2 problems,
      the first one is that after I start Twinkle, I only have around 5 min so people can call me, afterthat I don't receive any calls at all. Is there any specific value I have to change??

      the second problem, is a most common error: choppy sound when I call someone. The choppiness :P comes from the one I'm calling to twinkle.

      I get this in the DEBUG you can see there are som packet lost:

      +++ 2-3-2010 13:42:17.278985 DEBUG NORMAL t_alsa_io::write
      Playback buffer underrun.
      ---

      +++ 2-3-2010 13:42:17.377531 DEBUG NORMAL t_audio_tx::run
      Audio tx line 1: 1 RTP packets lost.
      ---

      +++ 2-3-2010 13:42:17.377594 DEBUG NORMAL t_alsa_io::write
      Playback buffer underrun.

      thanks in advanced :D
    • Iñaki Baz Castillo
      ... This is too much generic to give you a response. If you are behind NAT your provider must mantain the NAT keepalive by sending you some SIP method (as
      Message 2 of 4 , Mar 4, 2010
        El Martes, 2 de Marzo de 2010, chiqui.mman escribió:
        > Hi everyone, I installed twinkle 1.4.2 in ubuntu 9.10
        >
        > I'm having 2 problems,
        > the first one is that after I start Twinkle, I only have around 5 min so
        > people can call me, afterthat I don't receive any calls at all. Is there
        > any specific value I have to change??

        This is too much generic to give you a response.
        If you are behind NAT your provider must mantain the NAT keepalive by sending
        you some SIP method (as OPTIONS, INFO...).
        You can also enable STUN in Twinkle (if you are not under a symmetric NAT
        router in which STUN protocol doesn't work), so Twinkle would mantain the NAT
        keepalive by itself.


        --
        Iñaki Baz Castillo <ibc@...>
      • chiqui.mman
        ... The first problem I solved it with checking the box, NAT keep alive. It works now. But the problem with the choppy audio, I can t solve it. It misses or
        Message 3 of 4 , Mar 14, 2010
          --- In twinklephone@yahoogroups.com, Iñaki Baz Castillo <ibc@...> wrote:
          >
          > El Martes, 2 de Marzo de 2010, chiqui.mman escribió:
          > > Hi everyone, I installed twinkle 1.4.2 in ubuntu 9.10
          > >
          > > I'm having 2 problems,
          > > the first one is that after I start Twinkle, I only have around 5 min so
          > > people can call me, afterthat I don't receive any calls at all. Is there
          > > any specific value I have to change??
          >
          > This is too much generic to give you a response.
          > If you are behind NAT your provider must mantain the NAT keepalive by sending
          > you some SIP method (as OPTIONS, INFO...).
          > You can also enable STUN in Twinkle (if you are not under a symmetric NAT
          > router in which STUN protocol doesn't work), so Twinkle would mantain the NAT
          > keepalive by itself.
          >
          >
          > --
          > Iñaki Baz Castillo <ibc@...>
          >

          The first problem I solved it with checking the box, NAT keep alive. It works now. But the problem with the choppy audio, I can't solve it. It misses or skips some packages so the audio gets choppy. Any idea or which info should I post?

          thanks!
        • zrtp_cpp
          ... Which soundsystem do you use or selected in twinkle? ALSA? I had some problems with ALSA using default output. Switching to dmix solved this mostly (also
          Message 4 of 4 , Mar 20, 2010
            --- In twinklephone@yahoogroups.com, "chiqui.mman" <chiqui.mman@...> wrote:
            >
            >
            >
            > --- In twinklephone@yahoogroups.com, I�aki Baz Castillo <ibc@> wrote:
            > >
            > > El Martes, 2 de Marzo de 2010, chiqui.mman escribi�:
            > > > Hi everyone, I installed twinkle 1.4.2 in ubuntu 9.10
            > > >
            > > > I'm having 2 problems,
            > > > the first one is that after I start Twinkle, I only have around 5 min so
            > > > people can call me, afterthat I don't receive any calls at all. Is there
            > > > any specific value I have to change??
            > >
            > > This is too much generic to give you a response.
            > > If you are behind NAT your provider must mantain the NAT keepalive by sending
            > > you some SIP method (as OPTIONS, INFO...).
            > > You can also enable STUN in Twinkle (if you are not under a symmetric NAT
            > > router in which STUN protocol doesn't work), so Twinkle would mantain the NAT
            > > keepalive by itself.
            > >
            > >
            > > --
            > > I�aki Baz Castillo <ibc@>
            > >
            >
            > The first problem I solved it with checking the box, NAT keep alive. It works now. But the problem with the choppy audio, I can't solve it. It misses or skips some packages so the audio gets choppy. Any idea or which info should I post?
            >
            > thanks!
            >

            Which soundsystem do you use or selected in twinkle? ALSA? I had
            some problems with ALSA using "default" output. Switching to dmix
            solved this mostly (also depends on the soundcard/driver combo you use).

            Regards,
            Werner
          Your message has been successfully submitted and would be delivered to recipients shortly.