Loading ...
Sorry, an error occurred while loading the content.

Bluetooth and alsa question

Expand Messages
  • daveschile
    Hello, I m having the hardest time getting my bluetooth headset to work with Twinkle. I d like the ringtone to come from the system speakers, but the phone
    Message 1 of 3 , Dec 31, 2008
    • 0 Attachment
      Hello,
      I'm having the hardest time getting my bluetooth headset to work with
      Twinkle. I'd like the ringtone to come from the system speakers, but
      the phone speaker and the mic to come from the bluetooth headset. I
      have the headset connected, and the settings in Twinkle -> System
      Settings -> Audio to be:
      Ringtone: Alsa default device
      Speaker: Alsa other device / bluetooth
      Microphone Alsa other device / bluetooth

      The problem is when a call comes in Twinkle can't access the alsa
      default device for the ringtone. The call goes on, and I get audio on
      the bluetooth headset, but no ringtone. The error is this:

      Critical: Opening ALSA driver failed: snd_pcm_hw_params_set_rate(8287)
      failed: Invalid argument

      Then it sends this poorly worded warning:
      Warning: Failed to open sound card: Success

      If anyone has any ideas about this I'd be very happy. Thanks.

      I'm running Debian on a 2.6.26 kernel. Twinkle is version 1.2 09
      March 2008

      Thanks,
      Dave
    • AdonusX
      twinkle doesn t seem to like sharing audio ports... what else do you have going through those speakser at the time a call comes in?
      Message 2 of 3 , Jan 1, 2009
      • 0 Attachment

        twinkle doesn't seem to like sharing audio ports... what else do you have going through those speakser at the time a call comes in?
      • daveschile
        I think I solved this problem. It seems to have little to do with alsa and the error I got about setting the pcm rate. In my testing I was using twinkle to
        Message 3 of 3 , Jan 1, 2009
        • 0 Attachment
          I think I solved this problem. It seems to have little to do with alsa
          and the error I got about setting the pcm rate. In my testing I was
          using twinkle to call itself. While the call went through on my
          bluetooth headset, the ringer (pc speakers) didn't work. Thanks for
          your response.


          --- In twinklephone@yahoogroups.com, AdonusX <AdonusX@...> wrote:
          >
          > twinkle doesn't seem to like sharing audio ports... what else do you
          have
          > going through those speakser at the time a call comes in?
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.