Loading ...
Sorry, an error occurred while loading the content.
 

Getting Library requirements (libccrtp1 >= 1.6.0)

Expand Messages
  • Amit
    Hi Guys, I am trying to install Twinkle 1.3.2 on my FC8 however I get bellow said error when I do .configure checking for commoncpp2 version = 1.6.0... yes
    Message 1 of 2 , Dec 2, 2008
      Hi Guys,

      I am trying to install Twinkle 1.3.2 on my FC8 however I get bellow
      said error when I do .configure

      checking for commoncpp2 version >= 1.6.0... yes
      checking for pkg-config... /usr/bin/pkg-config
      checking for libccrtp1 >= 1.6.0... Requested 'libccrtp1 >= 1.6.0' but
      version of libccrtp1 is 1.5.0
      configure: error: Library requirements (libccrtp1 >= 1.6.0) not met;
      consider adjusting the PKG_CONFIG_PATH environment variable if your
      libraries are in a nonstandard prefix so pkg-config can find them.


      I checked for latest libzrtpcpp and I have it

      [root@localhost libzrtpcpp-1.3.0]# rpm -qa | grep libzrtpcpp
      libzrtpcpp-1.3.0-2.fc8
      libzrtpcpp-devel-1.3.0-2.fc8

      Am I missing something? Any help is highly appreciated. Thxs in advance
    • Iñaki Baz Castillo
      ... The warning/error is about libccrtp1, not about libzrtpcpp. You can always install the library from the sources (the link appears in twinklephone.com page
      Message 2 of 2 , Dec 2, 2008
        2008/12/2 Amit <amii_2009@...>:
        > Hi Guys,
        >
        > I am trying to install Twinkle 1.3.2 on my FC8 however I get bellow
        > said error when I do .configure
        >
        > checking for commoncpp2 version >= 1.6.0... yes
        > checking for pkg-config... /usr/bin/pkg-config
        > checking for libccrtp1 >= 1.6.0... Requested 'libccrtp1 >= 1.6.0' but
        > version of libccrtp1 is 1.5.0
        > configure: error: Library requirements (libccrtp1 >= 1.6.0) not met;
        > consider adjusting the PKG_CONFIG_PATH environment variable if your
        > libraries are in a nonstandard prefix so pkg-config can find them.
        >
        >
        > I checked for latest libzrtpcpp and I have it
        >
        > [root@localhost libzrtpcpp-1.3.0]# rpm -qa | grep libzrtpcpp
        > libzrtpcpp-1.3.0-2.fc8
        > libzrtpcpp-devel-1.3.0-2.fc8
        >
        > Am I missing something? Any help is highly appreciated. Thxs in advance

        The warning/error is about libccrtp1, not about libzrtpcpp.
        You can always install the library from the sources (the link appears
        in twinklephone.com page in download section).


        --
        Iñaki Baz Castillo
        <ibc@...>
      Your message has been successfully submitted and would be delivered to recipients shortly.