Loading ...
Sorry, an error occurred while loading the content.

twinkle: Failed to open sound card

Expand Messages
  • sasikala kala
    hi, In my twinkle , oftenly I am getting the message as , Warning: Failed to open sound card: Device or resource busy . At this time I havent accessed any
    Message 1 of 9 , Apr 2 1:35 AM
    • 0 Attachment
      hi,
           In my twinkle , oftenly I am getting the message as ,
      "Warning: Failed to open sound card: Device or resource busy".
      At this time I havent accessed any other sound application.
      I think the sound card is not getting freed some times. Please check this,
      and help to solve this.

      regards
      sasikala.


      TV dinner still cooling?
      Check out "Tonight's Picks" on Yahoo! TV.
    • joerg.greoj
      twinkle does not occupy the audio device (since 0.4 at least). probably your audio setup is faulty. disable your KDE-event sounds. change device used for KDE
      Message 2 of 9 , Apr 2 3:09 AM
      • 0 Attachment
        twinkle does not occupy the audio device (since 0.4 at least).
        probably your audio setup is faulty.

        disable your KDE-event sounds.
        change device used for KDE audio notification (to dmix).
        use ALSA device in twinkle; change this device to dmix.


        please: what do you think how anybody should reproduce your problems
        with this few detail about your configuration???

        <a href="http://catb.org/esr/faqs/smart-questions.html">please look
        here!</a>

        also please study <a
        href="http://tech.groups.yahoo.com/group/twinklephone/message/897">this
        thread (ending msg 897)</a> e.g.

        j
      • joerg.greoj
        btw: you´re constantly reporting errors more or less related to suspected parallel running of multiple instances of twinkle. Lockfile; port5060; audio;
        Message 3 of 9 , Apr 2 5:28 AM
        • 0 Attachment
          btw: you´re constantly reporting "errors" more or less related to
          suspected parallel running of multiple instances of twinkle.
          Lockfile; port5060; audio; whatever...
          Are you sure there is no BIG bummer on your systems' setup, or even
          in concept? E.g. _nobody_ needs to delete lockfile in a twinkle
          startscript unconditionally. It simply shouldn't be there - except
          from when erratically DOUBLEclicking the icon or pulling the mains
          plug.
          I really wonder which distro you're using, and what exactly you're
          trying to build there.

          cheers
          jOERG
        • sasikala kala
          hi, Thanks for your link to ask the question in a smarter way. I will explain my configuration. - I will launch the twinkle through the icon. As a end user
          Message 4 of 9 , Apr 2 9:18 PM
          • 0 Attachment
            hi,
                Thanks for your link to ask the question in a smarter way.

            I will explain my configuration.

            - I will launch the twinkle through the icon. As a end user they click the icon any number of times. At that time there is no time gap between the first click and the second click. so the lock file wont get removed, so it will
            say Twinkle is already running. This is the problem I faced earlier. Then I installed twinkle1.0 and used --force option. Then also rarely this error has come. ( if there is a gap between first and next click then there is no problem at all ).
            -  As a user , we should not see any errors while launching. So that  I have changed the launching procedure, I have given sleep for every launch.
            At the second click , it will  sleep for 1 sec and then try to launch the twinkle. At the third click , 2 sec it will sleep and tried to launch the twinkle.
            - This is the procedure I am following now.
            - Now I am facing one more problem is that. while the call comes, it is saying that Failed to Open Sound card, device is busy.
            - My settings are

            System settings -> Audio -> ALSA:plughW:0,1:VIA 8237(VIA 8237).
            Why I have given this is , this is the Audio controller in my system.
            I am using linux os. I have given a command lspci which list all pci devices. there
            Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60).
            So that I have choosen this in the Audio.
            - I tried with ALSA default device also , there also I am facing the same problem. it will work fine, when the call comes, it will say the error.
            - If I relaunches the twinkle , then it will get solved. It wont say error.
            - This is my problem. If you need more information on this I will surely give to you.

            Thanks in Advance.


            "joerg.greoj" <joerg.twinklephone@...> wrote:
            twinkle does not occupy the audio device (since 0.4 at least).
            probably your audio setup is faulty.

            disable your KDE-event sounds.
            change device used for KDE audio notification (to dmix).
            use ALSA device in twinkle; change this device to dmix.

            please: what do you think how anybody should reproduce your problems
            with this few detail about your configuration? ??

            <a href="http://catb. org/esr/faqs/ smart-questions. html">please look
            here!</a>

            also please study <a
            href="http://tech. groups.yahoo. com/group/ twinklephone/ message/897">this
            thread (ending msg 897)</a> e.g.

            j



            Don't be flakey. Get Yahoo! Mail for Mobile and
            always stay connected to friends.

          • Chris Davies
            ... But Twinkle (by then) will *already* be running (from the first click). You really need to try to educate your users not to double click, but to click just
            Message 5 of 9 , Apr 3 3:32 AM
            • 0 Attachment
              sasikala kala wrote:
              > - I will launch the twinkle through the icon. As a end user they click
              > the icon any number of times. At that time there is no time gap between
              > the first click and the second click. so the lock file wont get removed,
              > so it will say Twinkle is already running.

              But Twinkle (by then) will *already* be running (from the first click). You
              really need to try to educate your users not to double click, but to click just
              once to start a program.

              You could associating your Twinkle icon with the attached script, but I doubt it
              will run fast enough to catch a double click.

              Chris
            • Andrew Myers
              You really need to sit back an analyse exactly what you want to do. If you are running twinkle as a server , with many users taking control of it from time to
              Message 6 of 9 , Apr 3 4:54 AM
              • 0 Attachment
                You really need to sit back an analyse exactly what you want to do.

                If you are running twinkle as a "server", with many users taking control of it from time to time, you may need to consider:

                checking whether twinkle is already running.
                finding out who the process is allocated to.
                checking whether they are actually using twinkle at the moment that the icon is clicked (else you will cut them off in the middle of a call).
                closing twinkle if it is open but unused.
                restarting twinkle and allocating the process to the new user.

                (on a double click of the icon, you can then ignore any extra clicks since you can see that twinkle is running and allocated to the correct user.)

                I am sure there are plenty of people who would be glad to help if you could explain in detail exactly what you are trying to do. The main question being; do you have one machine used by a number of people, or do you have several people connecting over a network to the one machine?

                All the best


                Andrew




                sasikala kala wrote:

                hi,
                    Thanks for your link to ask the question in a smarter way.

                I will explain my configuration.

                - I will launch the twinkle through the icon. As a end user they click the icon any number of times. At that time there is no time gap between the first click and the second click. so the lock file wont get removed, so it will
                say Twinkle is already running. This is the problem I faced earlier. Then I installed twinkle1.0 and used --force option. Then also rarely this error has come. ( if there is a gap between first and next click then there is no problem at all ).
                -  As a user , we should not see any errors while launching. So that  I have changed the launching procedure, I have given sleep for every launch.
                At the second click , it will  sleep for 1 sec and then try to launch the twinkle. At the third click , 2 sec it will sleep and tried to launch the twinkle.
                - This is the procedure I am following now.
                - Now I am facing one more problem is that. while the call comes, it is saying that Failed to Open Sound card, device is busy.
                - My settings are

                System settings -> Audio -> ALSA:plughW: 0,1:VIA 8237(VIA 8237).
                Why I have given this is , this is the Audio controller in my system.
                I am using linux os. I have given a command lspci which list all pci devices. there
                Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/ 8237 AC97 Audio Controller (rev 60).
                So that I have choosen this in the Audio.
                - I tried with ALSA default device also , there also I am facing the same problem. it will work fine, when the call comes, it will say the error.
                - If I relaunches the twinkle , then it will get solved. It wont say error.
                - This is my problem. If you need more information on this I will surely give to you.

                Thanks in Advance.


                "joerg.greoj" <joerg.twinklephone@ gmx.de> wrote:

                twinkle does not occupy the audio device (since 0.4 at least).
                probably your audio setup is faulty.

                disable your KDE-event sounds.
                change device used for KDE audio notification (to dmix).
                use ALSA device in twinkle; change this device to dmix.

                please: what do you think how anybody should reproduce your problems
                with this few detail about your configuration? ??

                <a href="http://catb. org/esr/faqs/ smart-questions. html">please look
                here!</a>

                also please study <a
                href="http://tech. groups.yahoo. com/group/ twinklephone/ message/897">this
                thread (ending msg 897)</a> e.g.

                j



                Don't be flakey. Get Yahoo! Mail for Mobile and
                always stay connected to friends.
              • joerg.greoj
                ... And right so! It *IS* running already. this warning doesn t mean please delete some lockfile, kill me and do other weird things... , no it simply means
                Message 7 of 9 , Apr 3 5:22 AM
                • 0 Attachment
                  --- In twinklephone@yahoogroups.com, sasikala kala
                  <sasi_jeyalakshmi@...> wrote:
                  > As a end user they click the icon any number of times. At that
                  > time there is no time gap between the first click and the second
                  > click. so the lock file wont get removed, so it will
                  > say Twinkle is already running.

                  And right so! It *IS* running already.
                  this warning doesn't mean "please delete some lockfile, kill me and
                  do other weird things...", no it simply means "hey user! twinkle IS
                  started! You're not supposed to start it another time."

                  So please
                  DON'T delete twinkle.lock (you might do this while system boot)
                  DON'T kill twinkle
                  DON'T use the --force option! (it´s kind of a hacker thing, not an
                  everyday user option. It's just nonsense to force twinkle to start
                  double)
                  You may use the script of previous poster (with some small
                  modifications; more of this later)
                  - or (i suppose) you just stay calm and wait for next release of
                  twinkle, when Michel will implement an improved handling of
                  "lockfile" and popup twinkle instead of warning when started twice.

                  > - As a user , we should not see any errors while launching.
                  if user is in error (starting twice) she should be told. It's simply
                  not the right way to handle KDE/twinkle




                  > - Now I am facing one more problem is that. while the call comes,
                  > it is saying that Failed to Open Sound card, device is busy.
                  Please cleanup and fix the above issue, discard your startscript.
                  Educate users. Don't kill twinkle!
                  If the audio problem persists: uncheck
                  [system]-[audio]-[_]"check_audio_settings", there´s a flaw in this
                  function in 1.0 which indeed could cause problems with some audio
                  devs.

                  if audio problem _still_ there: come back here with report

                  cheers
                  jOERG
                • joerg.greoj
                  because the file vanished on web frontend, and to implement a small improvement: #!/bin/sh # TPID=`cat $HOME/.twinkle/twinkle.lck 2 /dev/null` if test -n
                  Message 8 of 9 , Apr 3 5:37 AM
                  • 0 Attachment
                    because the file vanished on web frontend, and to implement a small
                    improvement:

                    #!/bin/sh
                    #
                    TPID=`cat "$HOME/.twinkle/twinkle.lck" 2>/dev/null`

                    if test -n "$TPID"
                    then
                    # Lock file exists. Check the PID
                    #
                    WHOAMI="${USER:-`whoami`}"

                    PS=`
                    ( test -n "$WHOAMI" && ps -u "$WHOAMI" || ps -e ) |
                    awk '$1 == "'"$TPID"'" && $4 ~ /twinkle/ {print $0}'
                    `

                    # Process is no longer running
                    #jr: ...so we could as well delete lockfile here,
                    #jr: or we --force what's the same
                    #
                    test -z "$PS" && TPID=
                    fi

                    if test -z "$TPID"
                    then
                    # Start twinkle
                    #
                    test -t 2 && echo "Starting twinkle" >&2
                    #jr: ...we know twinkle NOT running,
                    #jr: so here use the --force option the only way it makes sense
                    twinkle --force "$@"
                    else
                    test -t 2 && echo "Twinkle already running (PID $TPID)" >&2
                    fi


                    # All done
                    #
                    exit 0
                  • joerg
                    ... you may consider starting twinkle in autostart folder, so this might enable discarding the obviously too tempting twinkle start icon from desktop and
                    Message 9 of 9 , Apr 4 4:23 PM
                    • 0 Attachment
                      > - I will launch the twinkle through the icon.
                      you may consider starting twinkle in "autostart" folder, so this might enable
                      discarding the obviously too tempting twinkle start icon from desktop and
                      taskbar.
                      (btw: I have a command like `sleep 120; twinkle` there in autostart to allow
                      the network to establish before twinkle comes up)

                      > As a end user they click the icon any number of times.
                      You should provide the nice icon in systray for them. on this they can click
                      any number of times.
                      [edit]-[system settings...]-[General]
                      - - [X]'Create system tray icon on startup'
                      - - [X]'Hide in system tray when closing main window'

                      > At that time there is no time gap between the
                      > first click and the second click. so the lock file wont get removed,
                      the lockfile is supposed to stay there _as _long_ as twinkle is running, so
                      that a second instance of twinkle started inadvertent can know and tell user
                      he did sth wrong (and to avoid other problems with 2 twinkles sharing ports,
                      concurrent editing config files etc pp).
                      i don't see why it should be removed here _any_ time

                      > so it
                      > will say Twinkle is already running. This is the problem I faced earlier.
                      There is no problem. Everything completely correct. Changing anything here
                      will create problems.

                      > Then I installed twinkle1.0 and used --force option.
                      This option is supposed to be used for very special purposes like recovering
                      from a system crash(!), when twinkle wasn't able to remove it's lock file
                      while normal program termination. It mustn't be used for ordinary everyday
                      program start of twinkle.

                      > Then also rarely this
                      > error has come. ( if there is a gap between first and next click then there
                      > is no problem at all ).
                      You don't see them now maybe, but believe me there are a few

                      > - As a user , we should not see any errors while
                      > launching.
                      ...we should not *make* any errors... so we don't see any ;-)
                      > So that I have changed the launching procedure, I have given
                      > sleep for every launch. At the second click , it will sleep for 1 sec and
                      > then try to launch the twinkle. At the third click , 2 sec it will sleep
                      > and tried to launch the twinkle.
                      i wonder HOW you programmed THAT. How does "second" click know it's the second
                      click? Do you check for some file you remember the first click in (the way
                      twinkle does with it's lock file)?
                      Why do you put a sec of sleep in there instead of simply refusing to start
                      twinkle?

                      cheers
                      j
                    Your message has been successfully submitted and would be delivered to recipients shortly.