Loading ...
Sorry, an error occurred while loading the content.

G28

Expand Messages
  • capnden
    I am having trouble getting G28 Home axes to work. I get the message no axes with home switches defined . I checked other posts about the same message but
    Message 1 of 7 , Dec 4, 2012
    • 0 Attachment
      I am having trouble getting G28 Home axes to work. I get the message "no axes with home switches defined". I checked other posts about the same message but their answer was to delete G28 from the code. I am running long programs to make PC boards and I would like to use G28 to recalibrate periodically. I have limit switches on all 3 axes and I have used Configure I/O to configure them as home switches but I still get the error message. Does anyone know how to fix this?

      Thanks for your help.
    • Art Eckstein
      OK, First off, which version are you using? Next, have you set Home is Limit: in General Config? Have you set limit switches in Config I/O IF so, un select
      Message 2 of 7 , Dec 5, 2012
      • 0 Attachment
        OK,
        First off, which version are you using?
        Next, have you set "Home is Limit:" in General Config?
        Have you set limit switches in Config I/O IF so, un select them.
        Have you tested the switches to be sure they are working? Way back
        when, Iearned to setup ONE axis at a time and make sure it was
        working before going on to the next one. Even though you think you
        have it correct, if one is off, none will work.

        Also, I think there is a bug if you just issue a G28 call. I do one
        axis at a time G28 Z0 F10 (I have modified the code so I can specify
        the approach speed.
        This also assures me the Z axis will be done first to avoid any obstructions.

        Art
        Country Bubba


        At 10:26 PM 12/4/2012, you wrote:
        >I am having trouble getting G28 Home axes to work. I get the
        >message "no axes with home switches defined". I checked other posts
        >about the same message but their answer was to delete G28 from the
        >code. I am running long programs to make PC boards and I would like
        >to use G28 to recalibrate periodically. I have limit switches on
        >all 3 axes and I have used Configure I/O to configure them as home
        >switches but I still get the error message. Does anyone know how to fix this?
        >
        >Thanks for your help.
        >
      • capnden
        Thanks Art, I am using v4.01 I have set Home is Limit in General Config. Port 10 is set to Home X switch. All my limit switches are daisy chained together
        Message 3 of 7 , Dec 5, 2012
        • 0 Attachment
          Thanks Art,
          I am using v4.01
          I have set Home is Limit in General Config.
          Port 10 is set to Home X switch. All my limit switches are daisy chained together because I don't have enough ports for a port for each axis. From what you say this is probably my problem.
          I used the Port Monitor F2 to verify that the swithches are working, I also verified that they are working as limit switches.
          I get the same error "no axes with home switches defined" when I call G28 and when I call G28 X0 F1. I suspect that trying to home a specific axis is not covered by TurboCNC.

          Dennis

          --- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@...> wrote:
          >
          > OK,
          > First off, which version are you using?
          > Next, have you set "Home is Limit:" in General Config?
          > Have you set limit switches in Config I/O IF so, un select them.
          > Have you tested the switches to be sure they are working? Way back
          > when, Iearned to setup ONE axis at a time and make sure it was
          > working before going on to the next one. Even though you think you
          > have it correct, if one is off, none will work.
          >
          > Also, I think there is a bug if you just issue a G28 call. I do one
          > axis at a time G28 Z0 F10 (I have modified the code so I can specify
          > the approach speed.
          > This also assures me the Z axis will be done first to avoid any obstructions.
          >
          > Art
          > Country Bubba
          >
          >
          > At 10:26 PM 12/4/2012, you wrote:
          > >I am having trouble getting G28 Home axes to work. I get the
          > >message "no axes with home switches defined". I checked other posts
          > >about the same message but their answer was to delete G28 from the
          > >code. I am running long programs to make PC boards and I would like
          > >to use G28 to recalibrate periodically. I have limit switches on
          > >all 3 axes and I have used Configure I/O to configure them as home
          > >switches but I still get the error message. Does anyone know how to fix this?
          > >
          > >Thanks for your help.
          > >
          >
        • Art Eckstein
          Dennis, If you go to the files section, under the users 4.01 folder, you can download my version TCNC_V401enhanced.zip There is a pdf file that explains the
          Message 4 of 7 , Dec 5, 2012
          • 0 Attachment
            Dennis,
            If you go to the files section, under the users 4.01 folder, you can
            download my version TCNC_V401enhanced.zip

            There is a pdf file that explains the usage. I know this one works as
            it is the basis of the version that I use today.
            you indicate your using 1 pin for all switches. That is fine IF the
            switches are NC and wired in series or NO and wired in parallel!
            Also, do you have a pullup resistor on that pin?

            Country

            At 09:51 AM 12/5/2012, you wrote:
            >Thanks Art,
            >I am using v4.01
            >I have set Home is Limit in General Config.
            >Port 10 is set to Home X switch. All my limit switches are daisy
            >chained together because I don't have enough ports for a port for
            >each axis. From what you say this is probably my problem.
            >I used the Port Monitor F2 to verify that the swithches are working,
            >I also verified that they are working as limit switches.
            >I get the same error "no axes with home switches defined" when I
            >call G28 and when I call G28 X0 F1. I suspect that trying to home a
            >specific axis is not covered by TurboCNC.
            >
            >Dennis
            >
            >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@...> wrote:
            > >
            > > OK,
            > > First off, which version are you using?
            > > Next, have you set "Home is Limit:" in General Config?
            > > Have you set limit switches in Config I/O IF so, un select them.
            > > Have you tested the switches to be sure they are working? Way back
            > > when, Iearned to setup ONE axis at a time and make sure it was
            > > working before going on to the next one. Even though you think you
            > > have it correct, if one is off, none will work.
            > >
            > > Also, I think there is a bug if you just issue a G28 call. I do one
            > > axis at a time G28 Z0 F10 (I have modified the code so I can specify
            > > the approach speed.
            > > This also assures me the Z axis will be done first to avoid any
            > obstructions.
            > >
            > > Art
            > > Country Bubba
            > >
            > >
            > > At 10:26 PM 12/4/2012, you wrote:
            > > >I am having trouble getting G28 Home axes to work. I get the
            > > >message "no axes with home switches defined". I checked other posts
            > > >about the same message but their answer was to delete G28 from the
            > > >code. I am running long programs to make PC boards and I would like
            > > >to use G28 to recalibrate periodically. I have limit switches on
            > > >all 3 axes and I have used Configure I/O to configure them as home
            > > >switches but I still get the error message. Does anyone know
            > how to fix this?
            > > >
            > > >Thanks for your help.
            > > >
            > >
          • capnden
            Thanks Art, I downloaded your enhanced zip file and put it on my machine. I also separated out my switches so X is on port 10, Y on 12 and Z on 15. The
            Message 5 of 7 , Dec 5, 2012
            • 0 Attachment
              Thanks Art, I downloaded your enhanced zip file and put it on my machine. I also separated out my switches so X is on port 10, Y on 12 and Z on 15. The switches are NC and there are pull ups on my control board so they are active high. I am getting a lot closer.
              When I call G28 X0 F1 it will home X and back off like the manual says except if I have the "Home is Limit set", then when it contacts the switch it shows a limit is tripped and stops. So right now I can have the homing working or the limits but not both. I am sure I am missing something. Thanks for all your help.

              Dennis

              --- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@...> wrote:
              >
              > Dennis,
              > If you go to the files section, under the users 4.01 folder, you can
              > download my version TCNC_V401enhanced.zip
              >
              > There is a pdf file that explains the usage. I know this one works as
              > it is the basis of the version that I use today.
              > you indicate your using 1 pin for all switches. That is fine IF the
              > switches are NC and wired in series or NO and wired in parallel!
              > Also, do you have a pullup resistor on that pin?
              >
              > Country
              >
              > At 09:51 AM 12/5/2012, you wrote:
              > >Thanks Art,
              > >I am using v4.01
              > >I have set Home is Limit in General Config.
              > >Port 10 is set to Home X switch. All my limit switches are daisy
              > >chained together because I don't have enough ports for a port for
              > >each axis. From what you say this is probably my problem.
              > >I used the Port Monitor F2 to verify that the swithches are working,
              > >I also verified that they are working as limit switches.
              > >I get the same error "no axes with home switches defined" when I
              > >call G28 and when I call G28 X0 F1. I suspect that trying to home a
              > >specific axis is not covered by TurboCNC.
              > >
              > >Dennis
              > >
              > >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@> wrote:
              > > >
              > > > OK,
              > > > First off, which version are you using?
              > > > Next, have you set "Home is Limit:" in General Config?
              > > > Have you set limit switches in Config I/O IF so, un select them.
              > > > Have you tested the switches to be sure they are working? Way back
              > > > when, Iearned to setup ONE axis at a time and make sure it was
              > > > working before going on to the next one. Even though you think you
              > > > have it correct, if one is off, none will work.
              > > >
              > > > Also, I think there is a bug if you just issue a G28 call. I do one
              > > > axis at a time G28 Z0 F10 (I have modified the code so I can specify
              > > > the approach speed.
              > > > This also assures me the Z axis will be done first to avoid any
              > > obstructions.
              > > >
              > > > Art
              > > > Country Bubba
              > > >
              > > >
              > > > At 10:26 PM 12/4/2012, you wrote:
              > > > >I am having trouble getting G28 Home axes to work. I get the
              > > > >message "no axes with home switches defined". I checked other posts
              > > > >about the same message but their answer was to delete G28 from the
              > > > >code. I am running long programs to make PC boards and I would like
              > > > >to use G28 to recalibrate periodically. I have limit switches on
              > > > >all 3 axes and I have used Configure I/O to configure them as home
              > > > >switches but I still get the error message. Does anyone know
              > > how to fix this?
              > > > >
              > > > >Thanks for your help.
              > > > >
              > > >
              >
            • Art Eckstein
              Do you have backlash compensation enabled? If so, I found that problem also! Disable backlash compensation. I never got around to trying to fix that as I
              Message 6 of 7 , Dec 5, 2012
              • 0 Attachment
                Do you have backlash compensation enabled? If so, I found that
                problem also! Disable backlash compensation. I never got around to
                trying to fix that as I fixed the backlash problem in the proper
                mechanical method:})


                By the way, the Fx in the command will only affect the approach speed
                to the switch. The backoff speed is what you set in the config file.
                I ran several tests to find the most reliable backoff speed based on
                the switches I used. Surprisingly there was a significant difference
                and if to slow or to fast there was quite a difference in repeatibility.

                IF you have home is limit set, you DO NOT enable any limit switches
                in the config.

                Country


                At 04:05 PM 12/5/2012, you wrote:
                >Thanks Art, I downloaded your enhanced zip file and put it on my
                >machine. I also separated out my switches so X is on port 10, Y on
                >12 and Z on 15. The switches are NC and there are pull ups on my
                >control board so they are active high. I am getting a lot closer.
                >When I call G28 X0 F1 it will home X and back off like the manual
                >says except if I have the "Home is Limit set", then when it contacts
                >the switch it shows a limit is tripped and stops. So right now I
                >can have the homing working or the limits but not both. I am sure I
                >am missing something. Thanks for all your help.
                >
                >Dennis
                >
                >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@...> wrote:
                > >
                > > Dennis,
                > > If you go to the files section, under the users 4.01 folder, you can
                > > download my version TCNC_V401enhanced.zip
                > >
                > > There is a pdf file that explains the usage. I know this one works as
                > > it is the basis of the version that I use today.
                > > you indicate your using 1 pin for all switches. That is fine IF the
                > > switches are NC and wired in series or NO and wired in parallel!
                > > Also, do you have a pullup resistor on that pin?
                > >
                > > Country
                > >
                > > At 09:51 AM 12/5/2012, you wrote:
                > > >Thanks Art,
                > > >I am using v4.01
                > > >I have set Home is Limit in General Config.
                > > >Port 10 is set to Home X switch. All my limit switches are daisy
                > > >chained together because I don't have enough ports for a port for
                > > >each axis. From what you say this is probably my problem.
                > > >I used the Port Monitor F2 to verify that the swithches are working,
                > > >I also verified that they are working as limit switches.
                > > >I get the same error "no axes with home switches defined" when I
                > > >call G28 and when I call G28 X0 F1. I suspect that trying to home a
                > > >specific axis is not covered by TurboCNC.
                > > >
                > > >Dennis
                > > >
                > > >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@> wrote:
                > > > >
                > > > > OK,
                > > > > First off, which version are you using?
                > > > > Next, have you set "Home is Limit:" in General Config?
                > > > > Have you set limit switches in Config I/O IF so, un select them.
                > > > > Have you tested the switches to be sure they are working? Way back
                > > > > when, Iearned to setup ONE axis at a time and make sure it was
                > > > > working before going on to the next one. Even though you think you
                > > > > have it correct, if one is off, none will work.
                > > > >
                > > > > Also, I think there is a bug if you just issue a G28 call. I do one
                > > > > axis at a time G28 Z0 F10 (I have modified the code so I can specify
                > > > > the approach speed.
                > > > > This also assures me the Z axis will be done first to avoid any
                > > > obstructions.
                > > > >
                > > > > Art
                > > > > Country Bubba
                > > > >
                > > > >
                > > > > At 10:26 PM 12/4/2012, you wrote:
                > > > > >I am having trouble getting G28 Home axes to work. I get the
                > > > > >message "no axes with home switches defined". I checked other posts
                > > > > >about the same message but their answer was to delete G28 from the
                > > > > >code. I am running long programs to make PC boards and I would like
                > > > > >to use G28 to recalibrate periodically. I have limit switches on
                > > > > >all 3 axes and I have used Configure I/O to configure them as home
                > > > > >switches but I still get the error message. Does anyone know
                > > > how to fix this?
                > > > > >
                > > > > >Thanks for your help.
                > > > > >
                > > > >
                > >
                >
                >
                >
                >
                >------------------------------------
                >
                >
                >
                >Yahoo! Groups Links
                >
                >
                >
              • capnden
                Thanks Art, that s what it was. I don t think I can make a mill with no backlash, even Bridgeport has .005. I will just turn off the limits when I m using
                Message 7 of 7 , Dec 6, 2012
                • 0 Attachment
                  Thanks Art, that's what it was. I don't think I can make a mill with no backlash, even Bridgeport has .005. I will just turn off the limits when I'm using G28.
                  Thanks for all your help.

                  --- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@...> wrote:
                  >
                  > Do you have backlash compensation enabled? If so, I found that
                  > problem also! Disable backlash compensation. I never got around to
                  > trying to fix that as I fixed the backlash problem in the proper
                  > mechanical method:})
                  >
                  >
                  > By the way, the Fx in the command will only affect the approach speed
                  > to the switch. The backoff speed is what you set in the config file.
                  > I ran several tests to find the most reliable backoff speed based on
                  > the switches I used. Surprisingly there was a significant difference
                  > and if to slow or to fast there was quite a difference in repeatibility.
                  >
                  > IF you have home is limit set, you DO NOT enable any limit switches
                  > in the config.
                  >
                  > Country
                  >
                  >
                  > At 04:05 PM 12/5/2012, you wrote:
                  > >Thanks Art, I downloaded your enhanced zip file and put it on my
                  > >machine. I also separated out my switches so X is on port 10, Y on
                  > >12 and Z on 15. The switches are NC and there are pull ups on my
                  > >control board so they are active high. I am getting a lot closer.
                  > >When I call G28 X0 F1 it will home X and back off like the manual
                  > >says except if I have the "Home is Limit set", then when it contacts
                  > >the switch it shows a limit is tripped and stops. So right now I
                  > >can have the homing working or the limits but not both. I am sure I
                  > >am missing something. Thanks for all your help.
                  > >
                  > >Dennis
                  > >
                  > >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@> wrote:
                  > > >
                  > > > Dennis,
                  > > > If you go to the files section, under the users 4.01 folder, you can
                  > > > download my version TCNC_V401enhanced.zip
                  > > >
                  > > > There is a pdf file that explains the usage. I know this one works as
                  > > > it is the basis of the version that I use today.
                  > > > you indicate your using 1 pin for all switches. That is fine IF the
                  > > > switches are NC and wired in series or NO and wired in parallel!
                  > > > Also, do you have a pullup resistor on that pin?
                  > > >
                  > > > Country
                  > > >
                  > > > At 09:51 AM 12/5/2012, you wrote:
                  > > > >Thanks Art,
                  > > > >I am using v4.01
                  > > > >I have set Home is Limit in General Config.
                  > > > >Port 10 is set to Home X switch. All my limit switches are daisy
                  > > > >chained together because I don't have enough ports for a port for
                  > > > >each axis. From what you say this is probably my problem.
                  > > > >I used the Port Monitor F2 to verify that the swithches are working,
                  > > > >I also verified that they are working as limit switches.
                  > > > >I get the same error "no axes with home switches defined" when I
                  > > > >call G28 and when I call G28 X0 F1. I suspect that trying to home a
                  > > > >specific axis is not covered by TurboCNC.
                  > > > >
                  > > > >Dennis
                  > > > >
                  > > > >--- In turbocnc@yahoogroups.com, Art Eckstein <art.eckstein@> wrote:
                  > > > > >
                  > > > > > OK,
                  > > > > > First off, which version are you using?
                  > > > > > Next, have you set "Home is Limit:" in General Config?
                  > > > > > Have you set limit switches in Config I/O IF so, un select them.
                  > > > > > Have you tested the switches to be sure they are working? Way back
                  > > > > > when, Iearned to setup ONE axis at a time and make sure it was
                  > > > > > working before going on to the next one. Even though you think you
                  > > > > > have it correct, if one is off, none will work.
                  > > > > >
                  > > > > > Also, I think there is a bug if you just issue a G28 call. I do one
                  > > > > > axis at a time G28 Z0 F10 (I have modified the code so I can specify
                  > > > > > the approach speed.
                  > > > > > This also assures me the Z axis will be done first to avoid any
                  > > > > obstructions.
                  > > > > >
                  > > > > > Art
                  > > > > > Country Bubba
                  > > > > >
                  > > > > >
                  > > > > > At 10:26 PM 12/4/2012, you wrote:
                  > > > > > >I am having trouble getting G28 Home axes to work. I get the
                  > > > > > >message "no axes with home switches defined". I checked other posts
                  > > > > > >about the same message but their answer was to delete G28 from the
                  > > > > > >code. I am running long programs to make PC boards and I would like
                  > > > > > >to use G28 to recalibrate periodically. I have limit switches on
                  > > > > > >all 3 axes and I have used Configure I/O to configure them as home
                  > > > > > >switches but I still get the error message. Does anyone know
                  > > > > how to fix this?
                  > > > > > >
                  > > > > > >Thanks for your help.
                  > > > > > >
                  > > > > >
                  > > >
                  > >
                  > >
                  > >
                  > >
                  > >------------------------------------
                  > >
                  > >
                  > >
                  > >Yahoo! Groups Links
                  > >
                  > >
                  > >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.