Loading ...
Sorry, an error occurred while loading the content.

Problem with Home switches

Expand Messages
  • jimc1950
    Here we go again with the home switches. I don t know if it is a hardware problem, or a software problem I originally wired the limit switches as X
    Message 1 of 11 , Jun 1, 2007
    • 0 Attachment
      Here we go again with the home switches.
      I don't know if it is a hardware problem, or a software problem
      I originally wired the limit switches as X limit , Y limit. As I was
      trying it out, I used the limit
      switches as home switches. This worked except that after homing it
      showed "Limit switch
      activated". Well just don't use home switches.
      After installing it all in a box, hooking all limit switches together
      as one unit. And starting to use
      it I see a need for Home switches.
      So I installed 2 home switches(One on each of 2 pins, with
      resisters). Wired one to Pin 12, and
      one to Pin 15.
      When I tell it to go home it just moved the Y axis ( the software
      said both were moving) and
      when hitting that switch it showed both home.
      I switched the wires at the machine, and now the X axis does the same
      thing.
      I use G28 Y0 and only the X moves.
      I switched the Y to pins 17,11,10 and still no change.
      I installed a new motor on the Y axis.
      This morning I installed a new parallel port card on my computer.
      Using the installed one over
      the "built in" one, I say go home and Nothing moves, but the software
      immediately shows Home.
      I have run out of ideas.
      Anyone else got some.
      Jim
    • Art Eckstein
      Jim, when you set it up to use homeaslimit , did you disable the limit switches in the config file? If you didn t, it won t work! also, I don t believe
      Message 2 of 11 , Jun 1, 2007
      • 0 Attachment
        Jim,
        when you set it up to use "homeaslimit", did you disable the limit
        switches in the config file? If you didn't, it won't work!
        also, I don't believe homing in the jog screen works at this time (version 4.1)

        As for getting homing switches setup and working properly, I advise
        configuring only one axis at a time. Get it working properly and
        then move on to the next one after disabling the first.

        Which version are you using.


        Bubba


        At 08:44 AM 6/1/2007, you wrote:
        >Here we go again with the home switches.
        >I don't know if it is a hardware problem, or a software problem
        > I originally wired the limit switches as X limit , Y limit. As I was
        >trying it out, I used the limit
        >switches as home switches. This worked except that after homing it
        >showed "Limit switch
        >activated". Well just don't use home switches.
        >After installing it all in a box, hooking all limit switches together
        >as one unit. And starting to use
        >it I see a need for Home switches.
        >So I installed 2 home switches(One on each of 2 pins, with
        >resisters). Wired one to Pin 12, and
        >one to Pin 15.
        >When I tell it to go home it just moved the Y axis ( the software
        >said both were moving) and
        >when hitting that switch it showed both home.
        >I switched the wires at the machine, and now the X axis does the same
        >thing.
        >I use G28 Y0 and only the X moves.
        >I switched the Y to pins 17,11,10 and still no change.
        >I installed a new motor on the Y axis.
        >This morning I installed a new parallel port card on my computer.
        >Using the installed one over
        >the "built in" one, I say go home and Nothing moves, but the software
        >immediately shows Home.
        >I have run out of ideas.
        >Anyone else got some.
        >Jim
        >
        >
        >
      • JCullins
        I am not sure with turbocnc but with Mach Mach knows what mode it is in and acts acordingly. If you request a home then the first switch closure is the home
        Message 3 of 11 , Jun 1, 2007
        • 0 Attachment
          I am not sure with turbocnc but with Mach
          Mach knows what mode it is in and acts acordingly.
          If you request a home then the first switch closure is the home switch
          any other time it is a limit and will reset Mach. This way you only need one input
          to handle all the limit and home functions.
          I don't know if Turbocnc is setup that way or not.
          Jim



          ----- Original Message ----
          From: Art Eckstein <a_eckstein@...>
          To: turbocnc@yahoogroups.com
          Sent: Friday, June 1, 2007 1:05:53 PM
          Subject: Re: [turbocnc] Problem with Home switches


          Jim,
          when you set it up to use "homeaslimit", did you disable the limit
          switches in the config file? If you didn't, it won't work!
          also, I don't believe homing in the jog screen works at this time (version 4.1)

          As for getting homing switches setup and working properly, I advise
          configuring only one axis at a time. Get it working properly and
          then move on to the next one after disabling the first.

          Which version are you using.


          Bubba


          At 08:44 AM 6/1/2007, you wrote:
          >Here we go again with the home switches.
          >I don't know if it is a hardware problem, or a software problem
          > I originally wired the limit switches as X limit , Y limit. As I was
          >trying it out, I used the limit
          >switches as home switches. This worked except that after homing it
          >showed "Limit switch
          >activated". Well just don't use home switches.
          >After installing it all in a box, hooking all limit switches together
          >as one unit. And starting to use
          >it I see a need for Home switches.
          >So I installed 2 home switches(One on each of 2 pins, with
          >resisters). Wired one to Pin 12, and
          >one to Pin 15.
          >When I tell it to go home it just moved the Y axis ( the software
          >said both were moving) and
          >when hitting that switch it showed both home.
          >I switched the wires at the machine, and now the X axis does the same
          >thing.
          >I use G28 Y0 and only the X moves.
          >I switched the Y to pins 17,11,10 and still no change.
          >I installed a new motor on the Y axis.
          >This morning I installed a new parallel port card on my computer.
          >Using the installed one over
          >the "built in" one, I say go home and Nothing moves, but the software
          >immediately shows Home.
          >I have run out of ideas.
          >Anyone else got some.
          >Jim
          >
          >
          >






          Yahoo! Groups Links



          [Non-text portions of this message have been removed]
        • Art Eckstein
          Back when I was first setting this up, one of the things Tony G commented on was the fact that you had to disable the limit switches in order for it to work.
          Message 4 of 11 , Jun 1, 2007
          • 0 Attachment
            Back when I was first setting this up, one of the things Tony G
            commented on was the fact that you had to "disable" the limit
            switches in order for it to work.

            If limits are enabled, you will get exactly the symptoms described.
            In my case, on the X and Y, only one switch is used for handling the
            +/- limit functions (as well as home). The only caution I have is I
            have to make sure the switch opposite from the home end is NOT
            tripped when issuing a home command or the axis moves in the wrong direction!

            Also, I believe the home function in the jog screen has a bug (I
            never use it), but it is documented on the bug list.





            At 05:45 PM 6/1/2007, you wrote:
            >I am not sure with turbocnc but with Mach
            >Mach knows what mode it is in and acts acordingly.
            >If you request a home then the first switch closure is the home switch
            >any other time it is a limit and will reset Mach. This way you only
            >need one input
            >to handle all the limit and home functions.
            >I don't know if Turbocnc is setup that way or not.
            >Jim
            >
            >
            >
            >----- Original Message ----
            >From: Art Eckstein <a_eckstein@...>
            >To: turbocnc@yahoogroups.com
            >Sent: Friday, June 1, 2007 1:05:53 PM
            >Subject: Re: [turbocnc] Problem with Home switches
            >
            >
            >Jim,
            >when you set it up to use "homeaslimit", did you disable the limit
            >switches in the config file? If you didn't, it won't work!
            >also, I don't believe homing in the jog screen works at this time
            >(version 4.1)
            >
            >As for getting homing switches setup and working properly, I advise
            >configuring only one axis at a time. Get it working properly and
            >then move on to the next one after disabling the first.
            >
            >Which version are you using.
            >
            >
            >Bubba
          • JCullins
            Art, Thanks for the info I have no experience with Turbocnc. Jim ... From: Art Eckstein To: turbocnc@yahoogroups.com Sent: Friday,
            Message 5 of 11 , Jun 1, 2007
            • 0 Attachment
              Art,
              Thanks for the info I have no experience with Turbocnc.
              Jim


              ----- Original Message ----
              From: Art Eckstein <a_eckstein@...>
              To: turbocnc@yahoogroups.com
              Sent: Friday, June 1, 2007 6:03:06 PM
              Subject: Re: [turbocnc] Problem with Home switches


              Back when I was first setting this up, one of the things Tony G
              commented on was the fact that you had to "disable" the limit
              switches in order for it to work.

              If limits are enabled, you will get exactly the symptoms described.
              In my case, on the X and Y, only one switch is used for handling the
              +/- limit functions (as well as home). The only caution I have is I
              have to make sure the switch opposite from the home end is NOT
              tripped when issuing a home command or the axis moves in the wrong direction!

              Also, I believe the home function in the jog screen has a bug (I
              never use it), but it is documented on the bug list.





              At 05:45 PM 6/1/2007, you wrote:
              >I am not sure with turbocnc but with Mach
              >Mach knows what mode it is in and acts acordingly.
              >If you request a home then the first switch closure is the home switch
              >any other time it is a limit and will reset Mach. This way you only
              >need one input
              >to handle all the limit and home functions.
              >I don't know if Turbocnc is setup that way or not.
              >Jim
              >
              >
              >
              >----- Original Message ----
              >From: Art Eckstein <a_eckstein@...>
              >To: turbocnc@yahoogroups.com
              >Sent: Friday, June 1, 2007 1:05:53 PM
              >Subject: Re: [turbocnc] Problem with Home switches
              >
              >
              >Jim,
              >when you set it up to use "homeaslimit", did you disable the limit
              >switches in the config file? If you didn't, it won't work!
              >also, I don't believe homing in the jog screen works at this time
              >(version 4.1)
              >
              >As for getting homing switches setup and working properly, I advise
              >configuring only one axis at a time. Get it working properly and
              >then move on to the next one after disabling the first.
              >
              >Which version are you using.
              >
              >
              >Bubba






              Yahoo! Groups Links



              [Non-text portions of this message have been removed]
            • Art Eckstein
              Jim, Guilty as I am the one who started this home as limit stuff back in V3.x:}) Then Tony G took the ball and made it better in V4.x. However, there are still
              Message 6 of 11 , Jun 1, 2007
              • 0 Attachment
                Jim,
                Guilty as I am the one who started this home as limit stuff back in V3.x:})

                Then Tony G took the ball and made it better in V4.x. However, there
                are still some bugs and Dave has them listed for the next release? I
                understand he has more than enough to do in his real job (Travel)
                than to work with Turbo.

                I thought he was close to releasing the next beta when he had to stop
                (for how long?)

                In the meantime, I am plugging along and homing works great for
                ME. Recently, I sent an updated version to a gent in France?, but it
                seems there are major problem when dealing with metrics.

                If I remember correctly, the jog screen routine for homing does NOT
                access the coding for G28 and as I don't use that portion, haven't
                really tried to fix it.

                A real programmer I am not, so there are a lot of things that I may
                be missing and not even recognize it. With all the modules there are
                for the program, it is easy to overlook or not recognize the inter-reaction.

                Bubba



                At 06:25 PM 6/1/2007, you wrote:
                >Art,
                >Thanks for the info I have no experience with Turbocnc.
                >Jim
                >
                >
                >----- Original Message ----
                >From: Art Eckstein <a_eckstein@...>
                >To: turbocnc@yahoogroups.com
                >Sent: Friday, June 1, 2007 6:03:06 PM
                >Subject: Re: [turbocnc] Problem with Home switches
                >
                >
                >Back when I was first setting this up, one of the things Tony G
                >commented on was the fact that you had to "disable" the limit
                >switches in order for it to work.
                >
                >If limits are enabled, you will get exactly the symptoms described.
                >In my case, on the X and Y, only one switch is used for handling the
                >+/- limit functions (as well as home). The only caution I have is I
                >have to make sure the switch opposite from the home end is NOT
                >tripped when issuing a home command or the axis moves in the wrong direction!
                >
                >Also, I believe the home function in the jog screen has a bug (I
                >never use it), but it is documented on the bug list.
                >
                >
                >
                >
                >
                >At 05:45 PM 6/1/2007, you wrote:
                > >I am not sure with turbocnc but with Mach
                > >Mach knows what mode it is in and acts acordingly.
                > >If you request a home then the first switch closure is the home switch
                > >any other time it is a limit and will reset Mach. This way you only
                > >need one input
                > >to handle all the limit and home functions.
                > >I don't know if Turbocnc is setup that way or not.
                > >Jim
                > >
                > >
                > >
                > >----- Original Message ----
                > >From: Art Eckstein <a_eckstein@...>
                > >To: turbocnc@yahoogroups.com
                > >Sent: Friday, June 1, 2007 1:05:53 PM
                > >Subject: Re: [turbocnc] Problem with Home switches
                > >
                > >
                > >Jim,
                > >when you set it up to use "homeaslimit", did you disable the limit
                > >switches in the config file? If you didn't, it won't work!
                > >also, I don't believe homing in the jog screen works at this time
                > >(version 4.1)
                > >
                > >As for getting homing switches setup and working properly, I advise
                > >configuring only one axis at a time. Get it working properly and
                > >then move on to the next one after disabling the first.
                > >
                > >Which version are you using.
                > >
                > >
                > >Bubba
              • JCullins
                no problem I assumed it was handles as it is in Mach. Thanks Jim ... From: Art Eckstein To: turbocnc@yahoogroups.com Sent: Friday,
                Message 7 of 11 , Jun 1, 2007
                • 0 Attachment
                  no problem I assumed it was handles as it is in Mach.
                  Thanks
                  Jim


                  ----- Original Message ----
                  From: Art Eckstein <a_eckstein@...>
                  To: turbocnc@yahoogroups.com
                  Sent: Friday, June 1, 2007 7:01:17 PM
                  Subject: Re: [turbocnc] Problem with Home switches


                  Jim,
                  Guilty as I am the one who started this home as limit stuff back in V3.x:})

                  Then Tony G took the ball and made it better in V4.x. However, there
                  are still some bugs and Dave has them listed for the next release? I
                  understand he has more than enough to do in his real job (Travel)
                  than to work with Turbo.

                  I thought he was close to releasing the next beta when he had to stop
                  (for how long?)

                  In the meantime, I am plugging along and homing works great for
                  ME. Recently, I sent an updated version to a gent in France?, but it
                  seems there are major problem when dealing with metrics.

                  If I remember correctly, the jog screen routine for homing does NOT
                  access the coding for G28 and as I don't use that portion, haven't
                  really tried to fix it.

                  A real programmer I am not, so there are a lot of things that I may
                  be missing and not even recognize it. With all the modules there are
                  for the program, it is easy to overlook or not recognize the inter-reaction.

                  Bubba



                  At 06:25 PM 6/1/2007, you wrote:
                  >Art,
                  >Thanks for the info I have no experience with Turbocnc.
                  >Jim
                  >
                  >
                  >----- Original Message ----
                  >From: Art Eckstein <a_eckstein@...>
                  >To: turbocnc@yahoogroups.com
                  >Sent: Friday, June 1, 2007 6:03:06 PM
                  >Subject: Re: [turbocnc] Problem with Home switches
                  >
                  >
                  >Back when I was first setting this up, one of the things Tony G
                  >commented on was the fact that you had to "disable" the limit
                  >switches in order for it to work.
                  >
                  >If limits are enabled, you will get exactly the symptoms described.
                  >In my case, on the X and Y, only one switch is used for handling the
                  >+/- limit functions (as well as home). The only caution I have is I
                  >have to make sure the switch opposite from the home end is NOT
                  >tripped when issuing a home command or the axis moves in the wrong direction!
                  >
                  >Also, I believe the home function in the jog screen has a bug (I
                  >never use it), but it is documented on the bug list.
                  >
                  >
                  >
                  >
                  >
                  >At 05:45 PM 6/1/2007, you wrote:
                  > >I am not sure with turbocnc but with Mach
                  > >Mach knows what mode it is in and acts acordingly.
                  > >If you request a home then the first switch closure is the home switch
                  > >any other time it is a limit and will reset Mach. This way you only
                  > >need one input
                  > >to handle all the limit and home functions.
                  > >I don't know if Turbocnc is setup that way or not.
                  > >Jim
                  > >
                  > >
                  > >
                  > >----- Original Message ----
                  > >From: Art Eckstein <a_eckstein@...>
                  > >To: turbocnc@yahoogroups.com
                  > >Sent: Friday, June 1, 2007 1:05:53 PM
                  > >Subject: Re: [turbocnc] Problem with Home switches
                  > >
                  > >
                  > >Jim,
                  > >when you set it up to use "homeaslimit", did you disable the limit
                  > >switches in the config file? If you didn't, it won't work!
                  > >also, I don't believe homing in the jog screen works at this time
                  > >(version 4.1)
                  > >
                  > >As for getting homing switches setup and working properly, I advise
                  > >configuring only one axis at a time. Get it working properly and
                  > >then move on to the next one after disabling the first.
                  > >
                  > >Which version are you using.
                  > >
                  > >
                  > >Bubba






                  Yahoo! Groups Links



                  [Non-text portions of this message have been removed]
                • Art Eckstein
                  when you use homeaslimit, it will act as a limit switch under normal running conditions and as a home switch when a home command is issued. You disable the
                  Message 8 of 11 , Jun 2, 2007
                  • 0 Attachment
                    when you use homeaslimit, it will act as a limit switch under
                    "normal" running conditions and as a home switch when a home command
                    is issued. You disable the limit switches IF you are using homeaslimit.

                    However all is mute at this time as you have now installed separate
                    home and limit switches.

                    Is it working properly now?

                    Bubba


                    At 10:38 AM 6/2/2007, you wrote:
                    >Jim,
                    >when you set it up to use "homeaslimit" , did you disable the limit
                    >switches in the config file? If you didn't, it won't work!
                    >also, I don't believe homing in the jog screen works at this time
                    >(version 4.1)
                    >
                    > Ok now I am not using the home switches as limits. I have limit
                    > switches and have added 2 home switches wired on their own.
                    > using the newest version, I believe it is 4.1
                    > Using G28, and the "home" function under Settings (I think)
                    >
                    >
                    >
                    > Back when I was first setting this up, one of the things Tony G
                    >commented on was the fact that you had to "disable" the limit
                    >switches in order for it to work.
                    >
                    > Humm, have to disable the limit switches? That doesn't sould
                    > good, I have hit the limits twice in two days already. An I reading correctly?
                    > Jim
                    > PS too many Jim's
                    >
                    >
                  • Jim C
                    Jim, when you set it up to use homeaslimit , did you disable the limit switches in the config file? If you didn t, it won t work! also, I don t believe
                    Message 9 of 11 , Jun 2, 2007
                    • 0 Attachment
                      Jim,
                      when you set it up to use "homeaslimit" , did you disable the limit
                      switches in the config file? If you didn't, it won't work!
                      also, I don't believe homing in the jog screen works at this time (version 4.1)

                      Ok now I am not using the home switches as limits. I have limit switches and have added 2 home switches wired on their own.
                      using the newest version, I believe it is 4.1
                      Using G28, and the "home" function under Settings (I think)



                      Back when I was first setting this up, one of the things Tony G
                      commented on was the fact that you had to "disable" the limit
                      switches in order for it to work.

                      Humm, have to disable the limit switches? That doesn't sould good, I have hit the limits twice in two days already. An I reading correctly?
                      Jim
                      PS too many Jim's


                      ---------------------------------
                      Moody friends. Drama queens. Your life? Nope! - their life, your story.
                      Play Sims Stories at Yahoo! Games.

                      [Non-text portions of this message have been removed]
                    • Jim C
                      Finally after about 8-10 hours of trial and error, Success. Maybe this will help someone else that can’t get something to work. Got an older computer and
                      Message 10 of 11 , Jun 2, 2007
                      • 0 Attachment
                        Finally after about 8-10 hours of trial and error, Success.
                        Maybe this will help someone else that can’t get something to work.
                        Got an older computer and hooked it up. Same thing, no home movement in the Y.
                        Went back to original computer and ran a different wire from pin 11 to Y switch, Nope.
                        Then changed out Y switch, Nope again. Checked all the pins coming out of the computer, and they have about 5 volts. Humm all seem to be working, and connected.
                        Running out of ideas. Thought about it for an hour or two.
                        Switched the wires at the machine again, X to Y, Y to X. Again now Y works not X.
                        Removed Limit switch wire and hooked up X home to it. Now have Home in both X & Y, but no limit switch capability.
                        Hooked limit switch to pin 10. Wow now have Home and limit switches working.
                        Ah, but wait, getting an interment limit switch activation after about each 30-40 seconds.
                        Switch limit switch to pin 15, and all seems to be working as planned.
                        So, I ended up with X-home on pin 13, Y-home pin 12, and limit switches ( along with E-stop) on pin 15.
                        Just keep my fingers crossed.
                        Thanks for all suggestions.
                        Jim


                        ---------------------------------
                        Be a better Heartthrob. Get better relationship answers from someone who knows.
                        Yahoo! Answers - Check it out.

                        [Non-text portions of this message have been removed]
                      • Jim C
                         Interesting, I wonder what brought that up on my earlier post? Jim ... Need a vacation? Get great deals to amazing places on Yahoo! Travel.
                        Message 11 of 11 , Jun 2, 2007
                        • 0 Attachment
                          " " Interesting, I wonder what brought that up on my earlier post?
                          Jim


                          ---------------------------------
                          Need a vacation? Get great deals to amazing places on Yahoo! Travel.

                          [Non-text portions of this message have been removed]
                        Your message has been successfully submitted and would be delivered to recipients shortly.