Loading ...
Sorry, an error occurred while loading the content.

G00 speed

Expand Messages
  • dan pines
    Is there any user accessible way to set/change the feed speed used for G00? thanks dan
    Message 1 of 12 , Aug 1, 2005
    • 0 Attachment
      Is there any user accessible way to set/change the feed speed used for
      G00?
      thanks
      dan
    • Art Eckstein
      Dan, In the config file, just set the Max Vel to the speed you desire! This is G00 speed. Bubba ... OLDER THAN DIRT Country Bubba (Actually the inventor of
      Message 2 of 12 , Aug 1, 2005
      • 0 Attachment
        Dan,
        In the config file, just set the "Max Vel" to the speed you desire!
        This is G00 speed.

        Bubba

        At 08:44 AM 8/1/2005, you wrote:
        >Is there any user accessible way to set/change the feed speed used for
        >G00?
        >thanks
        >dan



        OLDER THAN DIRT
        Country Bubba
        (Actually the inventor of Country and Bubba)
        In God We Trust

        LaGrange, GA

        http://bellsouthpwp.net/A/r/Arts_home_page/cnc/

        [Non-text portions of this message have been removed]
      • Carol & Jerry Jankura
        Hi, Dan: G00 runs at the maximum speed that you configured each axis for. If you re moving more than one axis simultaneously, TurboCNC will make sure that no
        Message 3 of 12 , Aug 1, 2005
        • 0 Attachment
          Hi, Dan:

          G00 runs at the "maximum" speed that you configured each axis for. If you're
          moving more than one axis simultaneously, TurboCNC will make sure that no
          axis exceeds its max. (So if you have one axis set to 100 steps/sec and
          another set to 1000, a single axis move will at either 100 or 1000,
          depending on the axis you move. However, if you move both axes, each will
          move at less than 100 setps/sec)

          -- Jerry

          > Is there any user accessible way to set/change the feed speed
          > used for G00?
          > thanks

          --
          Internal Virus Database is out-of-date.
          Checked by AVG Anti-Virus.
          Version: 7.0.323 / Virus Database: 267.9.2/55 - Release Date: 7/21/2005
        • Luc Degrande
          Sorry to jump in on this. But it doesn t work on my system. G00 moves don t reach the maximum speed set in the configuration. I am moving only one axis and I
          Message 4 of 12 , Aug 1, 2005
          • 0 Attachment
            Sorry to jump in on this.

            But it doesn't work on my system.
            G00 moves don't reach the maximum speed set in the configuration.
            I am moving only one axis and I don't get the maximum speed.
            I can run faster than G00 using G01 with feed rate specified.

            See my previous post, a few days ago, no replies yet.

            Thanks,
            Luc.



            ----- Original Message -----
            From: "Carol & Jerry Jankura" <jerry.jankura@...>
            To: <turbocnc@yahoogroups.com>
            Sent: Monday, August 01, 2005 3:50 PM
            Subject: RE: [turbocnc] G00 speed


            > Hi, Dan:
            >
            > G00 runs at the "maximum" speed that you configured each axis for. If
            you're
            > moving more than one axis simultaneously, TurboCNC will make sure that no
            > axis exceeds its max. (So if you have one axis set to 100 steps/sec and
            > another set to 1000, a single axis move will at either 100 or 1000,
            > depending on the axis you move. However, if you move both axes, each will
            > move at less than 100 setps/sec)
            >
            > -- Jerry
            >
            > > Is there any user accessible way to set/change the feed speed
            > > used for G00?
            > > thanks
            >
            > --
            > Internal Virus Database is out-of-date.
            > Checked by AVG Anti-Virus.
            > Version: 7.0.323 / Virus Database: 267.9.2/55 - Release Date: 7/21/2005
            >
            >
            >
            >
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >
            >
          • dan pines
            Art, Jerry,Luc thanks for the info. now for a related question : is the max speed also used for determining the speed of the backlash compensation move? thanks
            Message 5 of 12 , Aug 1, 2005
            • 0 Attachment
              Art, Jerry,Luc

              thanks for the info. now for a related question : is the max speed
              also used for determining the speed of the backlash compensation move?

              thanks
              dan
              --- In turbocnc@yahoogroups.com, Art Eckstein <a_eckstein@b...> wrote:
              > Dan,
              > In the config file, just set the "Max Vel" to the speed you desire!
              > This is G00 speed.
              >
              > Bubba
              >
              > At 08:44 AM 8/1/2005, you wrote:
              > >Is there any user accessible way to set/change the feed speed used
              for
              > >G00?
              > >thanks
              > >dan
              >
              >
              >
              > OLDER THAN DIRT
              > Country Bubba
              > (Actually the inventor of Country and Bubba)
              > In God We Trust
              >
              > LaGrange, GA
              >
              > http://bellsouthpwp.net/A/r/Arts_home_page/cnc/
              >
              > [Non-text portions of this message have been removed]
            • dan pines
              hi all i would appreciate some info regarding my posting below. is there any user accessible way (as opposed to programming) to slow down the backlash
              Message 6 of 12 , Aug 11, 2005
              • 0 Attachment
                hi all

                i would appreciate some info regarding my posting below.

                is there any user accessible way (as opposed to programming) to slow
                down the backlash compensation moves?

                thanks
                dan

                --- In turbocnc@yahoogroups.com, "dan pines" <dan@p...> wrote:
                >
                > Art, Jerry,Luc
                >
                > thanks for the info. now for a related question : is the max speed
                > also used for determining the speed of the backlash compensation
                move?
                >
                > thanks
                > dan
                > --- In turbocnc@yahoogroups.com, Art Eckstein <a_eckstein@b...>
                wrote:
                > > Dan,
                > > In the config file, just set the "Max Vel" to the speed you
                desire!
                > > This is G00 speed.
                > >
                > > Bubba
                > >
                > > At 08:44 AM 8/1/2005, you wrote:
                > > >Is there any user accessible way to set/change the feed speed
                used
                > for
                > > >G00?
                > > >thanks
                > > >dan
                > >
                > >
                > >
                > > OLDER THAN DIRT
                > > Country Bubba
                > > (Actually the inventor of Country and Bubba)
                > > In God We Trust
                > >
                > > LaGrange, GA
                > >
                > > http://bellsouthpwp.net/A/r/Arts_home_page/cnc/
                > >
                > > [Non-text portions of this message have been removed]
              • Antonius J.M. Groothuizen
                Dan: Linear moves use Max Vel for backlash compensation. It s done as a rapid with the usual start Vel and acceleration / deceleration applied. You can
                Message 7 of 12 , Aug 11, 2005
                • 0 Attachment
                  Dan:

                  Linear moves use Max Vel for backlash compensation. It's done as a
                  rapid with the usual start Vel and acceleration / deceleration
                  applied. You can decrease the maximum velocity reached by decreasing
                  the Start Vel and or acceleration.

                  Arc motion uses the Start Vel throughout compensation.

                  Tony
                  TurboCNC Development Team

                  --- In turbocnc@yahoogroups.com, "dan pines" <dan@p...> wrote:
                  > hi all
                  >
                  > i would appreciate some info regarding my posting below.
                  >
                  > is there any user accessible way (as opposed to programming) to
                  slow
                  > down the backlash compensation moves?
                  >
                  > thanks
                  > dan
                  >
                  > --- In turbocnc@yahoogroups.com, "dan pines" <dan@p...> wrote:
                  > >
                  > > Art, Jerry,Luc
                  > >
                  > > thanks for the info. now for a related question : is the max
                  speed
                  > > also used for determining the speed of the backlash compensation
                  > move?
                  > >
                  > > thanks
                  > > dan
                  > > --- In turbocnc@yahoogroups.com, Art Eckstein <a_eckstein@b...>
                  > wrote:
                  > > > Dan,
                  > > > In the config file, just set the "Max Vel" to the speed you
                  > desire!
                  > > > This is G00 speed.
                  > > >
                  > > > Bubba
                  > > >
                  > > > At 08:44 AM 8/1/2005, you wrote:
                  > > > >Is there any user accessible way to set/change the feed speed
                  > used
                  > > for
                  > > > >G00?
                  > > > >thanks
                  > > > >dan
                  > > >
                  > > >
                  > > >
                  > > > OLDER THAN DIRT
                  > > > Country Bubba
                  > > > (Actually the inventor of Country and Bubba)
                  > > > In God We Trust
                  > > >
                  > > > LaGrange, GA
                  > > >
                  > > > http://bellsouthpwp.net/A/r/Arts_home_page/cnc/
                  > > >
                  > > > [Non-text portions of this message have been removed]
                • Carol & Jerry Jankura
                  Hi, Dan: Since backlash moves are but a few thousanths of an inch, you could reduce the acceleration, as has been mentioned before, to slow down the velocity
                  Message 8 of 12 , Aug 11, 2005
                  • 0 Attachment
                    Hi, Dan:

                    Since backlash moves are but a few thousanths of an inch, you could reduce
                    the acceleration, as has been mentioned before, to slow down the velocity of
                    the first few steps. You might also want to consider adding a delay when you
                    switch directions. You can do that from one of the setup screens.

                    -- Jerry Jankura
                    TurboCNC Development Team


                    > i would appreciate some info regarding my posting below.
                    >
                    > is there any user accessible way (as opposed to programming)
                    > to slow down the backlash compensation moves?
                    >
                  • dan pines
                    Jerry I did all you suggest intuitively a couple of weeks ago. However, this slows down everything considerably and also plays hell with manual jogging because
                    Message 9 of 12 , Aug 11, 2005
                    • 0 Attachment
                      Jerry

                      I did all you suggest intuitively a couple of weeks ago. However,
                      this slows down everything considerably and also plays hell with
                      manual jogging because low deccelaration results in 1-2 seconds
                      passing and some extra travel between release of the arrow key and
                      actual stopping.
                      In my case, low backlash compensation speed would be meaningless time-
                      wise because of the short distance travelled and would allow faster
                      performance of other tasks. Pity it is not user settable.

                      thanks
                      dan

                      --- In turbocnc@yahoogroups.com, "Carol & Jerry Jankura"
                      <jerry.jankura@s...> wrote:
                      > Hi, Dan:
                      >
                      > Since backlash moves are but a few thousanths of an inch, you could
                      reduce
                      > the acceleration, as has been mentioned before, to slow down the
                      velocity of
                      > the first few steps. You might also want to consider adding a delay
                      when you
                      > switch directions. You can do that from one of the setup screens.
                      >
                      > -- Jerry Jankura
                      > TurboCNC Development Team
                      >
                      >
                      > > i would appreciate some info regarding my posting below.
                      > >
                      > > is there any user accessible way (as opposed to programming)
                      > > to slow down the backlash compensation moves?
                      > >
                    • jaymevillela
                      Luc: have ya solved your problem? I have same stuff heare. My machine is set to 19855 mm/min. On JOG screen, when i use ALT+arrows, the machine runs like hell,
                      Message 10 of 12 , Apr 14, 2007
                      • 0 Attachment
                        Luc: have ya solved your problem?

                        I have same stuff heare.
                        My machine is set to 19855 mm/min. On JOG screen, when i use
                        ALT+arrows, the machine runs like hell, really amazing, it made us
                        happy. But using ALT+G [1000 for example] it seems like 1/10 max speed.

                        Same ocurr on a file: G1 goes on F xxxx set, but G0 runs on same
                        speed as ALT+G JOG speed, really slower than 19855 mm/min.

                        I really searched, changed lots of things, but no with no good
                        results, problem not solved and i put back the original .ini backuped
                        file (seems like yours).

                        Thanks for help!!!

                        Ito-Brazil


                        --- In turbocnc@yahoogroups.com, "Luc Degrande" <luc.degrande@...> wrote:
                        >
                        > Hi all,
                        >
                        > after solving the PC powermanagement problem I now encounter the
                        following:
                        > G00 moves don't run at the maximum speed.
                        > G01 works fine with the specified feed and moves a lot faster than
                        G00 ( > 3
                        > times)
                        >
                        > When running the following simple file:
                        >
                        > G01 Y000.000 F8500.000
                        > G00 Y100.000
                        >
                        > the first line runs fast, the second approx 3 times slower.
                        > The fast jog is also a lot faster the the G00 moves.
                        >
                        > Is there a setting somewhere wich influences this, known bug ...?
                        > I'm sure the mechanics are fine, no lost steps etc..
                        > And I'm having a metric setup and configuration.
                        >
                        > Below are parts of ini file:
                        >
                        > Thanks,
                        > Luc.
                        >
                        >
                        > [General]
                        > IniDescription=TurboCNC 4.0 Distribution
                        > NumberOfAxes=3
                        > Start Inhibit=YES
                        > Block Inhibit=YES
                        > ConfiguredAsImperial=NO
                        > Imperial Places=4
                        > Metric_Places=8
                        > Default_Feed=50000.000000000000
                        > Home_Feed=2000.000000000000
                        > ArcFactor=1.000000000000
                        > StopOnIllegalCodes=YES
                        > Monochrome=NO
                        > Mouse Hide=YES
                        > Load_Tooling=NO
                        > Verbose=YES
                        > Sync Unit Indices=NO
                        > Sync Axis Indices=NO
                        > ListDir=.\
                        > ListExt=.CNC
                        > ToolDir=.\
                        > ToolExt=.TL
                        > Point Filename=.\POINTS.DAT
                        > ReverseDelay(ms)=5
                        > TurretIndexTime(ms)=2000
                        > ColletOpenTime(ms)=2000
                        > ColletCloseTime(ms)=2000
                        > SpindleTime(ms)=7000
                        > RelaySettleTime(ms)=100
                        > ClampDelay=15000.000000000000
                        > MachineType=MillDrill
                        > UsePentiumTimer=NO
                        > ClearMDIPrompt=NO
                        > HomeIsLimit=YES
                        > M6JogUpdateDistances=YES
                        >
                        > [Editor]
                        > First_Block=
                        > Last_Block=M30
                        > Add_First_Block=NO
                        > Add_Last_Block=NO
                        >
                        > [Dialect]
                        > LinearRapids=YES
                        > G04Letter=P
                        > G04InMS=NO
                        > ArcIJKMode=1
                        > G8xReleaseLetter=R
                        > G8xDwellLetter=P
                        > G8xDwellInMs=YES
                        > G8xPeckLetter=Q
                        > G33IsLead=YES
                        > Jump_Target=O
                        > RewindOnM30=NO
                        >
                        > [AXIS2]
                        > Designator=Y
                        > StepIncrement=0.007714840000
                        > IsLinear=True
                        > IsStep/Dir=False
                        > Phases=8
                        > Phase1=XXXX0001XXXX
                        > Phase2=XXXX0010XXXX
                        > Phase3=XXXX1010XXXX
                        > Phase4=XXXX1001XXXX
                        > Phase5=XXXX1101XXXX
                        > Phase6=XXXX1110XXXX
                        > Phase7=XXXX0110XXXX
                        > Phase8=XXXX0101XXXX
                        > Phase9=XXXXXXXXXXXX
                        > Phase10=XXXXXXXXXXXX
                        > Phase11=XXXXXXXXXXXX
                        > Phase12=XXXXXXXXXXXX
                        > Phase13=XXXXXXXXXXXX
                        > Phase14=XXXXXXXXXXXX
                        > Phase15=XXXXXXXXXXXX
                        > Phase16=XXXXXXXXXXXX
                        > PortAddress=$378
                        > Acceleration=8000.000000000000
                        > StartSpeed=1000.000000000000
                        > MaxSpeed=12000.000000000000
                        > Fast_Jog=6000.000000000000
                        > Slow_Jog=500.000000000000
                        > HomePosition=0.000000000000
                        > HomeInPositiveDir=false
                        > InvertJogKeys=NO
                        >
                      • Luc Degrande
                        Yes and no. It s been a long time and as far as I remember this is a know bug for metric users, our values are 25.4 times higher than inch values and it looks
                        Message 11 of 12 , Apr 14, 2007
                        • 0 Attachment
                          Yes and no.

                          It's been a long time and as far as I remember this is a know bug for metric
                          users, our values are 25.4 times higher than inch values and it looks like
                          tcnc get's lost for fast machines.
                          I believe it was on a "todo" list but nothing much has been done on TCNC
                          development..............

                          My new machine has a higher pitch, more torque but slower and I don't have
                          this problem anymore.

                          A feed rate of almost 20.000mm/min is just crazy, I was able to get at
                          10.000 but totally unreliable, no torque left.
                          Wich setup do you have, how many steps/sec do you have to push out of the
                          printer port?

                          A few possible solutions:
                          -Recalculate everything to inches and work in "Imperial" mode, I know not
                          easy nor elegant...
                          -Have a look at ZEUS, similar to TCNC but looks a lot better, it's not known
                          very well but it looks good, I will try it when I have time. It even has
                          "look ahead" for constant velocity contouring, a Major disadvantage of TCNC.



                          ----- Original Message -----
                          From: "jaymevillela" <jaymevillela@...>
                          To: <turbocnc@yahoogroups.com>
                          Sent: Saturday, April 14, 2007 3:39 PM
                          Subject: [turbocnc] Re: G00 speed VERY slower than G1


                          >
                          > Luc: have ya solved your problem?
                          >
                          > I have same stuff heare.
                          > My machine is set to 19855 mm/min. On JOG screen, when i use
                          > ALT+arrows, the machine runs like hell, really amazing, it made us
                          > happy. But using ALT+G [1000 for example] it seems like 1/10 max speed.
                          >
                          > Same ocurr on a file: G1 goes on F xxxx set, but G0 runs on same
                          > speed as ALT+G JOG speed, really slower than 19855 mm/min.
                          >
                          > I really searched, changed lots of things, but no with no good
                          > results, problem not solved and i put back the original .ini backuped
                          > file (seems like yours).
                          >
                          > Thanks for help!!!
                          >
                          > Ito-Brazil
                          >
                          >
                          > --- In turbocnc@yahoogroups.com, "Luc Degrande" <luc.degrande@...> wrote:
                          > >
                          > > Hi all,
                          > >
                          > > after solving the PC powermanagement problem I now encounter the
                          > following:
                          > > G00 moves don't run at the maximum speed.
                          > > G01 works fine with the specified feed and moves a lot faster than
                          > G00 ( > 3
                          > > times)
                          > >
                          > > When running the following simple file:
                          > >
                          > > G01 Y000.000 F8500.000
                          > > G00 Y100.000
                          > >
                          > > the first line runs fast, the second approx 3 times slower.
                          > > The fast jog is also a lot faster the the G00 moves.
                          > >
                          > > Is there a setting somewhere wich influences this, known bug ...?
                          > > I'm sure the mechanics are fine, no lost steps etc..
                          > > And I'm having a metric setup and configuration.
                          > >
                          > > Below are parts of ini file:
                          > >
                          > > Thanks,
                          > > Luc.
                          > >
                          > >
                          > > [General]
                          > > IniDescription=TurboCNC 4.0 Distribution
                          > > NumberOfAxes=3
                          > > Start Inhibit=YES
                          > > Block Inhibit=YES
                          > > ConfiguredAsImperial=NO
                          > > Imperial Places=4
                          > > Metric_Places=8
                          > > Default_Feed=50000.000000000000
                          > > Home_Feed=2000.000000000000
                          > > ArcFactor=1.000000000000
                          > > StopOnIllegalCodes=YES
                          > > Monochrome=NO
                          > > Mouse Hide=YES
                          > > Load_Tooling=NO
                          > > Verbose=YES
                          > > Sync Unit Indices=NO
                          > > Sync Axis Indices=NO
                          > > ListDir=.\
                          > > ListExt=.CNC
                          > > ToolDir=.\
                          > > ToolExt=.TL
                          > > Point Filename=.\POINTS.DAT
                          > > ReverseDelay(ms)=5
                          > > TurretIndexTime(ms)=2000
                          > > ColletOpenTime(ms)=2000
                          > > ColletCloseTime(ms)=2000
                          > > SpindleTime(ms)=7000
                          > > RelaySettleTime(ms)=100
                          > > ClampDelay=15000.000000000000
                          > > MachineType=MillDrill
                          > > UsePentiumTimer=NO
                          > > ClearMDIPrompt=NO
                          > > HomeIsLimit=YES
                          > > M6JogUpdateDistances=YES
                          > >
                          > > [Editor]
                          > > First_Block=
                          > > Last_Block=M30
                          > > Add_First_Block=NO
                          > > Add_Last_Block=NO
                          > >
                          > > [Dialect]
                          > > LinearRapids=YES
                          > > G04Letter=P
                          > > G04InMS=NO
                          > > ArcIJKMode=1
                          > > G8xReleaseLetter=R
                          > > G8xDwellLetter=P
                          > > G8xDwellInMs=YES
                          > > G8xPeckLetter=Q
                          > > G33IsLead=YES
                          > > Jump_Target=O
                          > > RewindOnM30=NO
                          > >
                          > > [AXIS2]
                          > > Designator=Y
                          > > StepIncrement=0.007714840000
                          > > IsLinear=True
                          > > IsStep/Dir=False
                          > > Phases=8
                          > > Phase1=XXXX0001XXXX
                          > > Phase2=XXXX0010XXXX
                          > > Phase3=XXXX1010XXXX
                          > > Phase4=XXXX1001XXXX
                          > > Phase5=XXXX1101XXXX
                          > > Phase6=XXXX1110XXXX
                          > > Phase7=XXXX0110XXXX
                          > > Phase8=XXXX0101XXXX
                          > > Phase9=XXXXXXXXXXXX
                          > > Phase10=XXXXXXXXXXXX
                          > > Phase11=XXXXXXXXXXXX
                          > > Phase12=XXXXXXXXXXXX
                          > > Phase13=XXXXXXXXXXXX
                          > > Phase14=XXXXXXXXXXXX
                          > > Phase15=XXXXXXXXXXXX
                          > > Phase16=XXXXXXXXXXXX
                          > > PortAddress=$378
                          > > Acceleration=8000.000000000000
                          > > StartSpeed=1000.000000000000
                          > > MaxSpeed=12000.000000000000
                          > > Fast_Jog=6000.000000000000
                          > > Slow_Jog=500.000000000000
                          > > HomePosition=0.000000000000
                          > > HomeInPositiveDir=false
                          > > InvertJogKeys=NO
                          > >
                          >
                          >
                          >
                          >
                          >
                          >
                          >
                          > Yahoo! Groups Links
                          >
                          >
                          >
                        Your message has been successfully submitted and would be delivered to recipients shortly.