Loading ...
Sorry, an error occurred while loading the content.
 

Triton 500

Expand Messages
  • lelin44
    Turned on my Triton 500 to see if I had a particular map loaded and all I get is a white screen with the battery indicator showing fully charged. Any ideas on
    Message 1 of 19 , Feb 1, 2009
      Turned on my Triton 500 to see if I had a particular map loaded and
      all I get is a white screen with the battery indicator showing fully
      charged. Any ideas on what to do next?
      thanks
      Lee
    • Eddyline Steve
      Same here. The only thing you can do is take out the battery to shut if off. I sent mine back and the next one did the same thing. From: lelin44
      Message 2 of 19 , Feb 1, 2009

        Same here.  The only thing you can do is take out the battery to shut if off.  I sent mine back and the next one did the same thing.

         

        From: lelin44 [mailto:lelin44@...]
        Sent: Sunday, February 01, 2009 10:08 PM
        To: tritongps@yahoogroups.com
        Subject: [tritongps] Triton 500

         

        Turned on my Triton 500 to see if I had a particular map loaded and
        all I get is a white screen with the battery indicator showing fully
        charged. Any ideas on what to do next?
        thanks
        Lee

      • Eddyline Steve
        Forgot to mention. It happened to me on the first day of a ten day trip. You can imagine my frosting. From: lelin44 [mailto:lelin44@yahoo.com] Sent: Sunday,
        Message 3 of 19 , Feb 1, 2009

          Forgot to mention. It happened to me on the first day of a ten day trip.  You can imagine my frosting.

           

          From: lelin44 [mailto:lelin44@...]
          Sent: Sunday, February 01, 2009 10:08 PM
          To: tritongps@yahoogroups.com
          Subject: [tritongps] Triton 500

           

          Turned on my Triton 500 to see if I had a particular map loaded and
          all I get is a white screen with the battery indicator showing fully
          charged. Any ideas on what to do next?
          thanks
          Lee

        • Ed Gelb
          Lee, Chances are that you have a mishap with your SD card. You must try to get back into the GPS to Clear Memory and Do A Factory Reset. Give this a try... (I
          Message 4 of 19 , Feb 1, 2009
            Lee,

            Chances are that you have a mishap with your SD card.  You must try to get back into the GPS to Clear Memory and Do A Factory Reset.

            Give this a try... (I cannot guarantee that this will work but at least you cannot harm the unit.)

            1. Start VantagePoint.

            2. Attach your USB cable to your Triton BUT "DO NOT TURN IT ON".

            3. Now Turn on your Triton 400 500 1500 or 2000 and select "Connect to PC".

            4. Connect the USB cable to your computer and see if the unit will now connect.

            5. If successful in VP Click the "MyGPS" tab.

            6. In the toolbar enter the 'synchronize' button (this button has double arrows).

            7. It will show your backups in the pop-up window. It will also show that there may be no files on your Triton to be synced.

            8. In the pop-up pane, enter the selection needed to sync your unit to the VantagePoint program.

            JG



            --- In tritongps@yahoogroups.com, "lelin44" <lelin44@...> wrote:
            >
            > Turned on my Triton 500 to see if I had a particular map loaded and
            > all I get is a white screen with the battery indicator showing fully
            > charged. Any ideas on what to do next?
            > thanks
            > Lee
            >
          • Lee or Linda Doughty
            Hi Ed, thanks for the response on my Triton 500---you have helped me in the past and over the last year I have gained enough knowledge to make using the gps
            Message 5 of 19 , Feb 1, 2009
              Hi Ed,
              thanks for the response on my Triton 500---you have helped me in the past and over the last year I have gained enough knowledge to make using the gps helpful instead of being extreme fustration. 
              I followed your instructions---however when I turn on the triton 500 it just goes to a white screen and I am unable to select anyting until I connect the usb cable to the computer and I can then select connect to computer.  I was able to download the 2 maps I wanted but I am still unable to get the gps to show anything but a white screen. (I did do the synchronize excerise you mentioned.)

              How do you do the hard reboot--perhaps that is what I need to do.

              Lee

              --- On Sun, 2/1/09, Ed Gelb <orders@...> wrote:
              From: Ed Gelb <orders@...>
              Subject: [tritongps] Re: Triton 500
              To: tritongps@yahoogroups.com
              Date: Sunday, February 1, 2009, 8:46 PM

              Lee,

              Chances are that you have a mishap with your SD card.  You must try to get back into the GPS to Clear Memory and Do A Factory Reset.

              Give this a try... (I cannot guarantee that this will work but at least you cannot harm the unit.)

              1. Start VantagePoint.

              2. Attach your USB cable to your Triton BUT "DO NOT TURN IT ON".

              3. Now Turn on your Triton 400 500 1500 or 2000 and select "Connect to PC".

              4. Connect the USB cable to your computer and see if the unit will now connect.

              5. If successful in VP Click the "MyGPS" tab.

              6. In the toolbar enter the 'synchronize' button (this button has double arrows).

              7. It will show your backups in the pop-up window. It will also show that there may be no files on your Triton to be synced.

              8. In the pop-up pane, enter the selection needed to sync your unit to the VantagePoint program.

              JG



              --- In tritongps@yahoogrou ps.com, "lelin44" <lelin44@...> wrote:
              >
              > Turned on my Triton 500 to see if I had a particular map loaded and
              > all I get is a white screen with the battery indicator showing fully
              > charged. Any ideas on what to do next?
              > thanks
              > Lee
              >

            • Ed Gelb
              Lee, If I read your message correctly .. you are getting a connection to exist between the GPS and VP. If that is so.. then while in VP .. click on CONNECT and
              Message 6 of 19 , Feb 2, 2009
                Lee,

                If I read your message correctly .. you are getting a connection to exist between the GPS and VP.

                If that is so.. then while in VP .. click on CONNECT and firmware and please do another install of the Version 1.56 of the T500 firmware.

                This new install will recheck the EEPROM and redo the low level format, etc. and should solve the problem.

                Keep us all a apprized of the situation.

                JG (Jungle Ghost)



                --- In tritongps@yahoogroups.com, Lee or Linda Doughty <lelin44@...> wrote:
                >
                > Hi Ed,
                > thanks for the response on my Triton 500---you have helped me in the past and over the last year I have gained enough knowledge to make using the gps helpful instead of being extreme frustration.
                > I followed your instructions---however when I turn on the triton 500 it just goes to a white screen and I am unable to select anything until I connect the usb cable to the computer and I can then select connect to computer. I was able to download the 2 maps I wanted but I am still unable to get the gps to show anything but a white screen. (I did do the synchronize exercise you mentioned.)
                >
                > How do you do the hard reboot--perhaps that is what I need to do.
                >
                > Lee
                >
                > --- On Sun, 2/1/09, Ed Gelb orders@... wrote:
                > From: Ed Gelb orders@...
                > Subject: [tritongps] Re: Triton 500
                > To: tritongps@yahoogroups.com
                > Date: Sunday, February 1, 2009, 8:46 PM
                >
                >
                >
                >
                >
                >
                >
                >
                >
                >
                >
                > Lee,
                >
                > Chances are that you have a mishap with your SD card. You must try to get back into the GPS to Clear Memory and Do A Factory Reset.
                >
                > Give this a try... (I cannot guarantee that this will work but at least you cannot harm the unit.)
                >
                > 1. Start VantagePoint.
                >
                > 2. Attach your USB cable to your Triton BUT "DO
                > NOT TURN IT ON".
                >
                > 3. Now Turn on your Triton 400 500 1500 or 2000 and
                > select "Connect to PC".
                >
                > 4. Connect the USB cable to your computer and see
                > if the unit will now connect.
                >
                > 5. If successful in VP Click the
                > "MyGPS" tab.
                >
                > 6. In the toolbar enter the 'synchronize' button
                > (this button has double arrows).
                >
                > 7. It will show your backups in the pop-up
                > window. It will also show that there may be no files on your Triton to be synced.
                >
                > 8. In the pop-up pane, enter the selection needed
                > to sync your unit to the VantagePoint program.
                >
                > JG
                >
                >
                > --- In tritongps@yahoogrou ps.com, "lelin44" lelin44@ wrote:
                > >
                > > Turned on my Triton 500 to see if I had a particular map loaded and
                > > all I get is a white screen with the battery indicator showing fully
                > > charged. Any ideas on what to do next?
                > > thanks
                > > Lee
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.