Loading ...
Sorry, an error occurred while loading the content.

Re: PTT through FET not working on a rangr mobile radio

Expand Messages
  • Rob
    ... Hmmm... RFI... maybe I should put the covers back on the radio. I am using a dummy load. And I also cranked the power down to almost minimum. But still
    Message 1 of 8 , May 6 11:36 AM
    • 0 Attachment
      --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
      Hmmm... RFI... maybe I should put the covers back on the radio.
      I am using a dummy load. And I also cranked the power down to almost minimum. But still this radio puts out quite a punch. I have some ferrite cores also.. Let my do some more testing... My cable going to the radio is also about 8 feet long. But it is shielded...
      Again thanks for the quick response...

      >
      > > sure something is not intermittent on the PTT could the software be
      > > detecting some type of audio or Squelch and not holding the PTT control
      > > signal steady on the controller side of things??
      >
      > In diagnostic mode, it just tells the tracker to turn PTT on, and the
      > tracker turns on that pin. There's no other logic to it.
      >
      > I'd check for possible RFI problems. If you can, put the radio on its
      > lowest power setting and keep the tracker away from the antenna.
      >
      > Scott
      >
    • Rob
      ... Not having any luck... I sealed up the radio.. added ferrite cores to cable. The easiest work around my be a small 12v relay. But not having a parts store
      Message 2 of 8 , May 6 1:46 PM
      • 0 Attachment
        --- In tracker2@yahoogroups.com, "Rob" <rhenry@...> wrote:
        Not having any luck...
        I sealed up the radio.. added ferrite cores to cable.
        The easiest work around my be a small 12v relay. But not having a parts store within 60 miles. I am going to have to wait or scavenge one out of some old equipment. Unless you have any other suggestions?

        >
        > --- In tracker2@yahoogroups.com, Scott Miller <scott@> wrote:
        > Hmmm... RFI... maybe I should put the covers back on the radio.
        > I am using a dummy load. And I also cranked the power down to almost minimum. But still this radio puts out quite a punch. I have some ferrite cores also.. Let my do some more testing... My cable going to the radio is also about 8 feet long. But it is shielded...
        > Again thanks for the quick response...
        >
        > >
        > > > sure something is not intermittent on the PTT could the software be
        > > > detecting some type of audio or Squelch and not holding the PTT control
        > > > signal steady on the controller side of things??
        > >
        > > In diagnostic mode, it just tells the tracker to turn PTT on, and the
        > > tracker turns on that pin. There's no other logic to it.
        > >
        > > I'd check for possible RFI problems. If you can, put the radio on its
        > > lowest power setting and keep the tracker away from the antenna.
        > >
        > > Scott
        > >
        >
      • Wes Freeman
        Hi Rob, How about trying this: Disconnect the radio and then measure the processor pin that drives the gate of the 2N7000. It should either be a steady 0V or
        Message 3 of 8 , May 6 2:51 PM
        • 0 Attachment
          Hi Rob,

          How about trying this:

          Disconnect the radio and then measure the processor
          pin that drives the gate of the 2N7000. It should
          either be a steady 0V or 5V when you control it from
          the config program.

          Then connect the radio and measure again. If the voltages
          are still steady, that should tell you it's not RFI.

          You can also connect your 100 Ohm resistor from the 12V
          supply (or whatever supply you're using for the Tracker) to
          the PTT output of the Tracker. If the voltage swings from
          12V to near zero Volts, then the 2N7000 is working.

          BTW, did the radio transmit when you shorted PTT to ground
          with the 100 Ohm resistor?

          Cheers,

          Wes Freeman
          KG6POV

          Rob wrote:
          Scott,  Thanks for replying so quickly...  I tried the 100ohm resistor in-line and did not help.  I also Measured the current and its only like 10ma.  I am going to double check my tracker2 with another radio and make sure something is not intermittent on the PTT could the software be detecting some type of audio or Squelch and not holding the PTT control signal steady on the controller side of things??
          
          
          
          --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
            
          How much current does it need?  The 2N7002 can handle a fair amount for 
          a little MOSFET.  All of the ferrites on the board are there for RFI 
          suppression.
          
          Will it transmit if you use a 100 ohm resistor instead of a jumper wire? 
            If so, can you try putting the 100 ohm resistor in line with the PTT 
          on the tracker?
          
          Scott
          
          Rob wrote:
              
          
          I can manually short the PTT to Ground and all is well but when running 
          the diagnostic program and keying the PTT I get oscillations on the PTT 
          relay in the radio.
          
          Is the PTT circuit lacking the ability to handle the current needed to 
          keep the PTT Relay engaged?
          
          Does L2 help protect the FET?
          or could it possibly be lowering the current running through the FET to 
          the PTT output?
          
          Possible work around? Can the Power Relay be used to supply ground to 
          the PTT Pin?
          
          The Radio is a 110 Watt RANGR with Modified Input Plug and everything 
          checks out fine on the radio end.
          
          
                
          
          
          
          ------------------------------------
          
          Yahoo! Groups Links
          
          <*> To visit your group on the web, go to:
              http://groups.yahoo.com/group/tracker2/
          
          <*> Your email settings:
              Individual Email | Traditional
          
          <*> To change settings online go to:
              http://groups.yahoo.com/group/tracker2/join
              (Yahoo! ID required)
          
          <*> To change settings via email:
              mailto:tracker2-digest@yahoogroups.com 
              mailto:tracker2-fullfeatured@yahoogroups.com
          
          <*> To unsubscribe from this group, send an email to:
              tracker2-unsubscribe@yahoogroups.com
          
          <*> Your use of Yahoo! Groups is subject to:
              http://docs.yahoo.com/info/terms/
          
          
            
        • Rob
          Hey you guys know that pin 9 on the serial connector looks like a six upside down..... LOL.... Sorry had Ground running to pin 9 instead of pin 6... All
          Message 4 of 8 , May 6 3:53 PM
          • 0 Attachment
            Hey you guys know that pin 9 on the serial connector looks like a six upside down..... LOL.... Sorry had Ground running to pin 9 instead of pin 6... All works now...
            Thanks for you input...



            --- In tracker2@yahoogroups.com, Wes Freeman <wes.freeman@...> wrote:
            >
            > Hi Rob,
            >
            > How about trying this:
            >
            > Disconnect the radio and then measure the processor
            > pin that drives the gate of the 2N7000. It should
            > either be a steady 0V or 5V when you control it from
            > the config program.
            >
            > Then connect the radio and measure again. If the voltages
            > are still steady, that should tell you it's not RFI.
            >
            > You can also connect your 100 Ohm resistor from the 12V
            > supply (or whatever supply you're using for the Tracker) to
            > the PTT output of the Tracker. If the voltage swings from
            > 12V to near zero Volts, then the 2N7000 is working.
            >
            > BTW, did the radio transmit when you shorted PTT to ground
            > with the 100 Ohm resistor?
            >
            > Cheers,
            >
            > Wes Freeman
            > KG6POV
            >
            > Rob wrote:
            >
            > >Scott, Thanks for replying so quickly... I tried the 100ohm resistor in-line and did not help. I also Measured the current and its only like 10ma. I am going to double check my tracker2 with another radio and make sure something is not intermittent on the PTT could the software be detecting some type of audio or Squelch and not holding the PTT control signal steady on the controller side of things??
            > >
            > >
            > >
            > >--- In tracker2@yahoogroups.com, Scott Miller <scott@> wrote:
            > >
            > >
            > >>How much current does it need? The 2N7002 can handle a fair amount for
            > >>a little MOSFET. All of the ferrites on the board are there for RFI
            > >>suppression.
            > >>
            > >>Will it transmit if you use a 100 ohm resistor instead of a jumper wire?
            > >> If so, can you try putting the 100 ohm resistor in line with the PTT
            > >>on the tracker?
            > >>
            > >>Scott
            > >>
            > >>Rob wrote:
            > >>
            > >>
            > >>>
            > >>>I can manually short the PTT to Ground and all is well but when running
            > >>>the diagnostic program and keying the PTT I get oscillations on the PTT
            > >>>relay in the radio.
            > >>>
            > >>>Is the PTT circuit lacking the ability to handle the current needed to
            > >>>keep the PTT Relay engaged?
            > >>>
            > >>>Does L2 help protect the FET?
            > >>>or could it possibly be lowering the current running through the FET to
            > >>>the PTT output?
            > >>>
            > >>>Possible work around? Can the Power Relay be used to supply ground to
            > >>>the PTT Pin?
            > >>>
            > >>>The Radio is a 110 Watt RANGR with Modified Input Plug and everything
            > >>>checks out fine on the radio end.
            > >>>
            > >>>
            > >>>
            > >>>
            > >
            > >
            > >
            > >
            > >------------------------------------
            > >
            > >Yahoo! Groups Links
            > >
            > >
            > >
            > >
            > >
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.