Loading ...
Sorry, an error occurred while loading the content.

Re: Otwincfg weirdness, possible bug?

Expand Messages
  • dondorgram
    This has bugged me for last several months, but I was too lazy to bring it up. For us senior folks who keep switching between profiles because we think we
    Message 1 of 6 , Apr 1 1:42 PM
    • 0 Attachment
      This has "bugged" me for last several months, but I was too lazy to bring it up. For us "senior" folks who keep switching between profiles because we think we might have forgotten something in one or the other, it means always reentering limit numbers as a last step. Kind of annoying. Thanks to Garrett and James for raising it. Interestingly I had never tried the English setting.

      Scott, once you fix it, could you mention it to the group.

      Graham VE6GW


      --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
      >
      > Yeah, I may have missed another rounding problem. I'll check it out,
      > see if there's an easy fix.
      >
      > Scott
      >
      > Garrett Sloan wrote:
      > >
      > >
      > > I've tried it on two machines now, and it's acting the same on both,
      > > when in OTWinCfg, if under waypoint output "limit to" is selected, and
      > > units are set to metric, if you enter say 10 miles as the distance and
      > > change the tabs between profile 1 & profile 2, the value in each begins
      > > to decrement towards zero, and when it hits zero "limit to" disables.
      > > It doesn't do this in English mode, so I'm guessing it has something to
      > > do with a rounding issue with metric conversion possibly?
      > >
      > > anyone else observe this?
      > >
      > > Garrett
      > > VE6RKY
      > >
      > >
      >
    • Garrett Sloan
      If your in there tweaking and fixing otwincfg.exe, I m not sure if this is the best place to suggest it, but possibly could you add the ability to enter or
      Message 2 of 6 , Apr 1 2:15 PM
      • 0 Attachment
        If your in there "tweaking" and fixing otwincfg.exe, I'm not sure if this is the best place to suggest it, but possibly could you add the ability to enter or view the TXLEVEL value as a real value other than only a slider? Specifically I know that for my setup a TXLEVEL of 247 is 3.5khz deviation, but if I update the firmware and flash the OT2, I have to then go into term and set the TXLEVEL in profile 1&2 then open otwincfg again to have it "stored" in my backup cfg file.

        Another "feature" that would be nice for testing (especially when configuring profile switching) would be if it was possible to add a 3rd condition to the parameter PROFILE. Since editing profile switching parameters via messages or a term program isn't possible, is would be nice if sending the command PROFILE 1 would manually select profile 1, sending PROFILE 2 would manually select profile 2 and possibly sending PROFILE 0 would "enable" automatic profile switching based on the defined parameters.
        I've had a couple of times when it would be nice to manually switch to a specific contradicting my profile switching settings for testing, and this isn't currently possible from what I've been able to see.

        Your going to hate having ever sold me a OT2 one of these days lol.

        Garrett
        VE6RKY

        --- In tracker2@yahoogroups.com, "dondorgram" <walker.graham@...> wrote:
        >
        > This has "bugged" me for last several months, but I was too lazy to bring it up. For us "senior" folks who keep switching between profiles because we think we might have forgotten something in one or the other, it means always reentering limit numbers as a last step. Kind of annoying. Thanks to Garrett and James for raising it. Interestingly I had never tried the English setting.
        >
        > Scott, once you fix it, could you mention it to the group.
        >
        > Graham VE6GW
        >
        >
        > --- In tracker2@yahoogroups.com, Scott Miller <scott@> wrote:
        > >
        > > Yeah, I may have missed another rounding problem. I'll check it out,
        > > see if there's an easy fix.
        > >
        > > Scott
        > >
        > > Garrett Sloan wrote:
        > > >
        > > >
        > > > I've tried it on two machines now, and it's acting the same on both,
        > > > when in OTWinCfg, if under waypoint output "limit to" is selected, and
        > > > units are set to metric, if you enter say 10 miles as the distance and
        > > > change the tabs between profile 1 & profile 2, the value in each begins
        > > > to decrement towards zero, and when it hits zero "limit to" disables.
        > > > It doesn't do this in English mode, so I'm guessing it has something to
        > > > do with a rounding issue with metric conversion possibly?
        > > >
        > > > anyone else observe this?
        > > >
        > > > Garrett
        > > > VE6RKY
        > > >
        > > >
        > >
        >
      • Scott Miller
        I think I ve got the rounding errors in the profile screen fixed - they should now stay at the closest value and not drift as they re loaded and saved. I m
        Message 3 of 6 , Apr 1 3:36 PM
        • 0 Attachment
          I think I've got the rounding errors in the profile screen fixed - they
          should now stay at the closest value and not drift as they're loaded and
          saved.

          I'm probably not going to be adding a lot of new features to otwincfg
          for a while; there's a rewrite in progress that'll totally redo the
          layout and allow for things like translations into other languages, and
          I don't want it to be a moving target.

          There's already a PROFILE command to set the profile manually, but it
          doesn't disable the profile switching. That will probably need to be a
          separate command since there are cases when you might want to switch to
          the other profile but let it switch back automatically.

          Scott

          Garrett Sloan wrote:
          >
          >
          > If your in there "tweaking" and fixing otwincfg.exe, I'm not sure if
          > this is the best place to suggest it, but possibly could you add the
          > ability to enter or view the TXLEVEL value as a real value other than
          > only a slider? Specifically I know that for my setup a TXLEVEL of 247 is
          > 3.5khz deviation, but if I update the firmware and flash the OT2, I have
          > to then go into term and set the TXLEVEL in profile 1&2 then open
          > otwincfg again to have it "stored" in my backup cfg file.
          >
          > Another "feature" that would be nice for testing (especially when
          > configuring profile switching) would be if it was possible to add a 3rd
          > condition to the parameter PROFILE. Since editing profile switching
          > parameters via messages or a term program isn't possible, is would be
          > nice if sending the command PROFILE 1 would manually select profile 1,
          > sending PROFILE 2 would manually select profile 2 and possibly sending
          > PROFILE 0 would "enable" automatic profile switching based on the
          > defined parameters.
          > I've had a couple of times when it would be nice to manually switch to a
          > specific contradicting my profile switching settings for testing, and
          > this isn't currently possible from what I've been able to see.
          >
          > Your going to hate having ever sold me a OT2 one of these days lol.
          >
          > Garrett
          > VE6RKY
          >
          > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
          > "dondorgram" <walker.graham@...> wrote:
          > >
          > > This has "bugged" me for last several months, but I was too lazy to
          > bring it up. For us "senior" folks who keep switching between profiles
          > because we think we might have forgotten something in one or the other,
          > it means always reentering limit numbers as a last step. Kind of
          > annoying. Thanks to Garrett and James for raising it. Interestingly I
          > had never tried the English setting.
          > >
          > > Scott, once you fix it, could you mention it to the group.
          > >
          > > Graham VE6GW
          > >
          > >
          > > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
          > Scott Miller <scott@> wrote:
          > > >
          > > > Yeah, I may have missed another rounding problem. I'll check it out,
          > > > see if there's an easy fix.
          > > >
          > > > Scott
          > > >
          > > > Garrett Sloan wrote:
          > > > >
          > > > >
          > > > > I've tried it on two machines now, and it's acting the same on both,
          > > > > when in OTWinCfg, if under waypoint output "limit to" is
          > selected, and
          > > > > units are set to metric, if you enter say 10 miles as the
          > distance and
          > > > > change the tabs between profile 1 & profile 2, the value in each
          > begins
          > > > > to decrement towards zero, and when it hits zero "limit to" disables.
          > > > > It doesn't do this in English mode, so I'm guessing it has
          > something to
          > > > > do with a rounding issue with metric conversion possibly?
          > > > >
          > > > > anyone else observe this?
          > > > >
          > > > > Garrett
          > > > > VE6RKY
          > > > >
          > > > >
          > > >
          > >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.