Loading ...
Sorry, an error occurred while loading the content.

Re: [tracker2] Re: OT2 is stripping non printable caracters to PC

Expand Messages
  • Scott Miller
    The recording was clipped pretty badly (or else everyone s just really overdeviating) but I got enough to find the problem. It s a bug in the handling of
    Message 1 of 7 , Dec 4, 2008
    • 0 Attachment
      The recording was clipped pretty badly (or else everyone's just really
      overdeviating) but I got enough to find the problem. It's a bug in the
      handling of third-party Mic-E packets - the destination call is used to
      store part of the latitude, but it's trying to use the destination call
      of the actual packet and not the third-party message encapsulated in the
      packet.

      I'll have a fix soon. Thanks for grabbing the samples.

      Scottt

      johannes_bo wrote:
      >
      >
      > Hi Scott,
      >
      > It seems to affect all LA stations which uses MICE format (of course
      > the location(s) we are in).
      > A sample is uploaded to http://johannesbo.net/Downloads/audiolog.zip
      > <http://johannesbo.net/Downloads/audiolog.zip>
      > Hope this is not too disturbed as it is captured on a HT and fed into
      > my laptop's mic port due to a lack of line input here.
      >
      > An other way to test it, is to set up an IGATE and gate LA stations
      > only.
      >
      > Johannes, LA4JAA
      >
      > Scott Miller wrote:
      > >
      > > Hi Johannes,
      > >
      > > Any chance you could capture some of this audio so I can do an
      > > end-to-end test and see if I can duplicate the problem? It's
      > easier
      > > than working from captures that might be missing characters.
      > >
      > > Scott
      > >
      > > johannes_bo wrote:
      > > >
      > > >
      > > > To overcome this issue I started to include $PMGLWPL info as an
      > > > option but found another issue when I started to decode the
      > protocol.
      > > > The $GPWPL and $PMGNWPL is far off position and also includes a
      > > > letter in Lat position:
      > > >
      > > > Example 1:
      > > > Original beacon: LA1VNA>V0RPY3,WIDE1-1,WIDE2-2:'{4vl <0x1c>K\]
      > > > Original position: 60°20.93' N 5°24.90' E
      > > > T2-135 Output:
      > > > LA4JAA>APU25N,LD4ST*:}LA1VNA>V0RPY3,TCPIP,LA4JAA*:'{4vl K\]
      > > > $GPWPL,0052.5N,S,09524.90,E,LA1VNA*4C
      > > > $PMGNWPL,0052.5N,S,09524.90,E,,F,LA1VNA, ,x*51
      > > >
      > > > Example 2:
      > > > Original beacon: LA5HH-9>V0RUR7,WIDE1-1,WIDE2-1:`{.Al!k>/"4P}
      > > > Original position: 60°25.27' N 5°18.37' E
      > > > T2-135 Output:
      > > > !LA4JAA>APU25N,LD4ST:}LA5HH-9>V0RUR7,TCPIP,LA4JAA*:`{.Al!k>/"4P}
      > > > !$GPWPL,0052.5N,S,09518.37,E,LA5HH-9*07
      > > > !$PMGNWPL,0052.5N,S,09518.37,E,187,F,LA5HH-9, ,f*3A
      > > >
      > > > Johannes, LA4JAA
      > > >
      > > > >
      > > > > Hi
      > > > > I am writing an application to plot stations in OZI Explorer
      > but
      > > > got
      > > > > some errors in decoding the MICE format.
      > > > >
      > > > > As I can see in a plain terminal program, OT2 is stripping off
      > the
      > > > > nonprintable caracters. In KISS mode, which I have not
      > implemented,
      > > > is
      > > > > not affected.
      > > > >
      > > > > Any suggestion to overcome this issue?
      > > > >
      > > > > Johannes, LA4JAA
      > > > >
      > > >
      > > >
      > >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.