Loading ...
Sorry, an error occurred while loading the content.
 

Re: [tracker2] PHG with Temperature

Expand Messages
  • FUJIURA Toyonori
    Thank you Keith, ... I think this format is wrong. PHG should be followed by voltage and temperature. ... No, I change the setiing manually. ... Thank you for
    Message 1 of 10 , Sep 27, 2008
      Thank you Keith,

      2008/9/27 Keith VE7GDH <ve7gdh@...>:
      > 2008-09-27 10:15:24 UTC:
      > JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
      > :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA

      I think this format is wrong.
      PHG should be followed by voltage and temperature.

      > 2008-09-27 10:22:08 UTC:
      > JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
      > :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
      >
      > Then later the PHG is gone. Are you using profile switching? Perhaps you
      > have voltage and temperature enabled in one profile but not the other.

      No, I change the setiing manually.

      > Also, what happens if you send the PHG as status text in every second
      > transmission instead of in a beacon comment every transmission?
      > Also, it seems to be beaconing every minute or so most of the time. Is
      > that just while you are testing?

      Thank you for your warning.
      Now I send the packet every ten minutesfor testing.

      When all my packets send to Internet through nearby IGATE,
      I'll change the interval to 30min.

      Thank you.
      --
      FUJIURA Toyonori mailto:toyokun@...
    • Patrick Domack
      The issue here is that it s hardcoded in the software, to add altitude, then temp, volt, hdoc, comment I changed my firmware to do it as, comment, temp, volt,
      Message 2 of 10 , Sep 27, 2008
        The issue here is that it's hardcoded in the software, to add
        altitude, then temp, volt, hdoc, comment

        I changed my firmware to do it as, comment, temp, volt, hdoc,
        altitude, but then the balloon people would get upset.

        I was just thinking of a checkbox that says to put the comment before
        or after the extra text, so it would work for both people.

        But yes, if your running the normal firmware, you will be stuck with
        having everything off, in order to use the comment to insert special
        stuff like that.

        If you would like, I can send you the firmware I am using so it will
        work for you now.

        Quoting FUJIURA Toyonori <toyokun@...>:

        > Thank you Keith,
        >
        > 2008/9/27 Keith VE7GDH <ve7gdh@...>:
        >> 2008-09-27 10:15:24 UTC:
        >> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
        >> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
        >
        > I think this format is wrong.
        > PHG should be followed by voltage and temperature.
        >
        >> 2008-09-27 10:22:08 UTC:
        >> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
        >> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
        >>
        >> Then later the PHG is gone. Are you using profile switching? Perhaps you
        >> have voltage and temperature enabled in one profile but not the other.
        >
        > No, I change the setiing manually.
        >
        >> Also, what happens if you send the PHG as status text in every second
        >> transmission instead of in a beacon comment every transmission?
        >> Also, it seems to be beaconing every minute or so most of the time. Is
        >> that just while you are testing?
        >
        > Thank you for your warning.
        > Now I send the packet every ten minutesfor testing.
        >
        > When all my packets send to Internet through nearby IGATE,
        > I'll change the interval to 30min.
        >
        > Thank you.
        > --
        > FUJIURA Toyonori mailto:toyokun@...
        >
      • FUJIURA Toyonori
        Ok, I understood. Please send me the firmware because I want to try it. Also I found a source code for this firmware in freepository.com. But I do not have the
        Message 3 of 10 , Sep 27, 2008
          Ok, I understood.

          Please send me the firmware because I want to try it.

          Also I found a source code for this firmware in freepository.com.
          But I do not have the experience of making the firmware for the
          built-in computer.
          If I can, please tell me how to build the firmware from the source code.
          I'll try to resolv future problems.

          2008/9/28 Patrick Domack <patrickdk@...>:
          > The issue here is that it's hardcoded in the software, to add
          > altitude, then temp, volt, hdoc, comment
          >
          > I changed my firmware to do it as, comment, temp, volt, hdoc,
          > altitude, but then the balloon people would get upset.
          >
          > I was just thinking of a checkbox that says to put the comment before
          > or after the extra text, so it would work for both people.
          >
          > But yes, if your running the normal firmware, you will be stuck with
          > having everything off, in order to use the comment to insert special
          > stuff like that.
          >
          > If you would like, I can send you the firmware I am using so it will
          > work for you now.
          >
          > Quoting FUJIURA Toyonori <toyokun@...>:
          >
          >> Thank you Keith,
          >>
          >> 2008/9/27 Keith VE7GDH <ve7gdh@...>:
          >>> 2008-09-27 10:15:24 UTC:
          >>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
          >>> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
          >>
          >> I think this format is wrong.
          >> PHG should be followed by voltage and temperature.
          >>
          >>> 2008-09-27 10:22:08 UTC:
          >>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
          >>> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
          >>>
          >>> Then later the PHG is gone. Are you using profile switching? Perhaps you
          >>> have voltage and temperature enabled in one profile but not the other.
          >>
          >> No, I change the setiing manually.
          >>
          >>> Also, what happens if you send the PHG as status text in every second
          >>> transmission instead of in a beacon comment every transmission?
          >>> Also, it seems to be beaconing every minute or so most of the time. Is
          >>> that just while you are testing?
          >>
          >> Thank you for your warning.
          >> Now I send the packet every ten minutesfor testing.
          >>
          >> When all my packets send to Internet through nearby IGATE,
          >> I'll change the interval to 30min.
          >>
          >> Thank you.
          >> --
          >> FUJIURA Toyonori mailto:toyokun@...
          >>
          >
          >
          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
          >



          --
          FUJIURA Toyonori mailto:toyokun@...
        • Patrick
          This is likely something that should be raised to Scott as a bug... The APRS spec (v1.0) does define PHG as being before the comment in the 7 byte data
          Message 4 of 10 , Sep 27, 2008
            This is likely something that should be raised to Scott as a bug... The
            APRS spec (v1.0) does define PHG as being before the comment in the 7
            byte data extension field... (that said, it may have changed as the
            spec has evolved)

            One thing that could be breaking the parsing of it is that there's no
            space between the temp (22C) and the PHG... does adding a space before
            the PHG resolve the issue?

            p

            Patrick Domack wrote:
            > The issue here is that it's hardcoded in the software, to add
            > altitude, then temp, volt, hdoc, comment
            >
            > I changed my firmware to do it as, comment, temp, volt, hdoc,
            > altitude, but then the balloon people would get upset.
            >
            > I was just thinking of a checkbox that says to put the comment before
            > or after the extra text, so it would work for both people.
            >
            > But yes, if your running the normal firmware, you will be stuck with
            > having everything off, in order to use the comment to insert special
            > stuff like that.
            >
            > If you would like, I can send you the firmware I am using so it will
            > work for you now.
            >
            > Quoting FUJIURA Toyonori <toyokun@...>:
            >
            >
            >> Thank you Keith,
            >>
            >> 2008/9/27 Keith VE7GDH <ve7gdh@...>:
            >>
            >>> 2008-09-27 10:15:24 UTC:
            >>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
            >>> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
            >>>
            >> I think this format is wrong.
            >> PHG should be followed by voltage and temperature.
            >>
            >>
            >>> 2008-09-27 10:22:08 UTC:
            >>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
            >>> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
            >>>
            >>> Then later the PHG is gone. Are you using profile switching? Perhaps you
            >>> have voltage and temperature enabled in one profile but not the other.
            >>>
            >> No, I change the setiing manually.
            >>
            >>
            >>> Also, what happens if you send the PHG as status text in every second
            >>> transmission instead of in a beacon comment every transmission?
            >>> Also, it seems to be beaconing every minute or so most of the time. Is
            >>> that just while you are testing?
            >>>
            >> Thank you for your warning.
            >> Now I send the packet every ten minutesfor testing.
            >>
            >> When all my packets send to Internet through nearby IGATE,
            >> I'll change the interval to 30min.
            >>
            >> Thank you.
            >> --
            >> FUJIURA Toyonori mailto:toyokun@...
            >>
            >>
            >
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
          • FUJIURA Toyonori
            Patrick, ... On aprs.fi, I have resolved the issue. But I haven t resolved it on openaprs.net. Anyway, thank you for your advise. # Testing with not T2 but
            Message 5 of 10 , Sep 27, 2008
              Patrick,

              2008/9/28 Patrick <winston@...>:
              > One thing that could be breaking the parsing of it is that there's no
              > space between the temp (22C) and the PHG... does adding a space before
              > the PHG resolve the issue?

              On aprs.fi, I have resolved the issue.
              But I haven't resolved it on openaprs.net.
              Anyway, thank you for your advise.
              # Testing with not T2 but UIView because nobody receive my QRP packet...
              --
              FUJIURA Toyonori mailto:toyokun@...
            • Patrick Domack
              Opps, I thought I was reading the opentracker+ forum not the tracker2. I looked at it, and I can t compile the firmware for the tracker2 myself, cause it s
              Message 6 of 10 , Sep 28, 2008
                Opps, I thought I was reading the opentracker+ forum not the tracker2.

                I looked at it, and I can't compile the firmware for the tracker2
                myself, cause it's >32k, and the company that has the compiler, offers
                it for free for <32k, and they want $2500 if you want to make >32k

                Guess scott is going have to compile a version of this for you. Or if
                I can come across a free/opensource compiler somewhere.

                Quoting FUJIURA Toyonori <toyokun@...>:

                > Ok, I understood.
                >
                > Please send me the firmware because I want to try it.
                >
                > Also I found a source code for this firmware in freepository.com.
                > But I do not have the experience of making the firmware for the
                > built-in computer.
                > If I can, please tell me how to build the firmware from the source code.
                > I'll try to resolv future problems.
                >
                > 2008/9/28 Patrick Domack <patrickdk@...>:
                >> The issue here is that it's hardcoded in the software, to add
                >> altitude, then temp, volt, hdoc, comment
                >>
                >> I changed my firmware to do it as, comment, temp, volt, hdoc,
                >> altitude, but then the balloon people would get upset.
                >>
                >> I was just thinking of a checkbox that says to put the comment before
                >> or after the extra text, so it would work for both people.
                >>
                >> But yes, if your running the normal firmware, you will be stuck with
                >> having everything off, in order to use the comment to insert special
                >> stuff like that.
                >>
                >> If you would like, I can send you the firmware I am using so it will
                >> work for you now.
                >>
                >> Quoting FUJIURA Toyonori <toyokun@...>:
                >>
                >>> Thank you Keith,
                >>>
                >>> 2008/9/27 Keith VE7GDH <ve7gdh@...>:
                >>>> 2008-09-27 10:15:24 UTC:
                >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                >>>> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
                >>>
                >>> I think this format is wrong.
                >>> PHG should be followed by voltage and temperature.
                >>>
                >>>> 2008-09-27 10:22:08 UTC:
                >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                >>>> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
                >>>>
                >>>> Then later the PHG is gone. Are you using profile switching? Perhaps you
                >>>> have voltage and temperature enabled in one profile but not the other.
                >>>
                >>> No, I change the setiing manually.
                >>>
                >>>> Also, what happens if you send the PHG as status text in every second
                >>>> transmission instead of in a beacon comment every transmission?
                >>>> Also, it seems to be beaconing every minute or so most of the time. Is
                >>>> that just while you are testing?
                >>>
                >>> Thank you for your warning.
                >>> Now I send the packet every ten minutesfor testing.
                >>>
                >>> When all my packets send to Internet through nearby IGATE,
                >>> I'll change the interval to 30min.
                >>>
                >>> Thank you.
                >>> --
                >>> FUJIURA Toyonori mailto:toyokun@...
                >>>
                >>
                >>
                >>
                >>
                >> ------------------------------------
                >>
                >> Yahoo! Groups Links
                >>
                >>
                >>
                >>
                >
                >
                >
                > --
                > FUJIURA Toyonori mailto:toyokun@...
                >
              • Scott Miller
                I think you can get a 30-day trial. You can also get a 1-year license for $400, which is more reasonable, but it s still a lot of a hobby project. I ll see if
                Message 7 of 10 , Sep 28, 2008
                  I think you can get a 30-day trial. You can also get a 1-year license
                  for $400, which is more reasonable, but it's still a lot of a hobby project.

                  I'll see if there's something simple I can do, but some things are hard
                  to shuffle around without excessively complicating the code.

                  Scott

                  Patrick Domack wrote:
                  >
                  >
                  > Opps, I thought I was reading the opentracker+ forum not the tracker2.
                  >
                  > I looked at it, and I can't compile the firmware for the tracker2
                  > myself, cause it's >32k, and the company that has the compiler, offers
                  > it for free for <32k, and they want $2500 if you want to make >32k
                  >
                  > Guess scott is going have to compile a version of this for you. Or if
                  > I can come across a free/opensource compiler somewhere.
                  >
                  > Quoting FUJIURA Toyonori <toyokun@... <mailto:toyokun%40gmail.com>>:
                  >
                  > > Ok, I understood.
                  > >
                  > > Please send me the firmware because I want to try it.
                  > >
                  > > Also I found a source code for this firmware in freepository.com.
                  > > But I do not have the experience of making the firmware for the
                  > > built-in computer.
                  > > If I can, please tell me how to build the firmware from the source code.
                  > > I'll try to resolv future problems.
                  > >
                  > > 2008/9/28 Patrick Domack <patrickdk@...
                  > <mailto:patrickdk%40patrickdk.com>>:
                  > >> The issue here is that it's hardcoded in the software, to add
                  > >> altitude, then temp, volt, hdoc, comment
                  > >>
                  > >> I changed my firmware to do it as, comment, temp, volt, hdoc,
                  > >> altitude, but then the balloon people would get upset.
                  > >>
                  > >> I was just thinking of a checkbox that says to put the comment before
                  > >> or after the extra text, so it would work for both people.
                  > >>
                  > >> But yes, if your running the normal firmware, you will be stuck with
                  > >> having everything off, in order to use the comment to insert special
                  > >> stuff like that.
                  > >>
                  > >> If you would like, I can send you the firmware I am using so it will
                  > >> work for you now.
                  > >>
                  > >> Quoting FUJIURA Toyonori <toyokun@...
                  > <mailto:toyokun%40gmail.com>>:
                  > >>
                  > >>> Thank you Keith,
                  > >>>
                  > >>> 2008/9/27 Keith VE7GDH <ve7gdh@... <mailto:ve7gdh%40yahoo.com>>:
                  > >>>> 2008-09-27 10:15:24 UTC:
                  > >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                  > >>>> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
                  > >>>
                  > >>> I think this format is wrong.
                  > >>> PHG should be followed by voltage and temperature.
                  > >>>
                  > >>>> 2008-09-27 10:22:08 UTC:
                  > >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                  > >>>> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
                  > >>>>
                  > >>>> Then later the PHG is gone. Are you using profile switching?
                  > Perhaps you
                  > >>>> have voltage and temperature enabled in one profile but not the other.
                  > >>>
                  > >>> No, I change the setiing manually.
                  > >>>
                  > >>>> Also, what happens if you send the PHG as status text in every second
                  > >>>> transmission instead of in a beacon comment every transmission?
                  > >>>> Also, it seems to be beaconing every minute or so most of the time. Is
                  > >>>> that just while you are testing?
                  > >>>
                  > >>> Thank you for your warning.
                  > >>> Now I send the packet every ten minutesfor testing.
                  > >>>
                  > >>> When all my packets send to Internet through nearby IGATE,
                  > >>> I'll change the interval to 30min.
                  > >>>
                  > >>> Thank you.
                  > >>> --
                  > >>> FUJIURA Toyonori mailto:toyokun@... <mailto:toyokun%40gmail.com>
                  > >>>
                  > >>
                  > >>
                  > >>
                  > >>
                  > >> ------------------------------------
                  > >>
                  > >> Yahoo! Groups Links
                  > >>
                  > >>
                  > >>
                  > >>
                  > >
                  > >
                  > >
                  > > --
                  > > FUJIURA Toyonori mailto:toyokun@... <mailto:toyokun%40gmail.com>
                  > >
                  >
                  >
                • Patrick Domack
                  Na, this is easy to shuffle Just cut/pase the comment transmit section to above the altitude tramsmit section. And I then move the altitude section down to
                  Message 8 of 10 , Sep 28, 2008
                    Na, this is easy to shuffle

                    Just cut/pase the comment transmit section to above the altitude
                    tramsmit section. And I then move the altitude section down to where
                    the comment section was.

                    As I am not doing ballooning, the altitude is of only little usefulness to me.

                    Quoting Scott Miller <scott@...>:

                    > I think you can get a 30-day trial. You can also get a 1-year license
                    > for $400, which is more reasonable, but it's still a lot of a hobby project.
                    >
                    > I'll see if there's something simple I can do, but some things are hard
                    > to shuffle around without excessively complicating the code.
                    >
                    > Scott
                    >
                    > Patrick Domack wrote:
                    >>
                    >>
                    >> Opps, I thought I was reading the opentracker+ forum not the tracker2.
                    >>
                    >> I looked at it, and I can't compile the firmware for the tracker2
                    >> myself, cause it's >32k, and the company that has the compiler, offers
                    >> it for free for <32k, and they want $2500 if you want to make >32k
                    >>
                    >> Guess scott is going have to compile a version of this for you. Or if
                    >> I can come across a free/opensource compiler somewhere.
                    >>
                    >> Quoting FUJIURA Toyonori <toyokun@... <mailto:toyokun%40gmail.com>>:
                    >>
                    >> > Ok, I understood.
                    >> >
                    >> > Please send me the firmware because I want to try it.
                    >> >
                    >> > Also I found a source code for this firmware in freepository.com.
                    >> > But I do not have the experience of making the firmware for the
                    >> > built-in computer.
                    >> > If I can, please tell me how to build the firmware from the source code.
                    >> > I'll try to resolv future problems.
                    >> >
                    >> > 2008/9/28 Patrick Domack <patrickdk@...
                    >> <mailto:patrickdk%40patrickdk.com>>:
                    >> >> The issue here is that it's hardcoded in the software, to add
                    >> >> altitude, then temp, volt, hdoc, comment
                    >> >>
                    >> >> I changed my firmware to do it as, comment, temp, volt, hdoc,
                    >> >> altitude, but then the balloon people would get upset.
                    >> >>
                    >> >> I was just thinking of a checkbox that says to put the comment before
                    >> >> or after the extra text, so it would work for both people.
                    >> >>
                    >> >> But yes, if your running the normal firmware, you will be stuck with
                    >> >> having everything off, in order to use the comment to insert special
                    >> >> stuff like that.
                    >> >>
                    >> >> If you would like, I can send you the firmware I am using so it will
                    >> >> work for you now.
                    >> >>
                    >> >> Quoting FUJIURA Toyonori <toyokun@...
                    >> <mailto:toyokun%40gmail.com>>:
                    >> >>
                    >> >>> Thank you Keith,
                    >> >>>
                    >> >>> 2008/9/27 Keith VE7GDH <ve7gdh@... <mailto:ve7gdh%40yahoo.com>>:
                    >> >>>> 2008-09-27 10:15:24 UTC:
                    >> >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                    >> >>>> :!3441.00NU13548.50E# 13.4V 22CPHG1220 W1,NRn New-N Fill-in Digi NARA
                    >> >>>
                    >> >>> I think this format is wrong.
                    >> >>> PHG should be followed by voltage and temperature.
                    >> >>>
                    >> >>>> 2008-09-27 10:22:08 UTC:
                    >> >>>> JG2RZF>APOT2A,WIDE2-2,qAR,JE3MXU
                    >> >>>> :!3441.00NU13548.50E#PHG1220 W1,NRn New-N Fill-in Digi NARA
                    >> >>>>
                    >> >>>> Then later the PHG is gone. Are you using profile switching?
                    >> Perhaps you
                    >> >>>> have voltage and temperature enabled in one profile but not the other.
                    >> >>>
                    >> >>> No, I change the setiing manually.
                    >> >>>
                    >> >>>> Also, what happens if you send the PHG as status text in every second
                    >> >>>> transmission instead of in a beacon comment every transmission?
                    >> >>>> Also, it seems to be beaconing every minute or so most of the time. Is
                    >> >>>> that just while you are testing?
                    >> >>>
                    >> >>> Thank you for your warning.
                    >> >>> Now I send the packet every ten minutesfor testing.
                    >> >>>
                    >> >>> When all my packets send to Internet through nearby IGATE,
                    >> >>> I'll change the interval to 30min.
                    >> >>>
                    >> >>> Thank you.
                    >> >>> --
                    >> >>> FUJIURA Toyonori mailto:toyokun@... <mailto:toyokun%40gmail.com>
                    >> >>>
                    >> >>
                    >> >>
                    >> >>
                    >> >>
                    >> >> ------------------------------------
                    >> >>
                    >> >> Yahoo! Groups Links
                    >> >>
                    >> >>
                    >> >>
                    >> >>
                    >> >
                    >> >
                    >> >
                    >> > --
                    >> > FUJIURA Toyonori mailto:toyokun@... <mailto:toyokun%40gmail.com>
                    >> >
                    >>
                    >>
                    >
                    >
                  • kb7nie
                    Hi Fujira, Patrick, How did you resolve the PHG issue on aprs.fi? Has Scott been made aware of this protocol bug? I m just running into it myself. Thanks
                    Message 9 of 10 , Nov 2, 2009
                      Hi Fujira, Patrick,

                      How did you resolve the PHG issue on aprs.fi? Has Scott been made aware of this protocol bug? I'm just running into it myself.

                      Thanks
                      Henry
                      KB7NIE

                      --- In tracker2@yahoogroups.com, "FUJIURA Toyonori" <toyokun@...> wrote:
                      >
                      > Patrick,
                      >
                      > 2008/9/28 Patrick <winston@...>:
                      > > One thing that could be breaking the parsing of it is that there's no
                      > > space between the temp (22C) and the PHG... does adding a space before
                      > > the PHG resolve the issue?
                      >
                      > On aprs.fi, I have resolved the issue.
                      > But I haven't resolved it on openaprs.net.
                      > Anyway, thank you for your advise.
                      > # Testing with not T2 but UIView because nobody receive my QRP packet...
                      > --
                      > FUJIURA Toyonori mailto:toyokun@...
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.