Loading ...
Sorry, an error occurred while loading the content.

Beta firmware updated

Expand Messages
  • Scott Miller
    Build 54588 has been posted. You can grab it with the config program or here: http://n1vg.net/opentracker/firmware/ot2-54588.s19 I m leaving for a weekend
    Message 1 of 4 , May 2, 2008
    • 0 Attachment
      Build 54588 has been posted. You can grab it with the config program or
      here:

      http://n1vg.net/opentracker/firmware/ot2-54588.s19

      I'm leaving for a weekend trip to the Maker Faire in San Mateo, and I
      managed to get a couple of fixes in, but they haven't been extensively
      tested yet.

      This should fix the problem with the T2 not processing messages from the
      Nuvi after a message in progress has been aborted or some other
      exception occurs. Turns out Garmin does something funny with message
      IDs that was messing up the dupe checking.

      On the other hand, this fix *might* mean that outgoing messages keep
      retrying forever, as the T2 times out and the Nuvi keeps resending.
      Depends on if I got the timing right in the ACK code.

      Also, I think this might fix the problem with AMODE and BMODE (and maybe
      other commands) reporting garbage. Might be related to
      null-termination of the incoming message. I added a simple mod that
      should take care of that for all Garmin messages.

      Now to see if my setup still works after being installed and removed so
      many times. I'll be on the air as N1VG-6 if anyone wants to try
      messaging me.

      Scott
    • Brent Gay
      With the new firmware I try to send a message to the Nuvi 350 (!VERSION for example) and it just stays in the outbox as Sending... I do not see where I can
      Message 2 of 4 , May 3, 2008
      • 0 Attachment
        With the new firmware I try to send a message to the Nuvi 350 (!VERSION for example) and it just stays in the outbox as "Sending..."

        I do not see where I can get previous beta firmwares to test. Are they available somewhere?

        Brent

        On Fri, May 2, 2008 at 3:40 PM, Scott Miller <scott@...> wrote:

        Build 54588 has been posted. You can grab it with the config program or
        here:

        http://n1vg.net/opentracker/firmware/ot2-54588.s19

        I'm leaving for a weekend trip to the Maker Faire in San Mateo, and I
        managed to get a couple of fixes in, but they haven't been extensively
        tested yet.

        This should fix the problem with the T2 not processing messages from the
        Nuvi after a message in progress has been aborted or some other
        exception occurs. Turns out Garmin does something funny with message
        IDs that was messing up the dupe checking.

        On the other hand, this fix *might* mean that outgoing messages keep
        retrying forever, as the T2 times out and the Nuvi keeps resending.
        Depends on if I got the timing right in the ACK code.

        Also, I think this might fix the problem with AMODE and BMODE (and maybe
        other commands) reporting garbage. Might be related to
        null-termination of the incoming message. I added a simple mod that
        should take care of that for all Garmin messages.

        Now to see if my setup still works after being installed and removed so
        many times. I'll be on the air as N1VG-6 if anyone wants to try
        messaging me.

        Scott


      • Steven Palm
        ... The command format changed in the previous version. USE: --VERSION NOT: !VERSION Steve
        Message 3 of 4 , May 3, 2008
        • 0 Attachment
          On May 3, 2008, at 10:32 PM, Brent Gay wrote:
          > With the new firmware I try to send a message to the Nuvi 350 (!
          > VERSION for example) and it just stays in the outbox as "Sending..."

          The command format changed in the previous version.

          USE:
          --VERSION

          NOT:
          !VERSION


          Steve
        • Brent Gay
          That did it. Thanks. Brent
          Message 4 of 4 , May 3, 2008
          • 0 Attachment
            That did it. Thanks.

            Brent

            On Sat, May 3, 2008 at 10:46 PM, Steven Palm <n9yty@...> wrote:


            On May 3, 2008, at 10:32 PM, Brent Gay wrote:
            > With the new firmware I try to send a message to the Nuvi 350 (!
            > VERSION for example) and it just stays in the outbox as "Sending..."

            The command format changed in the previous version.

            USE:
            --VERSION

            NOT:
            !VERSION

            Steve

          Your message has been successfully submitted and would be delivered to recipients shortly.