Loading ...
Sorry, an error occurred while loading the content.

Re: [tracker2] AUTHLIST COMMAND ACTION

Expand Messages
  • P. Suryono Adisoemarta
    ... Bruce, thanks for the report. It dawned on me that this might be a truncated variable problem, due to long callsigns. So I changed my D700A to my US
    Message 1 of 20 , Jan 7, 2008
    • 0 Attachment
      --- "Bruce W. Martin" <yahoo@...> wrote:

      > The test using the second callsign tonight worked
      > just fine.
      >

      Bruce,
      thanks for the report.

      It dawned on me that this might be a truncated
      variable problem, due to long callsigns.

      So I changed my D700A to my US callsign (N5SNN), put
      N5SNN and your callsign on the authlist, and now 2
      callsigns on the authlist WORKS!

      cmd:authlist
      AUTHLIST N5SNN, KQ4TV


      To reconfirm, I went back to my Indonesian callsign,
      and one other digi maintainer's callsign, and got RejZ
      again.

      cmd:authlist
      AUTHLIST YD0NXX, YC2WAN


      The difference is the length of the callsign.


      Scott,
      this observation hopefully might help you in fixing
      this bug.


      73 de Paulus - N5SNN / YD0NXX






      ____________________________________________________________________________________
      Be a better friend, newshound, and
      know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
    • Jason KG4WSV
      On Jan 7, 2008 9:24 PM, P. Suryono Adisoemarta ... hmm, my callsign works fine (kg4wsv), but it s the only one on the list. I
      Message 2 of 20 , Jan 7, 2008
      • 0 Attachment
        On Jan 7, 2008 9:24 PM, P. Suryono Adisoemarta <yono_adisoemarta@...> wrote:
        So I changed my D700A to my US callsign (N5SNN), put
        N5SNN and your callsign on the authlist, and now 2
        callsigns on the authlist WORKS!

        cmd:authlist
        AUTHLIST N5SNN, KQ4TV

        To reconfirm, I went back to my Indonesian callsign,
        and one other digi maintainer's callsign, and got RejZ
        again.

        cmd:authlist
        AUTHLIST YD0NXX, YC2WAN

        The difference is the length of the callsign.


        hmm, my callsign works fine (kg4wsv), but it's the only one on the list.  I have my T2 temporarily hosed up, so I can't add any test data to the discussion...
         
        -Jason
        kg4wsv

      • P. Suryono Adisoemarta
        Jason, One callsign on authlist, regardless of length, always works. The problem that I got was after adding a second callsign, then I got a Reject (regardless
        Message 3 of 20 , Jan 7, 2008
        • 0 Attachment
          Jason,

          One callsign on authlist, regardless of length, always
          works.

          The problem that I got was after adding a second
          callsign, then I got a Reject (regardless of which
          callsign I use to send the message). Both callsigns
          are of 6 chars of length.

          But 2 callsigns of 5 chars length, works fine, as
          reported by Bruce and I can duplicate it.

          So, whenever you got the chance to work on your T2,
          try adding a second callsign on authlist of 6 chars
          length, and see if you got a Reject or not.

          73 de Paulus



          --- Jason KG4WSV <kg4wsv@...> wrote:

          > On Jan 7, 2008 9:24 PM, P. Suryono Adisoemarta
          > <yono_adisoemarta@...>
          > wrote:
          >
          > > So I changed my D700A to my US callsign (N5SNN),
          > put
          > > N5SNN and your callsign on the authlist, and now 2
          > > callsigns on the authlist WORKS!
          > >
          > > cmd:authlist
          > > AUTHLIST N5SNN, KQ4TV
          > >
          > > To reconfirm, I went back to my Indonesian
          > callsign,
          > > and one other digi maintainer's callsign, and got
          > RejZ
          > > again.
          > >
          > > cmd:authlist
          > > AUTHLIST YD0NXX, YC2WAN
          > >
          > > The difference is the length of the callsign.
          >
          >
          >
          > hmm, my callsign works fine (kg4wsv), but it's the
          > only one on the list. I
          > have my T2 temporarily hosed up, so I can't add any
          > test data to the
          > discussion...
          >
          > -Jason
          > kg4wsv
          >



          ____________________________________________________________________________________
          Looking for last minute shopping deals?
          Find them fast with Yahoo! Search. http://tools.search.yahoo.com/newsearch/category.php?category=shopping
        • Scott Miller
          Ok, I m guessing that what must be going on is that a terminating null is getting written to the authlist table when a call is added. If that s the last call,
          Message 4 of 20 , Jan 7, 2008
          • 0 Attachment
            Ok, I'm guessing that what must be going on is that a terminating null
            is getting written to the authlist table when a call is added. If
            that's the last call, it won't affect anything. If it's not, it'll wipe
            out the next call in the list. Now that I know it's length-related,
            I'll see if I can duplicate it.

            Scott

            P. Suryono Adisoemarta wrote:
            >
            >
            >
            > Jason,
            >
            > One callsign on authlist, regardless of length, always
            > works.
            >
            > The problem that I got was after adding a second
            > callsign, then I got a Reject (regardless of which
            > callsign I use to send the message). Both callsigns
            > are of 6 chars of length.
            >
            > But 2 callsigns of 5 chars length, works fine, as
            > reported by Bruce and I can duplicate it.
            >
            > So, whenever you got the chance to work on your T2,
            > try adding a second callsign on authlist of 6 chars
            > length, and see if you got a Reject or not.
            >
            > 73 de Paulus
            >
            > --- Jason KG4WSV <kg4wsv@... <mailto:kg4wsv%40gmail.com>> wrote:
            >
            > > On Jan 7, 2008 9:24 PM, P. Suryono Adisoemarta
            > > <yono_adisoemarta@... <mailto:yono_adisoemarta%40yahoo.com>>
            > > wrote:
            > >
            > > > So I changed my D700A to my US callsign (N5SNN),
            > > put
            > > > N5SNN and your callsign on the authlist, and now 2
            > > > callsigns on the authlist WORKS!
            > > >
            > > > cmd:authlist
            > > > AUTHLIST N5SNN, KQ4TV
            > > >
            > > > To reconfirm, I went back to my Indonesian
            > > callsign,
            > > > and one other digi maintainer's callsign, and got
            > > RejZ
            > > > again.
            > > >
            > > > cmd:authlist
            > > > AUTHLIST YD0NXX, YC2WAN
            > > >
            > > > The difference is the length of the callsign.
            > >
            > >
            > >
            > > hmm, my callsign works fine (kg4wsv), but it's the
            > > only one on the list. I
            > > have my T2 temporarily hosed up, so I can't add any
            > > test data to the
            > > discussion...
            > >
            > > -Jason
            > > kg4wsv
            > >
            >
            > __________________________________________________________
            > Looking for last minute shopping deals?
            > Find them fast with Yahoo! Search.
            > http://tools.search.yahoo.com/newsearch/category.php?category=shopping
            > <http://tools.search.yahoo.com/newsearch/category.php?category=shopping>
            >
            >
          • Keith VE7GDH
            Scott N1VG wrote... ... FYI... a few weeks ago, I was giving someone a hand setting up a T2-135 as a digi. He couldn t add his callsign to the AUTHLIST. I
            Message 5 of 20 , Jan 7, 2008
            • 0 Attachment
              Scott N1VG wrote...

              > Ok, I'm guessing that what must be going on is that a terminating
              > null is getting written to the authlist table when a call is added.
              > If that's the last call, it won't affect anything. If it's not, it'll
              > wipe out the next call in the list. Now that I know it's
              > length-related, I'll see if I can duplicate it.

              FYI... a few weeks ago, I was giving someone a hand setting up a T2-135
              as a digi. He couldn't add his callsign to the AUTHLIST. I assumed it
              was a syntax error, but later he managed to add my callsign. I did some
              changes remotely. Later, I tried to add his callsign to the AUTHLIST. It
              looked like it worked, but later it wouldn't respond to my commands...
              e.g.

              REJ received for msg. no. 70, W7PFR will NOT have seen the message.

              73 es cul - Keith VE7GDH
              --
              "I may be lost, but I know exactly where I am!"
            • Scott Miller
              I need to roll back to the last release firmware and test it - maybe I fixed something along the way, because I can t duplicate the problem. I ran through a
              Message 6 of 20 , Jan 9, 2008
              • 0 Attachment
                I need to roll back to the last release firmware and test it - maybe I
                fixed something along the way, because I can't duplicate the problem. I
                ran through a bunch of adds and deletes with various length callsigns,
                and the list still looks just fine.

                Scott

                P. Suryono Adisoemarta wrote:
                >
                >
                >
                > --- "Bruce W. Martin" <yahoo@... <mailto:yahoo%40bwm.us>> wrote:
                >
                > > The test using the second callsign tonight worked
                > > just fine.
                > >
                >
                > Bruce,
                > thanks for the report.
                >
                > It dawned on me that this might be a truncated
                > variable problem, due to long callsigns.
                >
                > So I changed my D700A to my US callsign (N5SNN), put
                > N5SNN and your callsign on the authlist, and now 2
                > callsigns on the authlist WORKS!
                >
                > cmd:authlist
                > AUTHLIST N5SNN, KQ4TV
                >
                > To reconfirm, I went back to my Indonesian callsign,
                > and one other digi maintainer's callsign, and got RejZ
                > again.
                >
                > cmd:authlist
                > AUTHLIST YD0NXX, YC2WAN
                >
                > The difference is the length of the callsign.
                >
                > Scott,
                > this observation hopefully might help you in fixing
                > this bug.
                >
                > 73 de Paulus - N5SNN / YD0NXX
                >
                > __________________________________________________________
                > Be a better friend, newshound, and
                > know-it-all with Yahoo! Mobile. Try it now.
                > http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
                > <http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ>
                >
                >
              • Keith VE7GDH
                Scott N1VG wrote... ... I m using T2-135 version 54433. I can add multiple callsigns to AUTHLIST, but with more than one callsign in the list, it will no
                Message 7 of 20 , Jan 11, 2008
                • 0 Attachment
                  Scott N1VG wrote...

                  > I need to roll back to the last release firmware and test it -
                  > maybe I fixed something along the way, because I can't duplicate
                  > the problem. I ran through a bunch of adds and deletes with
                  > various length callsigns, and the list still looks just fine.

                  I'm using T2-135 version 54433. I can add multiple callsigns to
                  AUTHLIST, but with more than one callsign in the list, it will no longer
                  respond to remote callsigns from any of the authorized callsigns. I
                  could even add a second callsign remotely, but that locked me out after
                  that.

                  73 es cul - Keith VE7GDH
                  --
                  "I may be lost, but I know exactly where I am!"
                • Scott Miller
                  Got it! The problem would only pop up if you had a callsign that was 6 characters long AND there was a callsign in the next slot. It was just a strcmp() that
                  Message 8 of 20 , Jan 11, 2008
                  • 0 Attachment
                    Got it! The problem would only pop up if you had a callsign that was 6
                    characters long AND there was a callsign in the next slot. It was just
                    a strcmp() that should have been a strncmp(). It'll go out in the next
                    update.

                    Scott

                    Keith VE7GDH wrote:
                    >
                    >
                    > Scott N1VG wrote...
                    >
                    > > I need to roll back to the last release firmware and test it -
                    > > maybe I fixed something along the way, because I can't duplicate
                    > > the problem. I ran through a bunch of adds and deletes with
                    > > various length callsigns, and the list still looks just fine.
                    >
                    > I'm using T2-135 version 54433. I can add multiple callsigns to
                    > AUTHLIST, but with more than one callsign in the list, it will no longer
                    > respond to remote callsigns from any of the authorized callsigns. I
                    > could even add a second callsign remotely, but that locked me out after
                    > that.
                    >
                    > 73 es cul - Keith VE7GDH
                    > --
                    > "I may be lost, but I know exactly where I am!"
                    >
                    >
                  • Keith VE7GDH
                    Scott N1VG wrote... ... Hey, that s terrific! That will be good news for the control (cmd) freaks! Is it feed a fever and starve a code? hi! 73 es cul - Keith
                    Message 9 of 20 , Jan 11, 2008
                    • 0 Attachment
                      Scott N1VG wrote...

                      > Got it! The problem would only pop up if you had a callsign that
                      > was 6 characters long AND there was a callsign in the next slot...

                      Hey, that's terrific! That will be good news for the control (cmd)
                      freaks!

                      Is it feed a fever and starve a code? hi!

                      73 es cul - Keith VE7GDH
                      --
                      "I may be lost, but I know exactly where I am!"
                    Your message has been successfully submitted and would be delivered to recipients shortly.