Loading ...
Sorry, an error occurred while loading the content.

Re: [tracker2] T3-mini serial ports

Expand Messages
  • Scott Miller
    Hi Cai, I just added a note to the wiki: http://wiki.argentdata.com/index.php?title=Tracker3#Hardware_Configuration_Flags I ll add more specific information to
    Message 1 of 7 , Mar 27 11:17 AM
    • 0 Attachment
      Hi Cai,

      I just added a note to the wiki:

      http://wiki.argentdata.com/index.php?title=Tracker3#Hardware_Configuration_Flags

      I'll add more specific information to the T3-mini page when I have time.
      In short, you'll need to use the patch command to set a configuration
      byte.

      Scott

      On 3/27/2013 12:34 AM, caimaver wrote:
      > How can I get either serial port on the T3-mini to speak TTL instead of
      > RS-232? I couldn't find a setting for it in otwincfg or in the
      > "cmd:help" command list and I didn't see anything about it on the wiki
      > either.
      >
      > Thanks!
      > Cai /W6CAI
      >
      >
    • caimaver
      Hi Scott- Thanks for the update. I ve got the T3-mini working in TTL mode, but it looks like there s a problem with the A-TX pin. Using TTL, I am able to send
      Message 2 of 7 , Mar 28 4:15 PM
      • 0 Attachment
        Hi Scott-

        Thanks for the update. I've got the T3-mini working in TTL mode, but it looks like there's a problem with the A-TX pin. Using TTL, I am able to send commands to the T3-mini through the A-RX pin and communication through port B (TTL) seems to work fine (both TX and RX as far as I can tell, I can echo port B text with 'snoop' but I didn't see an obvious command to output text on port B).

        After a little more troubleshooting, it looks like the A-TX pin is still operating in RS-232 mode; it works if I run the A-TX line through a MAX3232 (while the A-RX is still receiving TTL). I verified that 002FFF01 is still 06 using "dump all". Can this be fixed in a firmware update?

        BTW, is there a way to use "dump" to output only the memory at 002FF0? That would make verifying this configuration byte much simpler.

        Thanks! I'm really excited about the options made possible with a T3 on a small PCB like this.

        - Cai


        --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
        >
        > Hi Cai,
        >
        > I just added a note to the wiki:
        >
        > http://wiki.argentdata.com/index.php?title=Tracker3#Hardware_Configuration_Flags
        >
        > I'll add more specific information to the T3-mini page when I have time.
        > In short, you'll need to use the patch command to set a configuration
        > byte.
        >
        > Scott
        >
        > On 3/27/2013 12:34 AM, caimaver wrote:
        > > How can I get either serial port on the T3-mini to speak TTL instead of
        > > RS-232? I couldn't find a setting for it in otwincfg or in the
        > > "cmd:help" command list and I didn't see anything about it on the wiki
        > > either.
        > >
        > > Thanks!
        > > Cai /W6CAI
        > >
        > >
        >
      • Scott Miller
        ... Actually I think TTL may be the default on the T3. That s the one annoying difference between the OTUSB and T3 - they have different default polarities
        Message 3 of 7 , Mar 28 4:45 PM
        • 0 Attachment
          > After a little more troubleshooting, it looks like the A-TX pin is still
          > operating in RS-232 mode; it works if I run the A-TX line through a

          Actually I think TTL may be the default on the T3. That's the one
          annoying difference between the OTUSB and T3 - they have different
          default polarities for the TX line. Try setting it without the TX
          invert bit.

          > MAX3232 (while the A-RX is still receiving TTL). I verified that
          > 002FFF01 is still 06 using "dump all". Can this be fixed in a firmware
          > update?

          I think those may have gone out with an older firmware version - the
          production programmer might not have been updated. I'll check on that
          tonight.

          > BTW, is there a way to use "dump" to output only the memory at 002FF0?
          > That would make verifying this configuration byte much simpler.

          No, afraid you have to do a DUMP ALL.

          Scott
        • caimaver
          Thanks for the fast reply. You re right, patch 002FFF0102 allows me to use TTL for both A-TX and A-RX. If it s helpful, my T3-mini was shipped with the 56373
          Message 4 of 7 , Mar 28 5:04 PM
          • 0 Attachment
            Thanks for the fast reply. You're right, "patch 002FFF0102" allows me to use TTL for both A-TX and A-RX. If it's helpful, my T3-mini was shipped with the 56373 firmware.

            One last thing: I tried to create an account on the Argent Data wiki, but I get, 'Database returned error "1146: Table 'argentwiki.account_requests' doesn't exist (db.argentdata.com)".'

            Thanks again!
            - Cai

            --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
            >
            > > After a little more troubleshooting, it looks like the A-TX pin is still
            > > operating in RS-232 mode; it works if I run the A-TX line through a
            >
            > Actually I think TTL may be the default on the T3. That's the one
            > annoying difference between the OTUSB and T3 - they have different
            > default polarities for the TX line. Try setting it without the TX
            > invert bit.
            >
            > > MAX3232 (while the A-RX is still receiving TTL). I verified that
            > > 002FFF01 is still 06 using "dump all". Can this be fixed in a firmware
            > > update?
            >
            > I think those may have gone out with an older firmware version - the
            > production programmer might not have been updated. I'll check on that
            > tonight.
            >
            > > BTW, is there a way to use "dump" to output only the memory at 002FF0?
            > > That would make verifying this configuration byte much simpler.
            >
            > No, afraid you have to do a DUMP ALL.
            >
            > Scott
            >
          • Scott Miller
            ... Hmm, the latest upgrade must have broken that. I ll have to see what I can do. At least it should keep down the spam accounts... =] Scott
            Message 5 of 7 , Apr 1, 2013
            • 0 Attachment
              > One last thing: I tried to create an account on the Argent Data wiki,
              > but I get, 'Database returned error "1146: Table
              > 'argentwiki.account_requests' doesn't exist (db.argentdata.com)".'

              Hmm, the latest upgrade must have broken that. I'll have to see what I
              can do. At least it should keep down the spam accounts... =]

              Scott
            Your message has been successfully submitted and would be delivered to recipients shortly.