Loading ...
Sorry, an error occurred while loading the content.

Re: OT USB Port A TEXT mode

Expand Messages
  • n9tkf
    Thanks Scott. I will try out the attached firmware and experiment a little. I tried switching to Port B Text and Port A on Auto, but could not get Port B to
    Message 1 of 9 , Feb 26, 2013
    • 0 Attachment
      Thanks Scott. I will try out the attached firmware and experiment a little. I tried switching to Port B Text and Port A on Auto, but could not get Port B to send when the tracker received a CR\LF from the Arduino. Since I was using a fixed position mode for the GPS, I copied a good Position packet as text and sent it from the Arduino from Port A along with the telemetry data. This worked great.

      --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
      >
      > Apparently at some point that behavior was by design, but I couldn't
      > tell you what my reasoning was. It was bypassing timed transmissions in
      > TEXT mode, but only for port A.
      >
      > Try the attached firmware version. Or switch to port B if you need to
      > stick with the current release.
      >
      > Scott
      >
      > On 2/21/2013 5:12 PM, n9tkf wrote:
      > > I programmed Port A to Auto and to beacon every 120 secs. The tracker
      > > sent a beacon every 120 secs. I programmed the Tracker Port A to TEXT
      > > Port B to AUTO and it will send the text telemetry from the Arduino but
      > > will not send a beacon. Maybe a setting is wrong on my setup?
      > >
      > > John
      > > N9TKF
      > >
      > > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
      > > Scott Miller wrote:
      > > >
      > > > I don't think having it in TEXT mode should affect normal beacon
      > > > operation. Does it beacon when you have it in AUTO mode?
      > > >
      > > > Scott
      > > >
      > > > On 2/21/2013 10:13 AM, n9tkf wrote:
      > > > > Is the OT USB capable of sending out a Fixed position packet while Port
      > > > > A is in the TEXT mode? I am using an Arduino Uno to send a formated
      > > > > plain text telemetry message to Port A in the TEXT mode. I have tried
      > > > > several different settings but can not get the OT USB to send a
      > > position
      > > > > packet.
      > > > >
      > > > > John
      > > > > N9TKF
      > > > >
      > > > >
      > > >
      > >
      > >
      >
    • Scott Miller
      More updates are forthcoming. I ve fixed the problem with the verify error at 0xDE00 ... it was related to my T3 power save modifications - changed the
      Message 2 of 9 , Feb 26, 2013
      • 0 Attachment
        More updates are forthcoming. I've fixed the problem with the 'verify
        error at 0xDE00'... it was related to my T3 power save modifications -
        changed the locations of some things that can't be moved in the OTUSB.

        Scott

        On 2/26/2013 12:21 PM, n9tkf wrote:
        > Thanks Scott. I will try out the attached firmware and experiment a
        > little. I tried switching to Port B Text and Port A on Auto, but could
        > not get Port B to send when the tracker received a CR\LF from the
        > Arduino. Since I was using a fixed position mode for the GPS, I copied a
        > good Position packet as text and sent it from the Arduino from Port A
        > along with the telemetry data. This worked great.
        >
        > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
        > Scott Miller wrote:
        > >
        > > Apparently at some point that behavior was by design, but I couldn't
        > > tell you what my reasoning was. It was bypassing timed transmissions in
        > > TEXT mode, but only for port A.
        > >
        > > Try the attached firmware version. Or switch to port B if you need to
        > > stick with the current release.
        > >
        > > Scott
        > >
        > > On 2/21/2013 5:12 PM, n9tkf wrote:
        > > > I programmed Port A to Auto and to beacon every 120 secs. The tracker
        > > > sent a beacon every 120 secs. I programmed the Tracker Port A to TEXT
        > > > Port B to AUTO and it will send the text telemetry from the Arduino but
        > > > will not send a beacon. Maybe a setting is wrong on my setup?
        > > >
        > > > John
        > > > N9TKF
        > > >
        > > > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com> ,
        > > > Scott Miller wrote:
        > > > >
        > > > > I don't think having it in TEXT mode should affect normal beacon
        > > > > operation. Does it beacon when you have it in AUTO mode?
        > > > >
        > > > > Scott
        > > > >
        > > > > On 2/21/2013 10:13 AM, n9tkf wrote:
        > > > > > Is the OT USB capable of sending out a Fixed position packet
        > while Port
        > > > > > A is in the TEXT mode? I am using an Arduino Uno to send a formated
        > > > > > plain text telemetry message to Port A in the TEXT mode. I have
        > tried
        > > > > > several different settings but can not get the OT USB to send a
        > > > position
        > > > > > packet.
        > > > > >
        > > > > > John
        > > > > > N9TKF
        > > > > >
        > > > > >
        > > > >
        > > >
        > > >
        > >
        >
        >
      • n9tkf
        The attached firmware worked great. I am putting the text in to Port A and the OT USB beacons as programmed. John N9TKF
        Message 3 of 9 , Feb 27, 2013
        • 0 Attachment
          The attached firmware worked great. I am putting the text in to Port A and the OT USB beacons as programmed.

          John
          N9TKF

          --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
          >
          > Apparently at some point that behavior was by design, but I couldn't
          > tell you what my reasoning was. It was bypassing timed transmissions in
          > TEXT mode, but only for port A.
          >
          > Try the attached firmware version. Or switch to port B if you need to
          > stick with the current release.
          >
          > Scott
          >
          > On 2/21/2013 5:12 PM, n9tkf wrote:
          > > I programmed Port A to Auto and to beacon every 120 secs. The tracker
          > > sent a beacon every 120 secs. I programmed the Tracker Port A to TEXT
          > > Port B to AUTO and it will send the text telemetry from the Arduino but
          > > will not send a beacon. Maybe a setting is wrong on my setup?
          > >
          > > John
          > > N9TKF
          > >
          > > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
          > > Scott Miller wrote:
          > > >
          > > > I don't think having it in TEXT mode should affect normal beacon
          > > > operation. Does it beacon when you have it in AUTO mode?
          > > >
          > > > Scott
          > > >
          > > > On 2/21/2013 10:13 AM, n9tkf wrote:
          > > > > Is the OT USB capable of sending out a Fixed position packet while Port
          > > > > A is in the TEXT mode? I am using an Arduino Uno to send a formated
          > > > > plain text telemetry message to Port A in the TEXT mode. I have tried
          > > > > several different settings but can not get the OT USB to send a
          > > position
          > > > > packet.
          > > > >
          > > > > John
          > > > > N9TKF
          > > > >
          > > > >
          > > >
          > >
          > >
          >
        • Tony VE6MVP
          Folks Not sure where to start warning folks but I ll start here. I happened to notice that the mini usb adapter going into the back of the Garmin Nuvi 350
          Message 4 of 9 , Feb 27, 2013
          • 0 Attachment
            Folks

            Not sure where to start warning folks but I'll start here.   I happened to notice that the mini usb adapter going into the back of the Garmin Nuvi 350 cradle was munged.  Actually it was bent so far down it was at a 90 degree down angle immediately past the metal socket part.  So all that was holding in the place was part of the metal and the wires.      Basically Garmin should've put the power adapter somewhere else rather then right below the ball socket  Right above wouldn't been great.

            Turns out the problem was that I had the Nuvi 350 too vertical on the mount from the suction cup adapter.  I needed to have the pivot arm from the suction cup to the  ball socket angled way forward to give the USB micro adapter lots of clearance to the vertical arm.    If I'm making any sense. 

            To put it another way if you look at this picture https://www.thebcgpsstore.ca/Garmin-Suction-Cup-Mount-for-Nuvi-300-GPS-automotive-series-theBCGPSstore.ca/ it is too vertical.  There's not enough clearance for USB micro adapter cable end.   The GPS and cradle needs to be further forward so the arm is at more of a slant.

            This would've been perfect.  <smile>   http://www.abt.com/product/25855/Garmin-0101081500.html

            As I have lots of USB mini cables I'm going to purchase several cheap micro USB right angle adapters from eBay and a dual USB port cigaretter light adapter.

            Tony
          Your message has been successfully submitted and would be delivered to recipients shortly.