Loading ...
Sorry, an error occurred while loading the content.

T3-301 Scripting Problems cannot connect to otwincfg and unresponsive to commands

Expand Messages
  • Marcel S
    Hello group, *Overview:* I recently got a T3-301 and am playing around with the scripting, but I think I might have broken something since I can no longer
    Message 1 of 1 , Nov 12, 2012
    • 0 Attachment
      Hello group,

      I recently got a T3-301 and am playing around with the scripting, but I
      think I might have broken something since I can no longer connect to the
      device through otwincfg and it's not responding to any commands.

      I wrote the beginnings of a test script (see below) which was going to loop
      through and wait for the interrupt pin and then transmit. Well, the good
      news is that it does almost all of this except for transmit. The big
      problem now is that I cannot get back into otwincfg to change any of the
      scripting, nor am I able to turn off the scripting engine through PortA,
      through the USB port, or over the air. It seems like the tracker is stuck
      in my lovely scripting loop and not responsive to any commands. I'm at a
      bit of a loss.

      - I can read from PortA nicely and see all my output lines from the test
      script (see end of message) but cannot control through here (ctrl-C does
      - I can connect to the USB port of the T3 via PuTTY and after come ctrl-C's
      I can get "cmd:" to appear, but it does not respond to any commands...
      - I cannot get otwincfg to connect to the T3 via USB or PortA. I just sits
      and waits for the tracker to reset, but it seems the tracker does not
      respond to the reset command from otwincfg either (power cycling did not
      work either).
      - I have tried turning off Turbo and force reloading firmware with no luck.
      - It also does not seem to beacon with the 10 min intervals that I had set
      in the regular profile.
      - On my last reconfig through otwincfg I also set Port A to "text". I'm not
      sure if this is a contributing factor.
      - I tried sending various messages to the device over the air including
      "CMD RESET" "CMD INFO" "CMD SCRIPT OFF" all with no responses. The FC-301/D
      lights up green for RX, but no changes to the device, no port A response,
      and the same scripting messages continue on port A.

      *What I need help with:*
      I'd appreciate if anyone can point me in the write direction for:
      A. How to get the script to turn off and reconnect with otwincfg so I can
      fix my scripting
      B. What I did so horribly wrong to make the unit unhappy

      The final goal for this is a proof-of-concept device for a school project
      that uses SQL or RSSI on the interrupt pin to trigger a status beacon with
      RSSI and GPS time anytime any signal is received on the channel (no, this
      is not for APRS).

      Thanks for the help!

      -Marcel AI6MS

      This is what I believe is currently loaded on the scripting engine (at
      least something similar)(and yes, I know, this is terrible code. It was my
      first first draft at writing anything on it. Hence the test print messages
      etc. I realize there should be some Do Once commands in there as well):

      > PrintA "Tracker is booting up..."
      > On Interrupt
      > PrintA "Interrupt Triggered"
      > Set Counter 1 = 0
      > Exec "BEACON"
      > PrintA "After Beacon"
      > End Block
      > PrintA "After Interrupt Routine"
      So as of now, it just sits continually printing to Port A: "Tracker is
      booting up..." and "After Interrupt Routine" as expected. If I short the
      interrupt pin to ground, then I get the "After Beacon" message to output on
      Port A as well but no TX lights or anything else.
    Your message has been successfully submitted and would be delivered to recipients shortly.