Loading ...
Sorry, an error occurred while loading the content.

Re: T2 and OTUSB firmware updates

Expand Messages
  • offtracks1
    ... The profile switching seems to be broken. It always wants to go to profile 2 if it is used. Scott KB7DZR
    Message 1 of 14 , Nov 3, 2011
    • 0 Attachment
      --- In tracker2@yahoogroups.com, "offtracks1" <worldroamer@...> wrote:
      >
      >
      >
      > --- In tracker2@yahoogroups.com, Scott Miller <scott@> wrote:
      > >
      > > Oops. Fixed it. Updated firmware has been posted.
      > >
      > > Scott
      > >
      > > On 11/3/2011 10:29 AM, offtracks1 wrote:
      > > >
      > > >
      > > > --- In tracker2@yahoogroups.com <mailto:tracker2%40yahoogroups.com>,
      > > > Scott Miller <scott@> wrote:
      > > > >
      > > > > > Testing the newer firmware and I must me missing something. It wants to
      > > > > > stay in profile 2 and uses the path for its Call. I have started with a
      > > > > > new setup even and it still only uses the path for the call.
      > > > > > Scott KB7DZR
      > > > >
      > > > > OTUSB or T2? Can you send me your configuration file?
      > > > >
      > > > > Scott
      > > > >
      > > > Sure Will do.
      > > >
      > > > I did get it to show the call by putting the call in the path box.
      > > >
      > > >
      > >
      > Scott
      >
      > That fixed it, thank you very much. They are coming today to pick up this weather station. I still need to figure out the new settings for the weather and position beacons.
      >
      > I do have an issue with the profile switching now. I have it set so the voltage at 12.4 it changes to profile 2. The same set up works fine with the original firmware shipped with the t2. I sent the file to you earlier.
      >
      > Now once powered up the profile changes to profile 2.
      > The voltage is set to change to profile 2 when at 12.4. The power supply is at 13.5 and it still switches over to profile 2.
      >
      > Scott KB7DZR
      >
      The profile switching seems to be broken. It always wants to go to profile 2 if it is used.

      Scott KB7DZR
    • James Ewen
      ... There s no option to switch profiles when the voltage equals 12.4 volts. You can choose to switch when the voltage is less than or equal, or greater than a
      Message 2 of 14 , Nov 3, 2011
      • 0 Attachment
        On Thu, Nov 3, 2011 at 1:10 PM, offtracks1 <worldroamer@...> wrote:

        > I do have an issue with the profile switching now. I have it set so
        > the voltage at 12.4 it changes to profile 2.
        >
        > Now once powered up the profile changes to profile 2.
        > The voltage is set to change to profile 2 when at 12.4.
        > The power supply is at 13.5 and it still switches over to profile 2.

        There's no option to switch profiles when the voltage equals 12.4
        volts. You can choose to switch when the voltage is less than or
        equal, or greater than a set point.

        --
        James
        VE6SRV
      • notrobbage
        ... It sure does. I m alternating between WIDE2-1 and no path every ~15 minutes. Thanks for fixing. 2011-11-20 00:57:55 UTC:
        Message 3 of 14 , Nov 19, 2011
        • 0 Attachment
          --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
          >
          > Build 55862 is up for both the T2 and the OTUSB. For the T2, it's still ...

          > Using ALTPATH with a blank path in one profile but not the other now
          > works correctly.
          >

          It sure does. I'm alternating between WIDE2-1 and no path every ~15 minutes. Thanks for fixing.

          2011-11-20 00:57:55 UTC: VK6RN-3>APOT21,VK6AHR-3*,WIDE2*,qAR,VK6UFO-4:T#042,152,166,254,000,000,00000010
          2011-11-20 01:12:40 UTC: VK6RN-3>APOT21,qAR,VK6EX-1:T#043,151,166,254,000,000,00000010

          55862 appears to be stable here anyway. It's also running well in my mobile VK6UFO-9.
        • offtracks1
          I stated that wrong on the voltage change. Thanks for getting me straight on that. It is set up for less then/equal 12.4 to change to profile 2. The update
          Message 4 of 14 , Nov 20, 2011
          • 0 Attachment
            I stated that wrong on the voltage change. Thanks for getting me straight on that. It is set up for less then/equal 12.4 to change to profile 2.

            The update just did not work for me like the old firmware in that area. With the same configuration as the old firmware when set to trigger the change at less then 12.4 it should then change over to profile 2. Profile 2 was set to change back to Profile 1 when the voltage is over 13.0 volts.

            What is taking place with the new firmware is as soon as I power the T2 back up it starts and stays in profile 2. The power to the system was at 13.5 volts.

            Not a big deal as we already deployed that station with the older firmware. Just did not want to take a chance. Next summer we may give it the update after some more testing and time here and I learn how to setup the Weather beacon and position beacons to be at separate times.

            Thanks
            Scott KB7DZR

            >
            > There's no option to switch profiles when the voltage equals 12.4
            > volts. You can choose to switch when the voltage is less than or
            > equal, or greater than a set point.
            >
            > --
            > James
            > VE6SRV
            >
          • Scott Miller
            ... I just tested the firmware off the website and it s switching as expected for me. Can you re-send your configuration file? Scott
            Message 5 of 14 , Nov 22, 2011
            • 0 Attachment
              > I do have an issue with the profile switching now. I have it set so the
              > voltage at 12.4 it changes to profile 2. The same set up works fine with
              > the original firmware shipped with the t2. I sent the file to you earlier.
              >
              > Now once powered up the profile changes to profile 2.
              > The voltage is set to change to profile 2 when at 12.4. The power supply
              > is at 13.5 and it still switches over to profile 2.

              I just tested the firmware off the website and it's switching as
              expected for me. Can you re-send your configuration file?

              Scott
            • offtracks1
              I got that sent off to you. Scott KB7DZR
              Message 6 of 14 , Nov 22, 2011
              • 0 Attachment
                I got that sent off to you.

                Scott KB7DZR

                >
                > I just tested the firmware off the website and it's switching as
                > expected for me. Can you re-send your configuration file?
                >
                > Scott
                >
              • vk6mt
                Is there any chance of adding Beacon t for a telemetry packet? Mal VK6MT
                Message 7 of 14 , Dec 5, 2011
                • 0 Attachment
                  Is there any chance of adding 'Beacon t' for a telemetry packet?

                  Mal
                  VK6MT

                  --- In tracker2@yahoogroups.com, Scott Miller <scott@...> wrote:
                  >
                  > Build 55862 is up for both the T2 and the OTUSB. For the T2, it's still
                  > marked as a development build because there have been MANY internal changes.
                  >
                  > For the OTUSB, analog inputs are now referenced to the MCU's internal
                  > bandgap reference. This means more accurate readings despite variations
                  > in supply voltage. I tested two units in the temperature chamber and
                  > after setting TEMPADJ, the readings were within 1 degree C from -30C to
                  > +40C, and not more than 3 degrees off over the entire tested range of
                  > -195C to +80C.
                  >
                  > BEACON P and BEACON W now beacon only position or weather packets,
                  > respectively. You can use these in scripts for better control over what
                  > packets get sent when.
                  >
                  > Using ALTPATH with a blank path in one profile but not the other now
                  > works correctly.
                  >
                  > For the T2 this is not a critical update, but I very much recommend it
                  > for the OTUSB if you didn't already update last week - there's another
                  > fix that corrects a problem with the USB stack freezing under certain
                  > circumstances.
                  >
                  > Scott
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.