Loading ...
Sorry, an error occurred while loading the content.

Re: [tracker2] Using OT2 in KISS mode

Expand Messages
  • J. Lance Cotton
    ... I think I recall something about KISS mode on the T2 running only at 4800 bps, so you probably should have something like: 1 N1VLV-8 4800
    Message 1 of 7 , Dec 6, 2006
    • 0 Attachment
      on 12/6/2006 9:39 AM Stephen Brown Jr said the following:
      > Here is my /etc/ax25/axports:
      > n1vlv-debian:~# cat /etc/ax25/axports
      > # /etc/ax25/axports
      > #
      > # The format of this file is:
      > #
      > # name callsign speed paclen window description
      > #
      > 1 N1VLV-8 9600 255 2 145.010 MHz (1200 bps)

      I think I recall something about KISS mode on the T2 running only at 4800
      bps, so you probably should have something like:


      1 N1VLV-8 4800 255 2 145.010 MHz (1200 bps)


      --
      J. Lance Cotton, KJ5O
      joe@...
      http://kj5o.lightningflash.net
      Three Step Plan: 1. Take over the world. 2. Get a lot of cookies. 3. Eat the
      cookies.
    • Scott Miller
      No, KISS will work at any baud rate now. You just need to make sure you set it. If you re running the new firmware, set AMODE KISS and ABAUD 9600 to run KISS
      Message 2 of 7 , Dec 6, 2006
      • 0 Attachment
        No, KISS will work at any baud rate now.  You just need to make sure you set it.  If you're running the new firmware, set AMODE KISS and ABAUD 9600 to run KISS at 9600 on the primary port.
         
        Scott


        From: tracker2@yahoogroups.com [mailto:tracker2@yahoogroups.com] On Behalf Of J. Lance Cotton
        Sent: Wednesday, December 06, 2006 7:57 AM
        To: tracker2@yahoogroups.com
        Subject: Re: [tracker2] Using OT2 in KISS mode

        on 12/6/2006 9:39 AM Stephen Brown Jr said the following:
        > Here is my /etc/ax25/axports:
        > n1vlv-debian: ~# cat /etc/ax25/axports
        > # /etc/ax25/axports
        > #
        > # The format of this file is:
        > #
        > # name callsign speed paclen window description
        > #
        > 1 N1VLV-8 9600 255 2 145.010 MHz (1200 bps)

        I think I recall something about KISS mode on the T2 running only at 4800
        bps, so you probably should have something like:

        1 N1VLV-8 4800 255 2 145.010 MHz (1200 bps)

        --
        J. Lance Cotton, KJ5O
        joe@lightningflash. net
        http://kj5o. lightningflash. net
        Three Step Plan: 1. Take over the world. 2. Get a lot of cookies. 3. Eat the
        cookies.

      • Stephen Brown Jr
        I m still fighting this and not having much luck :( I am up to date on all the firmware, and I am using config 2 in KISS mode. I have amode set to KISS, and
        Message 3 of 7 , Dec 6, 2006
        • 0 Attachment
          I'm still fighting this and not having much luck :( I am up to date on all the firmware, and I am using config 2 in KISS mode. I have amode set to KISS, and abaud set to 9600. I have the ax25 module loaded, and ran kissattach successfully.  Running listen from the CLI yields nothing, yet if I open up minicom and shoot a packet from my TH-D7, I do see garbage, so I'm assuming something is there. I swear there has got to be some small overlooked thing I have not found yet.....

          Ideas and suggestions appreciated!

          73's
          Stephen
          N1VLV


          On 12/6/06, Scott Miller <scott@... > wrote:

          No, KISS will work at any baud rate now.  You just need to make sure you set it.  If you're running the new firmware, set AMODE KISS and ABAUD 9600 to run KISS at 9600 on the primary port.
           
          Scott


          From: tracker2@yahoogroups.com [mailto:tracker2@yahoogroups.com] On Behalf Of J. Lance Cotton
          Sent: Wednesday, December 06, 2006 7:57 AM
          To: tracker2@yahoogroups.com
          Subject: Re: [tracker2] Using OT2 in KISS mode

          on 12/6/2006 9:39 AM Stephen Brown Jr said the following:
          > Here is my /etc/ax25/axports:
          > n1vlv-debian:~# cat /etc/ax25/axports
          > # /etc/ax25/axports
          > #
          > # The format of this file is:
          > #
          > # name callsign speed paclen window description
          > #
          > 1 N1VLV-8 9600 255 2 145.010 MHz (1200 bps)

          I think I recall something about KISS mode on the T2 running only at 4800
          bps, so you probably should have something like:

          1 N1VLV-8 4800 255 2 145.010 MHz (1200 bps)

          --
          J. Lance Cotton, KJ5O
          joe@...
          http://kj5o.lightningflash.net
          Three Step Plan: 1. Take over the world. 2. Get a lot of cookies. 3. Eat the
          cookies.


        • Scott Miller
          Got Xastir loaded? Try running it in KISS TNC mode, see if it can talk to the T2 directly. I m no expert on Linux AX.25, and I had some difficulty myself
          Message 4 of 7 , Dec 6, 2006
          • 0 Attachment
            Got Xastir loaded?  Try running it in KISS TNC mode, see if it can talk to the T2 directly.  I'm no expert on Linux AX.25, and I had some difficulty myself getting it set up (with a KPC-3), but that was so long ago I've forgotten what I had to do.  I think my biggest problem was the custom kernel build, since I kept forgetting the oddball IDE controller and various other critical bits.
             
            Scott


            From: tracker2@yahoogroups.com [mailto:tracker2@yahoogroups.com] On Behalf Of Stephen Brown Jr
            Sent: Wednesday, December 06, 2006 7:33 PM
            To: tracker2@yahoogroups.com
            Subject: Re: [tracker2] Using OT2 in KISS mode

            I'm still fighting this and not having much luck :( I am up to date on all the firmware, and I am using config 2 in KISS mode. I have amode set to KISS, and abaud set to 9600. I have the ax25 module loaded, and ran kissattach successfully.  Running listen from the CLI yields nothing, yet if I open up minicom and shoot a packet from my TH-D7, I do see garbage, so I'm assuming something is there. I swear there has got to be some small overlooked thing I have not found yet.....

            Ideas and suggestions appreciated!

            73's
            Stephen
            N1VLV


            On 12/6/06, Scott Miller <scott@opentrac. org > wrote:

            No, KISS will work at any baud rate now.  You just need to make sure you set it.  If you're running the new firmware, set AMODE KISS and ABAUD 9600 to run KISS at 9600 on the primary port.
             
            Scott


            From: tracker2@yahoogroups.com [mailto:tracker2@yahoogroups. com] On Behalf Of J. Lance Cotton
            Sent: Wednesday, December 06, 2006 7:57 AM
            To: tracker2@yahoogroups.com
            Subject: Re: [tracker2] Using OT2 in KISS mode

            on 12/6/2006 9:39 AM Stephen Brown Jr said the following:
            > Here is my /etc/ax25/axports:
            > n1vlv-debian: ~# cat /etc/ax25/axports
            > # /etc/ax25/axports
            > #
            > # The format of this file is:
            > #
            > # name callsign speed paclen window description
            > #
            > 1 N1VLV-8 9600 255 2 145.010 MHz (1200 bps)

            I think I recall something about KISS mode on the T2 running only at 4800
            bps, so you probably should have something like:

            1 N1VLV-8 4800 255 2 145.010 MHz (1200 bps)

            --
            J. Lance Cotton, KJ5O
            joe@lightningflash. net
            http://kj5o. lightningflash. net
            Three Step Plan: 1. Take over the world. 2. Get a lot of cookies. 3. Eat the
            cookies.


          • Lance Cotton
            ... Again, just guessing, but I would check to see if the rest of the modules are loaded. I think you would need: crc_ccitt, ax25, and mkiss. For your 2.4.33
            Message 5 of 7 , Dec 7, 2006
            • 0 Attachment
              Stephen Brown Jr wrote:
              > I'm still fighting this and not having much luck :( I am up to date on
              > all the firmware, and I am using config 2 in KISS mode. I have amode set
              > to KISS, and abaud set to 9600. I have the ax25 module loaded, and ran
              > kissattach successfully. Running listen from the CLI yields nothing,
              > yet if I open up minicom and shoot a packet from my TH-D7, I do see
              > garbage, so I'm assuming something is there. I swear there has got to be
              > some small overlooked thing I have not found yet.....
              >
              > Ideas and suggestions appreciated!

              Again, just guessing, but I would check to see if the rest of the
              modules are loaded. I think you would need: crc_ccitt, ax25, and mkiss.
              For your 2.4.33 kernel, obviously ax25 is already there.

              I would think that you'd get an error if you ran kissattach without the
              mkiss module loaded, but perhaps it doesn't. Look through
              /var/log/messages when you run kissattach to see if any errors show up
              there.

              I've set up ax25/kiss networking with KPC-3+, Elcom's mUSB-TNT, and
              TNC-X, on both SuSE 9 and Ubuntu 6.06, but it's been so long ago now
              that I may have forgotten any troubles I ran into.

              I have had a lot of luck scanning through /var/log/messages for clues
              about kernel modules loading (especially for the BP-96 modem from Baycom)

              -Lance KJ5O

              --
              J. Lance Cotton, KJ5O
              joe@...
              http://kj5o.lightningflash.net
              Three Step Plan: 1. Take over the world. 2. Get a lot of cookies. 3. Eat
              the cookies.
            Your message has been successfully submitted and would be delivered to recipients shortly.