Loading ...
Sorry, an error occurred while loading the content.

15937RE: Re: [tracker2] Re: My Peet Ultimeter 800 won't talk to my new T3-301

Expand Messages
  • ve7eje
    Sep 25, 2013
    • 0 Attachment

      I am beginning to think this has to be a timing issue. I have added a true RS-232 interface and can log the Peet output to the computer perfectly. When I connect the Peet output to the T3-301, I get the occasional WX packet immediately after powering the 301 up but not ever again.

      If I connect the 301 to the laptop and send the just captured data back to the 301, it works fine.

      About the only thing left that I can think to try is capture the raw signals with a storage scope and see if anything looks out of place with the timing there. I don't have access to a serial protocol analyzer unfortunately.

      -Rob-



      ---In tracker2@yahoogroups.com, <tracker2@yahoogroups.com> wrote:

      I think at some point I was writing a serial capture program that would
      also record timing of incoming characters, but I don't know what
      happened to that.

      If all else fails, you're welcome to send me the Peet 800 and I'll see
      what I can do with it here. I don't think I've ever had a chance to try
      out that model.

      Scott

      On 9/14/2013 11:45 AM, rclists@... wrote:
      > I tried 19,200 which is the only other data rate that the Peet 800
      > supports and didn't get anything at all.
      >
      > Oddly, the time when it does seem to work at 2400 is immediately after
      > powering up the T3-301. About 1 of 3 power cycles will send a valid
      > weather packet. After that though, nothing.
      >
      > I will try a MAX232 converter on the Peet and see if that helps.
      > Probably need to invert it first.
      >
      > -Rob-
      >
      >
      >
      > --- In tracker2@yahoogroups.com, <tracker2@yahoogroups.com> wrote:
      >
      > The T3 has a MAX202 in it and should have a threshold under 2 volts.
      > Seems more likely to me that it could be a timing problem - maybe the
      > Peet is pausing in places the PC isn't.
      >
      > Can you try some different baud rates and see if anything changes?
      >
      > Scott
      >
      > On 9/12/2013 7:46 PM, ve7eje wrote:
      > > OK, this is weird.
      > > I captured about 10 minutes of data from the Peet on my laptop, and then
      > > sent it back to the 301. The 301 seems to accept it just fine.
      > > When I look at the data on the scope it seems almost identical to what
      > > the Peet was sending, just slightly higher P-P voltage. +/- 6V from the
      > > laptop vs +/- 5V direct from the Peet.
      > > I may have to do an RS-232 conversion after all...
      > >
      > > --- Intracker2@yahoogroups.com <mailto:tracker2@yahoogroups.com>, Scott
      > Miller <scott@...> wrote:
      > > >
      > > > Here's a bit of Peet data for your testing:
      > > >
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > &CR&0000008000000000032E032E0000281C0001E3FE0001030D------------000004540136000700000000000001360007013600070000000000000136000728030026000000800000000000002803002602E0034C00000000000002E0034C03F2000000000000000003F2000003F2000000000000000003F2000000C0007900000000000000C0007903A900070000008000000000000003A90007281D03B5000000000000281D03B505D7000100000000000005D700010000000000000000000000000000000000000000000000000000000000000000000000000000008000800000
      > > >
      > > > Scott
      > > >
      > > > On 9/11/2013 8:46 PM, ve7eje wrote:
      > > > > The Peet appears to be putting out valid data. At least when I
      > > connect a
      > > > > laptop to its output, it looks like what Peet doc says it should look
      > > > > like. I will try and capture some data and send it to the 301 from the
      > > > > computer and see if it will accept that.
      > > > > I have also tried both inputs on the 301. Neither makes any difference.
      > > > >
      > > > > --- Intracker2@yahoogroups.com <mailto:tracker2@yahoogroups.com>, "ve7eje"
      > <rclists@> wrote:
      > > > > >
      > > > > > OK, I managed to get the Peet serial data to the T3-301 up to +/- 5V
      > > > > but still no wx data making it across.
      > > > > > Would anyone have a working canned wx data capture I could try
      > > > > sending from a computer? That may help pin this down to a Peet problem
      > > > > or a T3-301 problem.
      > > > > > Thanks
      > > > > >
      > > > > > --- Intracker2@yahoogroups.com <mailto:tracker2@yahoogroups.com>, "ve7eje"
      > <rclists@> wrote:
      > > > > > >
      > > > > > > The OT1+ was the device that was previously working and was stolen.
      > > > > I have not been able to get the 301 to work with the 800 at all. I even
      > > > > sent the 800 control head and IO module back to Peet for repair. Just
      > > > > got it back and still no communication although the serial output does
      > > > > look cleaner than when I sent it away.
      > > > > > > -Rob-
      > > > > > >
      > > > > > > --- Intracker2@yahoogroups.com <mailto:tracker2@yahoogroups.com>, Scott
      > Miller <scott@> wrote:
      > > > > > > >
      > > > > > > > Hi Rob,
      > > > > > > >
      > > > > > > > Was the same Peet 800 working with the T3-301 you had before?
      > > Or are
      > > > > > > > you saying the OT1+ was the device that was stolen?
      > > > > > > >
      > > > > > > > Scott
      > > > > > > >
      > > > > > > > On 9/9/2013 8:34 PM, ve7eje wrote:
      > > > > > > > > This has been driving me nuts for a while so I am hoping
      > > > > someone here
      > > > > > > > > has made this work. I recently replaced an OT1+ and Icom
      > > > > handheld with a
      > > > > > > > > T3-301. That combo worked great for several years until some
      > > > > miscreant
      > > > > > > > > decided they wanted it more than me!
      > > > > > > > > My problem is that I cannot get the Peet 800 to communicate
      > > > > reliably
      > > > > > > > > with the new T3-301. The radio beacons and sends telemetry just
      > > > > fine but
      > > > > > > > > doesn't want to receive any data from the 800. It isn't a speed
      > > > > issue as
      > > > > > > > > I do get the occasional valid wx data packet sent. It acts
      > > like the
      > > > > > > > > RS-232 serial data from the Peet isn't being received properly
      > > > > by the
      > > > > > > > > 301. If I stick a scope on the data input at the radio I do see
      > > > > nice
      > > > > > > > > clean 5V P-P data coming from the Peet.
      > > > > > > > > Anyone have any suggestions? At the moment the only thing I can
      > > > > think of
      > > > > > > > > to try is to convert the 800 serial data up to true +/- 12V
      > > > > RS232 and
      > > > > > > > > try that.
      > > > > > > > >
      > > > > > > > > Thanks -Rob-
      > > > > > > > >
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > > >
      > > >
      > >
      > >
      >
      >
    • Show all 16 messages in this topic