Loading ...
Sorry, an error occurred while loading the content.

15416OT1 USB problems...

Expand Messages
  • ricer3dad
    Apr 1 6:54 PM
      Not sure what I've done to my OT1 USB... but hope it's not dead.

      I use Linux mostly (Ubuntu 10.10), so I followed the usb wiki to set up the symbolic link and successfully ran the otwincfg.exe (operating under wine). It recognized the device displayed the default settings.
      I was also able to connect to it with the Linux cu utility (cu -l ttyACM0).

      Well, I noticed that there was a flash file on the Argentdata website for the OT1 USB (dated January 30, 2012), so I downloaded the file and used the otwincfg program to flash the file into the OT1 USB. But instead of a "successful load" message I got an error message about a bad data value. So i tried it again but this time I had the otwincfg program retrieve the flash file from the web. The same error message appeared. So I closed the program and powered off the device by unplugging the USB from the OT1 and then plugged it back in again.

      Now when I plug the USB in, the LED indicator is solid green and it stays on as long as the USB is connnected. I can't seem to get the otwincfg file to recognize the device. (But doing a terminal command lsusb shows that the usb is recognized: Bus 003 Device 006: ID 134a:9000)

      Instead of the USB power, when I plug in the +12VDC the LED flashes red at approximately a 1 Hz. rate. While the +12VDC is applied, attaching the USB to my Linux computer still doesn't recognize the device... but it still flashes red at 1Hz.

      Performing dmesg shows:
      [ 2399.096034] usb 3-1: new full speed USB device using uhci_hcd and address 6
      [ 2404.279184] cdc_acm 3-1:1.0: This device cannot do calls on its own. It is not a modem.
      [ 2404.279221] cdc_acm 3-1:1.0: ttyACM0: USB ACM device

      Any suggestions/comments/thoughts would be greatly appreciated.
    • Show all 6 messages in this topic