Loading ...
Sorry, an error occurred while loading the content.

RE: [toad] how to create Euro sy mbol â,¬ into a O racle table via using TOAD

Expand Messages
  • Karen Chu
    Thank you very much. I was able to change the font to COURIER NEW. I do see the right symbol in my sql statement (in toad editor) if I copy paste the symbol
    Message 1 of 58 , Nov 30, 2009
    • 0 Attachment

      Thank you very much.

      I was able to change the font to COURIER NEW.

      I do see the right symbol in my sql statement (in toad editor) if I copy paste the symbol from word.

      However, if I try  “Num Lock on,  ALT 0128”, it gives me a question mark in toad editor still.

       

       

      From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] On Behalf Of Erwin Rollauer
      Sent: Monday, November 30, 2009 1:53 PM
      To: toad@yahoogroups.com
      Subject: RE: [toad] how to create Euro symbol â,¬ into a Oracle table via using TOAD

       

       

      Go to OPTIONSèEDITOR/BEHAVIOUR

      In Toad 9.7 you see this

       

      Click on the triple dot button next to PL/SQL in LANGUAGES

       

      And you should see this

      Now you can play. In the above you see a button labelled CUSTOM FONT. You may see something else. Change it to CORIER NEW.

      Then do the APPLY and OK on each screen.

       

      Toad is not at the stage where you must know the OPTIONS dialogue.

       

      From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] On Behalf Of Karen Chu
      Sent: November 30, 2009 3:27 PM
      To: toad@yahoogroups.com
      Subject: RE: [toad] how to create Euro symbol â,¬ into a Oracle table via using TOAD

       





      ALT 0128 (with numlock on) in toad editor gives me a question mark (?) in my Toad for Oracle 9.5.

      Where do you change to COURIER NEW? I used View->Toad Options->Editor->Display->Button Text…, but it did not help.

       

       

      From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] On Behalf Of Rich Jesse
      Sent: Monday, November 30, 2009 11:31 AM
      To: toad@yahoogroups.com
      Subject: RE: [toad] how to create Euro symbol â,¬ into a Oracle table via using TOAD

       

       

      Yay! Glad you were able to figure it out!

      Rich -- [TeamT]

      Disclaimer: My workload is interrupting my online Christmas shopping today.

      > Everything is OK. I checked further and I noticed my EDITOR font was
      COURIER
      > instead of COURIER NEW.
      >
      > Both ALT-0128 (with numlock on) and copy/pasting from word gave me a BLACK
      > bar before changing the font and both give me the correct symbol after
      going
      > to COURIER NEW. I lied when I said one worked and the other did not.

       





    • Jeff Smith
      ... NLS params apply to any/all applications/sessions. From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] On Behalf Of Sam M. Koshy Sent: Monday,
      Message 58 of 58 , Dec 7, 2009
      • 0 Attachment

        >> I have used SQL Developer & DBConsole as well ; I assume none of them need any NLS params to be set.
        NLS params apply to any/all applications/sessions. 

         

        From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] On Behalf Of Sam M. Koshy
        Sent: Monday, December 07, 2009 10:35 AM
        To: toad@yahoogroups.com
        Subject: Re: [toad] Finding the right font

         

         

        Thanks for your time, Norm & Rich.
        I have used SQL Developer & DBConsole as well ; I assume none of them need any NLS params to be set.

        I assume, this could have something to do with the export  from the Telnet session ( possible incorrect NLS_LANG Settings) ; originally when it was moved from a non-unicode to a unicode 9.2.0.3 and later on to a 11.1.0.6 DB.

        Tnx :-)

         


        From: "Dunbar, Norman" <toad@...>
        To: toad@yahoogroups.com
        Sent: Mon, December 7, 2009 5:54:54 PM
        Subject: RE: [toad] Finding the right font

         

        Hi Sam,

        Your attachments are difficult to find, they are stored at Yahoo rather
        than being attached to the email! Strange.

        However, I've got the following:

        PINCODE DUMP(PINCODE, 16)
        2++++2++ Typ=1 Len=8: 32,11,05,15, 02,32,11, 08
        2++++2++ Typ=1 Len=8: 32,11,05,15, 02,32,11, 08
        2++++2++ Typ=1 Len=8: 32,11,05,15, 02,32,11, 08
        2++++2++ Typ=1 Len=8: 32,11,05,15, 02,32,11, 08

        Where I've replaced the "boxes" with "+" because they were affecting my
        display!

        Varchar2(8 char) means that the column is big enough to store 8
        characters (regardless of how ever many bytes they all need) rather than
        8 bytes. The characterset in use is the database characterset and not
        the National character set. I'm assuming that this is AL32UTF8 from
        your first post in this thread.

        If this is the case, all National (N*) data types will be stored in
        UTF8.

        Now, in the Globalization manual, table B2 (in the 10g version anyway)
        says that 7 Bit ASCII characters (0x00 to 0x7f) are stored in one byte
        in UTF8. This looks true for your '2' characters above (0x32). However,
        the other characters are also ASCII codes (they are in range) and should
        not be stored in anything other than one byte.

        I'm wondering if you don't have some sort of corruption going on here?
        You are getting control characters stored in the PINCODE column and it
        doesn't look like a UNICODE/UTF8 problems as such, especially as all
        four of the ones you sent appear to be identical.

        I presume that the PINCODE column is supposed to contain 'printable'
        characters and not these mixtures of printable and binary/control codes?

        Is the client environment set up with proper NLS_LANG settings - it
        could be something as simple (!) as a client-server mis-translation
        between character sets going on?

        I'm sorry I don't have much more of use for you. :-(

        Cheers,
        Norm. [TeamT]

        Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else. We have checked this email and its attachments for viruses. But you should still check any attachment before opening it. We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes. If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment- agency.gov. uk

        Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

        We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
        We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

        If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment- agency.gov. uk

         

      Your message has been successfully submitted and would be delivered to recipients shortly.