Loading ...
Sorry, an error occurred while loading the content.

RE: [toad] Question: CREATE OR REPLACE in packages

Expand Messages
  • Umgelter, Peter (LST)
    Hello Ian, upper- or lowercase in SQL is no issue with Oracle, no matter what platform it is running on. I see no reason why your standards group wanted to
    Message 1 of 7 , May 2, 2004
    • 0 Attachment
      Hello Ian,

      upper- or lowercase in SQL is no issue with Oracle, no matter
      what platform it is running on.
      I see no reason why your standards group wanted to change your
      previous policy.

      However the option can be found under:
      Editor Options/Highlighting/Reserved Word

      --
      Peter Umgelter
      LVAmt Abt. 5
      Tel. 0711-6376-550
      mailto:Peter.Umgelter@...

      > -----Original Message-----
      > From: ianjacksonca [mailto:ian.jackson@...]
      > Sent: Friday, April 30, 2004 3:54 PM
      > To: toad@yahoogroups.com
      > Subject: [toad] Question: CREATE OR REPLACE in packages
      >
      >
      > Background: We are starting to move to Oracle 9i forms and UNIX
      > servers, so uppercase / lowercase have become more of an issue.
      > Our standards group has decided that all code will be in lowercase,
      > with the except of strings in quotes.
    • Peter Lorenzen
      Hi Peter, When is this option enforced/executed? I have changed the option so everything should be in lower case, but when I open a package everything is still
      Message 2 of 7 , May 3, 2004
      • 0 Attachment
        Hi Peter,

        When is this option enforced/executed? I have changed the option so
        everything should be in lower case, but when I open a package everything is
        still in upper case? I always thought that the reason was that you had to
        have an add on module (formatter) for this to work, but maybe I have
        misunderstood it all?

        Another case question. When you for example mark a table name in the schema
        browser and press ctr+c and go to an editor and press ctrl-v the table name
        is in upper case. Are there still no way to change this to be in lower case?

        I hate all the upper case in my code, and that the tool I use has to decide
        how I write my code. This is the reason why I still write all my code in
        Ultra Edit and not in Toad.

        Regards,
        Peter Lorenzen


        -----Oprindelig meddelelse-----
        Fra: Umgelter, Peter (LST) [mailto:Peter.Umgelter@...]
        Sendt: 3. maj 2004 08:24
        Til: 'toad@yahoogroups.com'
        Emne: RE: [toad] Question: CREATE OR REPLACE in packages

        Hello Ian,

        upper- or lowercase in SQL is no issue with Oracle, no matter
        what platform it is running on.
        I see no reason why your standards group wanted to change your
        previous policy.

        However the option can be found under:
        Editor Options/Highlighting/Reserved Word

        --
        Peter Umgelter
        LVAmt Abt. 5
        Tel. 0711-6376-550
        mailto:Peter.Umgelter@...

        > -----Original Message-----
        > From: ianjacksonca [mailto:ian.jackson@...]
        > Sent: Friday, April 30, 2004 3:54 PM
        > To: toad@yahoogroups.com
        > Subject: [toad] Question: CREATE OR REPLACE in packages
        >
        >
        > Background: We are starting to move to Oracle 9i forms and UNIX
        > servers, so uppercase / lowercase have become more of an issue.
        > Our standards group has decided that all code will be in lowercase,
        > with the except of strings in quotes.


        Questions? Try the on-line FAQ: http://www.toadsoft.com/faq2.html

        To download the beta: http://www.toadsoft.com/beta.zip
        Yahoo! Groups Links
      • Umgelter, Peter (LST)
        Hi Peter, ... I checked again and found out that I gave the wrong option in my previous message. It should be Sql Reserved and PLSql Reserved and not
        Message 3 of 7 , May 3, 2004
        • 0 Attachment
          Hi Peter,

          > When is this option enforced/executed? I have changed the option so
          > everything should be in lower case, but when I open a package
          > everything is
          > still in upper case?

          I checked again and found out that I gave the wrong option
          in my previous message.

          It should be "Sql Reserved" and "PLSql Reserved" and not
          "Reserved Word".

          I never gave much attention to these options, I'm quite
          satisfied with the default way of Toad formatting.

          Regards
          --
          Peter Umgelter
          LVAmt Abt. 5
          Tel. 0711-6376-550
          mailto:Peter.Umgelter@...
        • ianjacksonca
          Hi Peter, I tried that and am still having the problem. Let me go through the steps and see if it does the same for you. 1. Open Procedure Editor 2. Change
          Message 4 of 7 , May 3, 2004
          • 0 Attachment
            Hi Peter, I tried that and am still having the problem. Let me go
            through the steps and see if it does the same for you.

            1. Open Procedure Editor
            2. Change Editing Options / Highlighting / SQL Reserved & PL/SQL
            Reserved to lowercase
            3. Open a package .. change the CREATE OR REPLACE to lowercase
            4. Close Tab
            5. Open the package again .. it is back to uppercase

            As for the standards group .. I know it doesn't matter to Oracle, but
            I think it was just easier for them to have on general rule instead
            of detailing what is upper and what is lower.

            Thanks
            Ian
          • ianjacksonca
            missed a step .. 3.5 compile package. ian ... but
            Message 5 of 7 , May 3, 2004
            • 0 Attachment
              missed a step .. 3.5 compile package.
              ian

              --- In toad@yahoogroups.com, "ianjacksonca" <ian.jackson@h...> wrote:
              > Hi Peter, I tried that and am still having the problem. Let me go
              > through the steps and see if it does the same for you.
              >
              > 1. Open Procedure Editor
              > 2. Change Editing Options / Highlighting / SQL Reserved & PL/SQL
              > Reserved to lowercase
              > 3. Open a package .. change the CREATE OR REPLACE to lowercase
              > 4. Close Tab
              > 5. Open the package again .. it is back to uppercase
              >
              > As for the standards group .. I know it doesn't matter to Oracle,
              but
              > I think it was just easier for them to have on general rule instead
              > of detailing what is upper and what is lower.
              >
              > Thanks
              > Ian
            • Umgelter, Peter (LST)
              Hello Ian, ... I followed your steps and it worked here. You don t have to edit the code manually. Try open a package first and then change the options, you
              Message 6 of 7 , May 3, 2004
              • 0 Attachment
                Hello Ian,

                > Hi Peter, I tried that and am still having the problem. Let me go
                > through the steps and see if it does the same for you.
                >
                > 1. Open Procedure Editor
                > 2. Change Editing Options / Highlighting / SQL Reserved & PL/SQL
                > Reserved to lowercase
                > 3. Open a package .. change the CREATE OR REPLACE to lowercase
                > 4. Close Tab
                > 5. Open the package again .. it is back to uppercase

                I followed your steps and it worked here.
                You don't have to edit the code manually.

                Try open a package first and then change the options,
                you should see the effect immediately after you close the
                Editor options dialog, even without recompile or reformat.

                If not, then the editor is still ignoring your options.

                Regards
                --
                Peter Umgelter
                LVAmt Abt. 5
                Tel. 0711-6376-550
                mailto:Peter.Umgelter@...
              Your message has been successfully submitted and would be delivered to recipients shortly.