Loading ...
Sorry, an error occurred while loading the content.
 

7bit encoding

Expand Messages
  • halloleo2000
    hi marcello i appriciate Tmail2000. we use it to access existing outlook express mailboxes. but i discovered a problem: 7bit encoded email are decoded. that
    Message 1 of 4 , Oct 23, 2002
      hi marcello

      i appriciate Tmail2000. we use it to access existing outlook
      express mailboxes.

      but i discovered a problem: 7bit encoded email are decoded. that
      can raise strange signs in the output. i have attached an example
      email (as eml-file) showing the problem. the wrong sign comes up
      in line

      > > > TYPE=DFR,SMSCONSTRUCT=NO,...

      in the function function TMailPart.Decode the decoding work is
      done under the condition

      if (Encoding = 'quoted-printable')or (Encoding = '7bit') then

      after deletion "(Encoding = '7bit')" it works fine for me. my
      questions now are: is that conform with all the rfcs? (rfc 821
      says: 7bit is just 7bit and has no encoding. so it needs no decoding)
      is my change ok for other email encodings?

      ta for every response!

      leooo

      ---

      Return-Path: <SDonk@...>
      Received: from DFRInnovation.Com ([192.168.150.109]) by
      mail.fdrinnovation.com (Netscape Messaging Server 4.15) with
      ESMTP id GU26H500.E61; Thu, 4 Apr 2002 14:36:41 -0500
      Message-ID: <3CACABE0.51C39261@...>
      Date: Thu, 04 Apr 2002 14:39:12 -0500
      From: "Steve Donk" <sdonk@...>
      X-Mailer: Mozilla 4.77 [en] (Win98; U)
      X-Accept-Language: en
      MIME-Version: 1.0
      To: "Williams Rusty" <rwilliams@...>
      Subject: #034483 Re: [Fwd: p53.5216]
      References: <69CFB2288E23EA46974DF08C1284FB2817CA21@...>
      Content-Type: multipart/mixed;
      boundary="------------A3EF607C06AD7F57CB466422"

      This is a multi-part message in MIME format.
      --------------A3EF607C06AD7F57CB466422
      Content-Type: text/plain; charset=us-ascii
      Content-Transfer-Encoding: 7bit

      > > > TYPE=DFR,SMSCONSTRUCT=NO,SMSPROT=NONE,MAXCARDS=999,MAXDD=999
      > > >
      > > > DFR303 CARD IMAGE -- MOUNT VOL=SMPRSA,FLASHUNIT=504B
      5002 SYSTEMS
      > > > VOLUME

      --------------A3EF607C06AD7F57CB466422
      Content-Type: text/x-vcard; charset=us-ascii;
      name="SDonk.vcf"
      Content-Transfer-Encoding: 7bit
      Content-Description: Card for Steve J. Donk
      Content-Disposition: attachment;
      filename="SDonk.vcf"

      begin:vcard
      n:Donk;Steve
      tel;work:973-890-7300
      x-mozilla-html:FALSE
      org:Innovation Data Processing, Inc
      adr:;;265 Paterson Street;Big Falls;New Jersey;07424-1658;
      version:2.1
      email;internet:SDonk@...
      title:Developer
      fn:Steve J. Donk
      end:vcard

      --------------A3EF607C06AD7F57CB466422--
    • Marcello
      Hi Mr Leo, You re likely using a older version of this component. I figured out what you are saying and already fixed this, try visiting the component website
      Message 2 of 4 , Oct 24, 2002
        Hi Mr Leo,

        You're likely using a older version of this component.
        I figured out what you are saying and already fixed this, try visiting
        the component website to download the lastest version:

        http://groups.yahoo.com/group/tmail2000

        Be encouraged to join the discussion group.

        Best wishes,

        --- halloleo2000 <halloleo@...> wrote:
        > hi marcello
        >
        > i appriciate Tmail2000. we use it to access existing outlook
        > express mailboxes.
        >
        > but i discovered a problem: 7bit encoded email are decoded. that
        > can raise strange signs in the output. i have attached an example
        > email (as eml-file) showing the problem. the wrong sign comes up
        > in line
        >
        > > > > TYPE=DFR,SMSCONSTRUCT=NO,...
        >
        > in the function function TMailPart.Decode the decoding work is
        > done under the condition
        >
        > if (Encoding = 'quoted-printable')or (Encoding = '7bit') then
        >
        > after deletion "(Encoding = '7bit')" it works fine for me. my
        > questions now are: is that conform with all the rfcs? (rfc 821
        > says: 7bit is just 7bit and has no encoding. so it needs no decoding)
        > is my change ok for other email encodings?
        >
        > ta for every response!
        >
        > leooo
        >
        > ---
        >
        > Return-Path: <SDonk@...>
        > Received: from DFRInnovation.Com ([192.168.150.109]) by
        > mail.fdrinnovation.com (Netscape Messaging Server 4.15)
        > with
        > ESMTP id GU26H500.E61; Thu, 4 Apr 2002 14:36:41 -0500
        > Message-ID: <3CACABE0.51C39261@...>
        > Date: Thu, 04 Apr 2002 14:39:12 -0500
        > From: "Steve Donk" <sdonk@...>
        > X-Mailer: Mozilla 4.77 [en] (Win98; U)
        > X-Accept-Language: en
        > MIME-Version: 1.0
        > To: "Williams Rusty" <rwilliams@...>
        > Subject: #034483 Re: [Fwd: p53.5216]
        > References:
        > <69CFB2288E23EA46974DF08C1284FB2817CA21@...>
        > Content-Type: multipart/mixed;
        > boundary="------------A3EF607C06AD7F57CB466422"
        >
        > This is a multi-part message in MIME format.
        > --------------A3EF607C06AD7F57CB466422
        > Content-Type: text/plain; charset=us-ascii
        > Content-Transfer-Encoding: 7bit
        >
        > > > > TYPE=DFR,SMSCONSTRUCT=NO,SMSPROT=NONE,MAXCARDS=999,MAXDD=999
        > > > >
        > > > > DFR303 CARD IMAGE -- MOUNT VOL=SMPRSA,FLASHUNIT=504B
        > 5002 SYSTEMS
        > > > > VOLUME
        >
        > --------------A3EF607C06AD7F57CB466422
        > Content-Type: text/x-vcard; charset=us-ascii;
        > name="SDonk.vcf"
        > Content-Transfer-Encoding: 7bit
        > Content-Description: Card for Steve J. Donk
        > Content-Disposition: attachment;
        > filename="SDonk.vcf"
        >
        > begin:vcard
        > n:Donk;Steve
        > tel;work:973-890-7300
        > x-mozilla-html:FALSE
        > org:Innovation Data Processing, Inc
        > adr:;;265 Paterson Street;Big Falls;New Jersey;07424-1658;
        > version:2.1
        > email;internet:SDonk@...
        > title:Developer
        > fn:Steve J. Donk
        > end:vcard
        >
        > --------------A3EF607C06AD7F57CB466422--
        >
        >


        =====
        Marcello Tavares
        mycelo@...
        ICQ 5831833
        Sorocaba/SP BRAZIL

        __________________________________________________
        Do you Yahoo!?
        Y! Web Hosting - Let the expert host your web site
        http://webhosting.yahoo.com/
      • halloleo2000
        hi marcello ... at first: thanks for your response! ... that s right, but i tried an newer version (V 1.10.1 beta) and i found the same problem: the 7bit
        Message 3 of 4 , Oct 27, 2002
          hi marcello

          --- In tmail2000@y..., Marcello <mycelo@y...> wrote:

          at first: thanks for your response!

          > You're likely using a older version of this component.

          that's right, but i tried an newer version (V 1.10.1 beta) and i
          found the same problem: the 7bit encoded *is* decoded. beacuse of the
          line 3200 (in v1.10.1):

          if (Encoding = 'quoted-printable') or (Encoding = '7bit') then

          maybe i use the decode-function in an inappropriate way?

          ta in advance, leo

          ps: i stuck with the older version because two problems i had with
          the old version occured in the newer one aswell:
          (i) html-body mails have an empty body and
          (ii) 7bit encoding is decoded. (the here-issued problem)
        • Marcello
          Hi Mr, This was fixed on lastest version (1.10.2). See what s new . Regards, ... ===== Marcello Tavares mycelo@yahoo.com ICQ 5831833 Sorocaba/SP BRAZIL
          Message 4 of 4 , Oct 29, 2002
            Hi Mr,

            This was fixed on lastest version (1.10.2).
            See "what's new".

            Regards,

            --- halloleo2000 <halloleo@...> wrote:
            > hi marcello
            >
            > --- In tmail2000@y..., Marcello <mycelo@y...> wrote:
            >
            > at first: thanks for your response!
            >
            > > You're likely using a older version of this component.
            >
            > that's right, but i tried an newer version (V 1.10.1 beta) and i
            > found the same problem: the 7bit encoded *is* decoded. beacuse of the
            >
            > line 3200 (in v1.10.1):
            >
            > if (Encoding = 'quoted-printable') or (Encoding = '7bit') then
            >
            > maybe i use the decode-function in an inappropriate way?
            >
            > ta in advance, leo
            >
            > ps: i stuck with the older version because two problems i had with
            > the old version occured in the newer one aswell:
            > (i) html-body mails have an empty body and
            > (ii) 7bit encoding is decoded. (the here-issued problem)
            >
            >


            =====
            Marcello Tavares
            mycelo@...
            ICQ 5831833
            Sorocaba/SP BRAZIL

            __________________________________________________
            Do you Yahoo!?
            Y! Web Hosting - Let the expert host your web site
            http://webhosting.yahoo.com/
          Your message has been successfully submitted and would be delivered to recipients shortly.