Loading ...
Sorry, an error occurred while loading the content.

Help with

Expand Messages
  • john324451
    I am making a schoolboy error somewhere, but I cannot find it. I create a template A Output A I create another
    Message 1 of 6 , Jul 1, 2010
    • 0 Attachment
      I am making a schoolboy error somewhere, but I cannot find it.

      I create a template "A"

      <TEMPLATE>
      <SECTION>
      Output A
      </SECTION>
      </TEMPLATE>

      I create another template "B"

      <TEMPLATE>
      <SECTION>
      Output B
      </SECTION>
      </TEMPLATE>

      Finally, a third template "AB"

      <TEMPLATE>
      <INCLUDE ENTRY="A">
      <INCLUDE ENTRY="B">
      </TEMPLATE>

      When I use the template AB, I only get the text "Output A". If I execute AB again, I now get "Output B". Again, and I get "Output A".

      Please help.

      John
    • David Michael
      What you describe you re getting, sounds right to me. What are you *expecting* to get that you re not getting? -David
      Message 2 of 6 , Jul 1, 2010
      • 0 Attachment
        What you describe you're getting, sounds right to me.

        What are you *expecting* to get that you're not getting?

        -David

        On 7/1/2010 8:51 AM, john324451 wrote:
        > I am making a schoolboy error somewhere, but I cannot find it.
        >
        > I create a template "A"
        >
        > <TEMPLATE>
        > <SECTION>
        > Output A
        > </SECTION>
        > </TEMPLATE>
        >
        > I create another template "B"
        >
        > <TEMPLATE>
        > <SECTION>
        > Output B
        > </SECTION>
        > </TEMPLATE>
        >
        > Finally, a third template "AB"
        >
        > <TEMPLATE>
        > <INCLUDE ENTRY="A">
        > <INCLUDE ENTRY="B">
        > </TEMPLATE>
        >
        > When I use the template AB, I only get the text "Output A". If I execute AB again, I now get "Output B". Again, and I get "Output A".
        >
        > Please help.
        >
        > John
        >
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      • john324451
        Hi David, I had assumed that I would get Output A Output B every time I executed the AB template - that is, it would execute each of the INCLUDE statements
        Message 3 of 6 , Jul 1, 2010
        • 0 Attachment
          Hi David,

          I had assumed that I would get

          Output A
          Output B

          every time I executed the "AB" template - that is, it would execute each of the INCLUDE statements until it reached the end of the AB template. It appears to only ever execute one of the INCLUDE statements (and it does it in sequence - I have tried by adding a C and a D), before exitting the AB template.

          Cheers,

          John


          --- In thejournal-users@yahoogroups.com, David Michael <davidrm@...> wrote:
          >
          > What you describe you're getting, sounds right to me.
          >
          > What are you *expecting* to get that you're not getting?
          >
          > -David
          >
          > On 7/1/2010 8:51 AM, john324451 wrote:
          > > I am making a schoolboy error somewhere, but I cannot find it.
          > >
          > > I create a template "A"
          > >
          > > <TEMPLATE>
          > > <SECTION>
          > > Output A
          > > </SECTION>
          > > </TEMPLATE>
          > >
          > > I create another template "B"
          > >
          > > <TEMPLATE>
          > > <SECTION>
          > > Output B
          > > </SECTION>
          > > </TEMPLATE>
          > >
          > > Finally, a third template "AB"
          > >
          > > <TEMPLATE>
          > > <INCLUDE ENTRY="A">
          > > <INCLUDE ENTRY="B">
          > > </TEMPLATE>
          > >
          > > When I use the template AB, I only get the text "Output A". If I execute AB again, I now get "Output B". Again, and I get "Output A".
          > >
          > > Please help.
          > >
          > > John
          > >
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          >
        • elaine.seery
          My 2p, ... I tried a while ago to do the same thing, with the same expectation and the same result. I was expecting both templates to appear, one after the
          Message 4 of 6 , Jul 2, 2010
          • 0 Attachment
            My 2p,

            > I had assumed that I would get
            >
            > Output A
            > Output B
            >
            > every time I executed the "AB" template - that is, it would execute each of the INCLUDE statements until it reached the end of the AB template. It appears to only ever execute one of the INCLUDE statements

            I tried a while ago to do the same thing, with the same expectation and the same result. I was expecting both templates to appear, one after the other. I didn't get as far as John, I wasn't that bothered, I just merged them instead.
          • David Michael
            To achieve that result, your AB template should be: -David
            Message 5 of 6 , Jul 2, 2010
            • 0 Attachment
              To achieve that result, your "AB" template should be:

              <template>
              <section>
              <select entry="A" />
              <select entry="B" />
              </section>
              </template>

              -David

              On 7/2/2010 1:19 AM, john324451 wrote:
              >
              >
              > Hi David,
              >
              > I had assumed that I would get
              >
              > Output A
              > Output B
              >
              > every time I executed the "AB" template - that is, it would execute each of the INCLUDE statements until it reached the end of the AB template. It appears to only ever execute one of the INCLUDE statements (and it does it in sequence - I have tried by adding a C and a D), before exitting the AB template.
              >
              > Cheers,
              >
              > John
              >
              >
              > --- In thejournal-users@yahoogroups.com, David Michael<davidrm@...> wrote:
              >>
              >> What you describe you're getting, sounds right to me.
              >>
              >> What are you *expecting* to get that you're not getting?
              >>
              >> -David
              >>
              >> On 7/1/2010 8:51 AM, john324451 wrote:
              >>> I am making a schoolboy error somewhere, but I cannot find it.
              >>>
              >>> I create a template "A"
              >>>
              >>> <TEMPLATE>
              >>> <SECTION>
              >>> Output A
              >>> </SECTION>
              >>> </TEMPLATE>
              >>>
              >>> I create another template "B"
              >>>
              >>> <TEMPLATE>
              >>> <SECTION>
              >>> Output B
              >>> </SECTION>
              >>> </TEMPLATE>
              >>>
              >>> Finally, a third template "AB"
              >>>
              >>> <TEMPLATE>
              >>> <INCLUDE ENTRY="A">
              >>> <INCLUDE ENTRY="B">
              >>> </TEMPLATE>
              >>>
              >>> When I use the template AB, I only get the text "Output A". If I execute AB again, I now get "Output B". Again, and I get "Output A".
              >>>
              >>> Please help.
              >>>
              >>> John
              >>>
              >>>
              >>>
              >>>
              >>> ------------------------------------
              >>>
              >>> Yahoo! Groups Links
              >>>
              >>>
              >>>
              >>>
              >>
              >
              >
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
            • john324451
              Bingo! Thanks David.
              Message 6 of 6 , Jul 2, 2010
              • 0 Attachment
                Bingo!

                Thanks David.

                --- In thejournal-users@yahoogroups.com, David Michael <davidrm@...> wrote:
                >
                > To achieve that result, your "AB" template should be:
                >
                > <template>
                > <section>
                > <select entry="A" />
                > <select entry="B" />
                > </section>
                > </template>
                >
                > -David
                >
                > On 7/2/2010 1:19 AM, john324451 wrote:
                > >
                > >
                > > Hi David,
                > >
                > > I had assumed that I would get
                > >
                > > Output A
                > > Output B
                > >
                > > every time I executed the "AB" template - that is, it would execute each of the INCLUDE statements until it reached the end of the AB template. It appears to only ever execute one of the INCLUDE statements (and it does it in sequence - I have tried by adding a C and a D), before exitting the AB template.
                > >
                > > Cheers,
                > >
                > > John
                > >
                > >
                > > --- In thejournal-users@yahoogroups.com, David Michael<davidrm@> wrote:
                > >>
                > >> What you describe you're getting, sounds right to me.
                > >>
                > >> What are you *expecting* to get that you're not getting?
                > >>
                > >> -David
                > >>
                > >> On 7/1/2010 8:51 AM, john324451 wrote:
                > >>> I am making a schoolboy error somewhere, but I cannot find it.
                > >>>
                > >>> I create a template "A"
                > >>>
                > >>> <TEMPLATE>
                > >>> <SECTION>
                > >>> Output A
                > >>> </SECTION>
                > >>> </TEMPLATE>
                > >>>
                > >>> I create another template "B"
                > >>>
                > >>> <TEMPLATE>
                > >>> <SECTION>
                > >>> Output B
                > >>> </SECTION>
                > >>> </TEMPLATE>
                > >>>
                > >>> Finally, a third template "AB"
                > >>>
                > >>> <TEMPLATE>
                > >>> <INCLUDE ENTRY="A">
                > >>> <INCLUDE ENTRY="B">
                > >>> </TEMPLATE>
                > >>>
                > >>> When I use the template AB, I only get the text "Output A". If I execute AB again, I now get "Output B". Again, and I get "Output A".
                > >>>
                > >>> Please help.
                > >>>
                > >>> John
                > >>>
                > >>>
                > >>>
                > >>>
                > >>> ------------------------------------
                > >>>
                > >>> Yahoo! Groups Links
                > >>>
                > >>>
                > >>>
                > >>>
                > >>
                > >
                > >
                > >
                > >
                > > ------------------------------------
                > >
                > > Yahoo! Groups Links
                > >
                > >
                > >
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.