Loading ...
Sorry, an error occurred while loading the content.

Re: Compilation problems with Aperios

Expand Messages
  • tencuid
    As I ve recently faced this problem I will give another solution for everyone who needs to solve it again. The problem is related to LOCALE s. To fix it
    Message 1 of 5 , Dec 15, 2011
    • 0 Attachment
      As I've recently faced this problem I will give another solution for everyone who needs to solve it again.

      The problem is related to LOCALE's. To fix it without changing your OS locale, just do:
      $export LANG=en-US.UTF-8
      $export LANGUAGE=en
      $export LC_ALL=C

      and then $make will not give you any error.

      Until it is fixed, I suggest to write a script like this:

      #!/bin/sh
      #change locales
      export LANG=en-US.UTF-8
      export LANGUAGE=en
      export LC_ALL=C
      make $1

      Hope it helps!!


      --- In tekkotsu_dev@yahoogroups.com, "xavips000" <xavips000@...> wrote:
      >
      > Thank you very much! The problem is solved changing the system language to English.
      >
      > About ==Bonus==, before the change of language, I had a lot of files prefixed by '#' below my $TEKKOTSU_ROOT folder, but nothing has changed after removing them .
      >
      > Thank you!
      >
      > xavi
      >
      > --- In tekkotsu_dev@yahoogroups.com, Ethan Tira-Thompson <ejt@> wrote:
      > >
      > > I just tried a clean aperios build on a 9.10 machine and wasn't able to replicate your problem. I see three issues in the output you posted:
      > >
      > > ==1==
      > > From the "[: 1: Illegal number: " in your output, I think you might be slightly out of date, try doing a 'cvs update'. This was from TEKKOTSU_PCH being undefined, also causing the "Generating .d" and ensuing errors (should be Generating common.h.d). This should now be fixed to ignore the precompiled header properly if TEKKOTSU_PCH is undefined.
      > >
      > > ==1A==
      > > Why is TEKKOTSU_PCH undefined? This comes from project/Environment.conf, you might want to enable the debug output at the bottom of that file to see if the version number is being detected properly. I note a previous post also contained the Illegal number error, and was also using a non-english localization, which might be breaking the version number parsing...?
      > >
      > > ==2==
      > > You're getting a lot of warning in system headers. These are supposed to be removed by tools/filtersyswarn, which is also configured in project/Environment.conf. That isn't working for you because of the language localization, which causes it not to match the regex patterns in filtersyswarn. You might want to either update the tool to match your language (just a few strings there if you know the corresponding error translation), or remove -Weffc++ from Makefile and project/Makefile which is where these warnings come from in the first place.
      > >
      > > If you know of a good way to test the language localization, we could wrap -Weffc++ with a test to only turn it on for English so filtersyswarn can get rid of all the stupid STL warnings and leave just the "real" warnings...
      > >
      > > ==Bonus==
      > > For future reference, I also uncovered a new problem when testing this:
      > > CVS sometimes creates directories named #cvs.locks (or sometimes doesn't remove them, perhaps if killed by Ctrl-C...?) Apparently the '#' character was disrupting part of the Makefile execution.
      > >
      > > Check for any similarly named files/directories:
      > > cd $TEKKOTSU_ROOT
      > > find . -name '*#*'
      > >
      > > Quick way to remove them:
      > > find . -name '*#*' -exec rmdir \{\} \; -prune
      > >
      > > (I actually used 'rm -rf' instead of 'rmdir' above... if that fails because there are files in the lock directories, double check the list of what it's trying to remove and switch to 'rm -rf')
      > >
      > > I would be surprised if this was your problem however, it was causing different symptoms. (not detecting the Aperios binary names, first being reported as missing Aperios stub headers)
      > >
      > >
      > > > sudo make TEKKOTSU_TARGET_PLATFORM=PLATFORM_APERIOS tekkotsu-ERS7
      > > >
      > > > sudo make install tekkotsu-ERS7 TEKKOTSU_TARGET_PLATFORM=PLATFORM_APERIOS
      > >
      > > FYI these commands cause a contradiction (particularly the latter) because tekkotsu-ERS7 is the local desktop executable, and this contradicts PLATFORM_APERIOS which produces a set of binaries for the Aibo. 'install' is also only a target for Aibo requesting copying to the memory stick, which wouldn't work with the tekkotsu-ERS7 executable.
      > >
      > > So either just 'tekkotsu-ERS7" for local execution or just 'install'/'update' for aperios execution.
      > >
      > > Hope that gets you back on track!
      > >
      > > -Ethan
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.