Loading ...
Sorry, an error occurred while loading the content.

Re: [tekkotsu_dev] Tekkotsu Beginner's Questions

Expand Messages
  • Veenushia Nair
    I had tried situp followed by pounce and then stand but it falls off backwards. Then, I tried liedown followed by pounce and then stand - it stand
    Message 1 of 4 , Jun 4, 2007
    • 0 Attachment
      I had tried "situp" followed by "pounce" and then "stand" but it falls off backwards.
      Then, I tried "liedown" followed by "pounce" and then "stand" - it stand up for a while and then switches off by itself. Had tried this several times but kept on repeating, even with "AutoGetup" behaviour on. The "pounce" position might be sufficient for me but just wonder what's happening there when it stands up?
       
      Also, I deleted "Smooth Video" and "Quality Video" from the 'Scripts' menu box. How can I add them back? Couldn't find them in the main menu list.
       
      Thanks a lot.
       


      Ethan Tira-Thompson <ejt@...> wrote:
      a) I made my Aibo to walk, sit up and lie down using the motion files found at /File Access/Load Posture. Is this the correct way? The Aibo falls over every time it tries to stand up - is there anything wrong here?
      Nope nothing wrong, it's just doing what you tell it to.

      I'm guessing you're trying to go directly from "situp" to "stand", which doesn't work (falls over backwards).  I suggest going to "pounce" and then "stand".  That should work ;)

      If you want it to be a little smarter when it falls over, check the AutoGetupBehavior in Background Behaviors.  (just watch out when you're carrying it then ;)

      Also, be aware that when loading postures, it's going to go *straight* to that posture.  This can cause joint overloads if the feet are trying to drag along the ground while the robot's weight is on them.  So you might need to make a motion sequence which does some smarter foot placement in some circumstances.

      b) Everything went fine until a point where the Aibo started to wag its ears continously (and doesn't respond to any commands). Does this indicate the battery level is down? Or does it trying to say anything else?
      Yeah, ear flapping is a low battery signal.  It should still respond to commands though.  The ear flapping gets faster as the battery gets lower, although older batteries seem to drop out pretty quick at the end, so it might go to full-speed flapping right off the bat.  Feel free to play around with Behaviors/Services/ BatteryMonitorBe havior.h. ..

      -ethan



      Need a vacation? Get great deals to amazing places on Yahoo! Travel.

    • Ethan Tira-Thompson
      ... You re getting a joint overload safety shutdown. Once the AIBO is standing, pick it up, and you ll notice they ve been trying to move, but can t while the
      Message 2 of 4 , Jun 4, 2007
      • 0 Attachment
        it stand up for a while and then switches off by itself. Had tried this several times but kept on repeating, even with "AutoGetup" behaviour on. The "pounce" position might be sufficient for me but just wonder what's happening there when it stands up?
        You're getting a joint overload safety shutdown.
        Once the AIBO is standing, pick it up, and you'll notice they've been trying to move, but can't while the Aibo's weight is on them.  This is simply because the "pounce" foot positions don't quite match the "stand" leg positions.  I suggest loading pounce, then stand, then hit estop, go to File Access menu, and resave the current posture over "stand".  Then you should be better guaranteed the foot placement will match so it won't be straining the joints to move some small distance.

        This is a general problem with standing on the legs -- if the joints are a little out of place when the Aibo's weight is on them, the Aibo will keep ramping up power to the joints to try to get where they're supposed to be, but won't be strong enough to overcome the friction, and eventually gives up and shuts down.

        So if you can somehow ensure the feet are accurately placed, that's one solution.  Another is to just reset the target joint positions to their current values once you're standing, so it doesn't keep trying to move if you're out of place.  Another is to have a type of idle behavior while you're standing which occasionally lifts each of the feet and shifts its weight around so it doesn't give any joints a chance to overload. (which is a pretty cool lifelike effect, but kind of annoying if you want a stable camera ;)

        Also, I deleted "Smooth Video" and "Quality Video" from the 'Scripts' menu box. How can I add them back? Couldn't find them in the main menu list.
        Yeah, if you 'edit' them, you'll see they're actually a series of configuration parameters being set, not just a single menu entry.  To get it back, track down your java preferences file for the ControllerGUI and delete it, and you'll get the default values back.  (the location is system dependent -- on OS X, it's Library/Preferences/org.tekkotsu.mon.plist)

        Alternatively, check the ControllerGUI source code for the scripts:

        Quality Video:
        !set vision.rawcam.transport=tcp
        !set vision.rawcam.compression=none
        !set vision.rawcam.y_skip=1
        !set vision.rawcam.uv_skip=1
        !set vision.rawcam.interval=1500

        Smooth Video:
        !set vision.rawcam.y_skip=2
        !set vision.rawcam.uv_skip=3
        !set vision.rawcam.interval=0
        !set vision.rawcam.compression=jpeg
        !set vision.rawcam.transport=udp

        -ethan

      Your message has been successfully submitted and would be delivered to recipients shortly.