Loading ...
Sorry, an error occurred while loading the content.

Re: [tekkotsu_dev] ERS-7M3

Expand Messages
  • Ethan Tira-Thompson
    ... Me too. I got one other bug report regarding the M3 not working (appears to crash in the Motion process), but i haven t gotten enough information on it yet
    Message 1 of 4 , Jan 3, 2006
    • 0 Attachment
      > I was under the assumption that they only changed to Mind 3 for the
      > new model and the hardware remains unchanged.
      Me too.

      I got one other bug report regarding the M3 not working (appears to
      crash in the Motion process), but i haven't gotten enough information
      on it yet to have any idea what's going on in there. Send me the
      output of running crashDebug after it crashes (I'm assuming that's
      what happens for you as well).
      http://www.cs.cmu.edu/~tekkotsu/FAQ.html#It_crashed_Where_did_it_crash

      I hear the M3 has an updated ethernet card which requires a new
      driver, and hence the update to the OPEN-R SDK, but that was the only
      significant change. So, make sure you're running with the latest
      OPEN-R SDK version for the M3...

      thanks,
      -ethan
    • Ethan Tira-Thompson
      Good news! Our first ERS-7M3 arrived today, and I ve been doing a little testing. It looks like the current code in CVS will boot the robot successfully, but
      Message 2 of 4 , Jan 4, 2006
      • 0 Attachment
        Good news! Our first ERS-7M3 arrived today, and I've been doing a
        little testing.

        It looks like the current code in CVS will boot the robot successfully,
        but the 2.4 release will not. I'm looking into the cause for that -- if
        it's something straightforward I'll provide a patch for 2.4 users, but
        otherwise in the mean time you're welcome to do a CVS update and things
        should work again (and you'll get a head start on updating to 2.5)

        Also, when updating your OPEN-R installation, remember to do a clean
        build in Tekkotsu to make sure the modifications are picked up. (I had
        some strange behavior after forgetting to do that myself)

        -ethan
      • Ethan Tira-Thompson
        Sorry, I spoke too soon. ... The 2.4.1 release works fine -- it was simply that I was using the precompiled demo stick, which was built with the old OPEN-R
        Message 3 of 4 , Jan 4, 2006
        • 0 Attachment
          Sorry, I spoke too soon.

          > It looks like the current code in CVS will boot the robot successfully,
          > but the 2.4 release will not.

          The 2.4.1 release works fine -- it was simply that I was using the
          precompiled demo stick, which was built with the old OPEN-R release
          (r3). A 2.4.1 build using OPEN-R r4 works just fine, and the updated
          precompiled stick is now live on the website. Hopefully that
          straightens out the M3 issue. :)

          -ethan
        Your message has been successfully submitted and would be delivered to recipients shortly.