Loading ...
Sorry, an error occurred while loading the content.

Re: ERROR: MotionSequenceMC

Expand Messages
  • Sebastiaan van Loon
    Sorry for the delay, but I was away for two week. ... You are right, when I use 128 ms as a sampling time, the delay is gone. ... I will have to look into it
    Message 1 of 5 , Aug 1, 2005
    • 0 Attachment

      Sorry for the delay, but I was away for two week.

       

      > 100ms is probably about

      right.  I wouldn't want to go any shorter 

      > though.

      > However, you might want to

      consider using a sample time that's a 

      > multiple of the Aibo's joint

      update time (32ms).

       

      You are right, when I use 128 ms as a sampling time, the delay is gone.

       

      > Unfortunately,

      MotionSequenceEngine doesn't directly support 

      > looping.

      style="mso-spacerun: yes">  (this has been on my todo for a while)  So you can instead 

      > listen for an event in your

      behavior from the motion to know when 

      > it's done and manually

      restart it, or you can patch the 

      > MotionSequenceEngine itself

      to add support looping, and send the 

      > patch to me

      ;)

       

      I will have to look into it in more detail, but thanks for the tips.

       

      Thanks again for the help.

       

      Sebastiaan

       
      PS I attached the motionfiles I created, maybe you can use it for stress testing
    Your message has been successfully submitted and would be delivered to recipients shortly.