Loading ...
Sorry, an error occurred while loading the content.

2353Re: [tekkotsu_dev] Problem with "camera object" in Mirage simulator

Expand Messages
  • Ignacio Herrero Reder
    Jul 5, 2012
    • 0 Attachment
      Hello. You forgot write also the <Visible> </false> key at line 53, as Camera objet has two components (revolute and prismatics) if you don't do so, you'll see the camera object as a little blue sphere just at the center of the image.
      But the overall fix worked like a charm!!

      Ignacio Herrero Reder            / Tl. +34-95.213.71.60
      Dpto. Tecnologia Electronica     / Fax: +34-95.213.14.47 
      E.T.S. Ing. Telecomunicacion     / nhr@... 
      Universidad de Malaga            / http://www.dte.uma.es
      Campus Universitario de Teatinos 
      29010 Malaga, Spain  
      El 05/07/2012 1:23, Ethan Tira-Thompson escribió:
       


      On Jul 4, 2012, at 4:10 PM, Ethan Tira-Thompson <ejt@...> wrote:

      I notice the CameraFOV for Aibo and some other robots isn’t using Visible=False in the .kin, we probably should be doing that so it doesn’t try to render the FOV cone regardless of the near clipping distance.  (in other words, if you shorten near clipping, make sure to either remove CameraFOV or add an entry: <key>Visible</key> <false/>

      Actually this was just a straightforward oversight, I’ve fixed them up:
      Thus when one robot sees another, it shouldn’t see the FOV cone, that would only show up in the Mirage window.  It’s kind of a useless indicator though, mostly handy when initially writing the .kin to make sure the camera is in the right place.

      -Ethan


    • Show all 15 messages in this topic