Loading ...
Sorry, an error occurred while loading the content.

2352Re: [tekkotsu_dev] Problem with "camera object" in Mirage simulator

Expand Messages
  • Ignacio Herrero Reder
    Jul 5, 2012
    • 0 Attachment
      Thanks a lot Ethan!! It seems to work!!

      Ignacio Herrero Reder / Tl. +34-95.213.71.60
      Dpto. Tecnologia Electronica / Fax: +34-95.213.14.47
      E.T.S. Ing. Telecomunicacion / nhr@...
      Universidad de Malaga / http://www.dte.uma.es
      Campus Universitario de Teatinos
      29010 Malaga, Spain

      El 05/07/2012 1:10, Ethan Tira-Thompson escribió:
      > I’m pretty sure you’d still see this even if you removed the blue graphic (remove the CameraFOV Model in the .kin file). The problem is the graphics engine has a minimum clipping distance for the camera, within which it doesn’t try to render the object. For your example this is also annoying because Ogre doesn’t render the back faces, so you wind up losing both the front and back of the sphere.
      >
      > This would probably be a good thing to make configurable, but for now you can edit the value at Tekkotsu/tools/mirage/src/CameraInfo.cc:86:
      > ogreCamera->setNearClipDistance(40);
      >
      > There’s a similar but different value for the user window that mirage itself displays, UIController.cc:496: mCamera->setNearClipDistance(5);
      >
      > I notice the CameraFOV for Aibo and some other robots isn’t using Visible=False in the .kin, we probably should be doing that so it doesn’t try to render the FOV cone regardless of the near clipping distance. (in other words, if you shorten near clipping, make sure to either remove CameraFOV or add an entry: <key>Visible</key> <false/>
      >
      > -Ethan
      >
      > On Jul 4, 2012, at 5:00 AM, Ignacio Herrero Reder <nhr@...> wrote:
      >
      >> Hello. I've found a problem when using simulated robots with camera in Mirage and camera must be close to the object it is viewing. It seems that the "blue pyramid" which shows the camera angle have some interference with the objects, so they
      >> disappear from the simulated world. Is there any way to avoid this? Or perhaps should I "move" the blue pyramid at the kinematic model inside the head frame?
      >>
      >> I enclose an attached image with an example of such interference. Thanks for your help.
      >> Regards
      >>
      >>
      >>
      >> Ignacio Herrero Reder / Tl. +34-95.213.71.60
      >> Dpto. Tecnologia Electronica / Fax: +34-95.213.14.47
      >> E.T.S. Ing. Telecomunicacion / nhr@...
      >> Universidad de Malaga / http://www.dte.uma.es
      >> Campus Universitario de Teatinos
      >> 29010 Malaga, Spain
      >>
      >>
      >>
      >>
      >> ------------------------------------
      >>
      >> Yahoo! Groups Links
      >>
      >>
      >>
      >>
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    • Show all 15 messages in this topic