Loading ...
Sorry, an error occurred while loading the content.
 

SVG Bug Introduced in Webkit ( Chrome )

Expand Messages
  • Raks A
    Hi, I ve found this bug on a pretty innocuous looking svg. All this does is make a circle on and off I have two such blocks one with a begin time of 0s and
    Message 1 of 1 , Jun 4, 2012
      Hi,

      I've found this bug on a pretty innocuous looking svg. All this does is
      make a circle on and off
      I have two such blocks one with a begin time of 0s and another of begin
      3.9s. Rest all of the things being same the behaviour is still different in
      that for 0s the freeze behaviour is correct and as expected whereas for
      begin 3.9s the fill=freeze behaviour is not correct.

      Pretty strange and shocking too ? Can any one try and see if this indeed a
      bug ? I have pasted the code below
      I tried this on Google Chrome 17.0.963.46

      - Raks


      <?xml version="1.0" encoding="UTF-8"?>
      <svg display="inherit" version="1.1" xml:space="preserve" xmlns="
      http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"
      xmlns:ev="http://www.w3.org/2001/xml-events">
      <g display="none">
      <animate attributeName="display" begin="0" calcMode="discrete"
      dur="0.8" fill="freeze" end="0.8" keyTimes="0;0.25;0.75;1.0"
      values="inherit;none;inherit;none"/>
      <circle cx="215" cy="120" r="20" fill="#ff0000"/>
      <circle cx="715" cy="620" r="20" fill="#00f0f0"/>
      </g>

      <g display="none">
      <animate attributeName="display" begin="3.9" calcMode="discrete"
      dur="0.8" end="4.7" fill="freeze" keyTimes="0;0.25;0.75;1.0"
      values="inherit;none;inherit;none"/>
      <circle cx="415" cy="120" r="20" fill="#ff0000"/>
      <circle cx="615" cy="620" r="20" fill="#00f0f0"/>
      </g>
      </svg>


      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.