Loading ...
Sorry, an error occurred while loading the content.

Re: Problem loading javascript file in Adobe SVG viewer

Expand Messages
  • fgn.rm
    All, thank you very much for your suggestions, it got me going in the right direction. The problems wasn t the Content-Type, it was the Cache control. IE
    Message 1 of 5 , Jul 31 2:46 PM
    • 0 Attachment
      All, thank you very much for your suggestions, it got me going in the right direction. The problems wasn't the Content-Type, it was the Cache control. IE doesn't like the Cache-Control settings below when it comes from a secure web server (HTTPS, SSL). I used the php function session_cache_limiter() and it did the trick. Now my svg graphics works with the generated javascript code!

      Problem solved! wooohooo

      --- In svg-developers@yahoogroups.com, "fgn.rm" <fgn@...> wrote:
      >
      > Very good suggestions, but it didn't do the trick :(
      >
      > I ran curl -I xxxx and got the following result:
      >
      > HTTP/1.1 200 OK
      > Date: Sat, 30 Jul 2011 23:36:17 GMT
      > Server: Apache/2.2.3 (Red Hat)
      > X-Powered-By: PHP/5.1.6
      > Set-Cookie: PHPSESSID=6t5lovfpmvd6rhb7426t8lckm4; path=/
      > Expires: Thu, 19 Nov 1981 08:52:00 GMT
      > Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
      > Pragma: no-cache
      > Connection: close
      > Content-Type: text/html
      >
      > Then I inserted the line
      > header("Content-Type: text/ecmascript");
      > as the first line on the php script and got the following result
      >
      > HTTP/1.1 200 OK
      > Date: Sat, 30 Jul 2011 23:38:28 GMT
      > Server: Apache/2.2.3 (Red Hat)
      > X-Powered-By: PHP/5.1.6
      > Set-Cookie: PHPSESSID=1a6h5qorhsoqpsrib2jukk2ab2; path=/
      > Expires: Thu, 19 Nov 1981 08:52:00 GMT
      > Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
      > Pragma: no-cache
      > Connection: close
      > Content-Type: text/ecmascript
      >
      > still the script doesn't get loaded it seems
      >
      >
      >
      > --- In svg-developers@yahoogroups.com, Jacob Beard <jbeard4@> wrote:
      > >
      > > You can check the MIME type and headers using curl -I, e.g.:
      > >
      > > curl -I
      > > https://xxxxxxxxxxxxxxxxxxxxxxxxxxxx/Common/lib/generate_javascript?this_graphic=ball
      > >
      > > Jake
      > >
      > > On Sat, Jul 30, 2011 at 5:07 PM, Jon Frost <jonfrost@> wrote:
      > >
      > > > **
      > > >
      > > >
      > > > The issue might be that the PHP code that generates your .js script might
      > > > need to specify that it is returning a file of Content-type
      > > > "text/ecmascript
      > > > ".
      > > >
      > > > I suggest asking your hosting company to check this out for you - often
      > > > they
      > > > are happy to help.
      > > >
      > > > Best of luck.
      > > > Jon
      > > >
      > > > [Non-text portions of this message have been removed]
      > > >
      > > >
      > > >
      > >
      > >
      > > [Non-text portions of this message have been removed]
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.