Loading ...
Sorry, an error occurred while loading the content.

Re: [svg-developers] SVG in Firefox

Expand Messages
  • narendra sisodiya
    ... How you checked that content type is wrong, I use firebug but unable to locate such details,, --
    Message 1 of 17 , Feb 5, 2009
    • 0 Attachment
      On Thu, Feb 5, 2009 at 6:51 PM, G. Wade Johnson <gwadej@...> wrote:

      > On Thu, 05 Feb 2009 02:52:56 -0000
      > "hardisondan" <hardisondan@... <hardisondan%40yahoo.com>> wrote:
      >
      > > Hi,
      > >
      > > Can anyone tell me what I'm doing wrong here?
      > >
      > > If you click on this link:
      > >
      > > http://people.aapt.net.au/~AAPT_12950709/index.htm<http://people.aapt.net.au/%7EAAPT_12950709/index.htm>
      > > <http://people.aapt.net.au/%7EAAPT_12950709/index.htm>
      > >
      > > In IE6 and 7, it takes you to the Adobe SVG viewer download and after
      > > that seems to work fine.
      > >
      > > In Firefox, where I thought SVG support was native, it doesnt work. It
      > > doesnt seem to find the viewer to download.
      > >
      > > And if you go straight to the SVG file like this:
      > >
      > > http://people.aapt.net.au/~AAPT_12950709/graph.svg<http://people.aapt.net.au/%7EAAPT_12950709/graph.svg>
      > > <http://people.aapt.net.au/%7EAAPT_12950709/graph.svg>
      > >
      > > it just shows the SVG code and doesnt render the image.
      > >
      > > I havent tried any other browsers.
      > >
      > > Any advice appreciated.
      >
      > Firefox is correct.
      >
      > Your webserver is returning the wrong content type for SVG. It's
      > returning "text/plain" instead of "image/svg+xml".
      >
      > G. Wade
      >

      How you checked that content type is wrong, I use firebug but unable to
      locate such details,,

      --
      ┌─────────────────────────┐
      │ Narendra Sisodiya ( नरेन्द्र सिसोदिया )
      │ R&D Engineer
      http://narendra.techfandu.org
      └─────────────────────────┘


      [Non-text portions of this message have been removed]
    • Samuel Dagan
      Hi Narenda, Have a look at http://wiki.svg.org/MIME_Type . You ll find there the required information. Cheers, Samy ...
      Message 2 of 17 , Feb 5, 2009
      • 0 Attachment
        Hi Narenda,
        Have a look at http://wiki.svg.org/MIME_Type .
        You'll find there the required information.
        Cheers, Samy

        --- In svg-developers@yahoogroups.com, narendra sisodiya
        <narendra.sisodiya@...> wrote:
        >
        > On Thu, Feb 5, 2009 at 6:51 PM, G. Wade Johnson <gwadej@...> wrote:
        >
        > > On Thu, 05 Feb 2009 02:52:56 -0000
        > > "hardisondan" <hardisondan@... <hardisondan%40yahoo.com>> wrote:
        > >
        > > > Hi,
        > > >
        > > > Can anyone tell me what I'm doing wrong here?
        > > >
        > > > If you click on this link:
        > > >
        > > >
        http://people.aapt.net.au/~AAPT_12950709/index.htm<http://people.aapt.net.au/%7EAAPT_12950709/index.htm>
        > > > <http://people.aapt.net.au/%7EAAPT_12950709/index.htm>
        > > >
        > > > In IE6 and 7, it takes you to the Adobe SVG viewer download and
        after
        > > > that seems to work fine.
        > > >
        > > > In Firefox, where I thought SVG support was native, it doesnt
        work. It
        > > > doesnt seem to find the viewer to download.
        > > >
        > > > And if you go straight to the SVG file like this:
        > > >
        > > >
        http://people.aapt.net.au/~AAPT_12950709/graph.svg<http://people.aapt.net.au/%7EAAPT_12950709/graph.svg>
        > > > <http://people.aapt.net.au/%7EAAPT_12950709/graph.svg>
        > > >
        > > > it just shows the SVG code and doesnt render the image.
        > > >
        > > > I havent tried any other browsers.
        > > >
        > > > Any advice appreciated.
        > >
        > > Firefox is correct.
        > >
        > > Your webserver is returning the wrong content type for SVG. It's
        > > returning "text/plain" instead of "image/svg+xml".
        > >
        > > G. Wade
        > >
        >
        > How you checked that content type is wrong, I use firebug but unable to
        > locate such details,,
        >
        > --
        > â"Œâ"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"
        > â"‚ Narendra Sisodiya ( नरेन्द्र सिसोदिया )
        > â"‚ R&D Engineer
        > â"‚ http://narendra.techfandu.org
        > â""â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"€â"˜
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Guy Morton
        Look at the headers sent by the web server.
        Message 3 of 17 , Feb 5, 2009
        • 0 Attachment
          Look at the headers sent by the web server.

          On 06/02/2009, at 1:02 AM, narendra sisodiya wrote:

          > On Thu, Feb 5, 2009 at 6:51 PM, G. Wade Johnson <gwadej@...>
          > wrote:
          >
          >> On Thu, 05 Feb 2009 02:52:56 -0000
          >> "hardisondan" <hardisondan@... <hardisondan%40yahoo.com>>
          >> wrote:
          >>
          >>> Hi,
          >>>
          >>> Can anyone tell me what I'm doing wrong here?
          >>>
          >>> If you click on this link:
          >>>
          >>> http://people.aapt.net.au/~AAPT_12950709/index.htm<http://people.aapt.net.au/%7EAAPT_12950709/index.htm
          >>> >
          >>> <http://people.aapt.net.au/%7EAAPT_12950709/index.htm>
          >>>
          >>> In IE6 and 7, it takes you to the Adobe SVG viewer download and
          >>> after
          >>> that seems to work fine.
          >>>
          >>> In Firefox, where I thought SVG support was native, it doesnt
          >>> work. It
          >>> doesnt seem to find the viewer to download.
          >>>
          >>> And if you go straight to the SVG file like this:
          >>>
          >>> http://people.aapt.net.au/~AAPT_12950709/graph.svg<http://people.aapt.net.au/%7EAAPT_12950709/graph.svg
          >>> >
          >>> <http://people.aapt.net.au/%7EAAPT_12950709/graph.svg>
          >>>
          >>> it just shows the SVG code and doesnt render the image.
          >>>
          >>> I havent tried any other browsers.
          >>>
          >>> Any advice appreciated.
          >>
          >> Firefox is correct.
          >>
          >> Your webserver is returning the wrong content type for SVG. It's
          >> returning "text/plain" instead of "image/svg+xml".
          >>
          >> G. Wade
          >>
          >
          > How you checked that content type is wrong, I use firebug but unable
          > to
          > locate such details,,
          >
          > --
          > ┌
          > ─
          > ─
          > ─
          > ──────────────────────┐
          > │ Narendra Sisodiya ( नरेन्द्र
          > सिसोदिया )
          > │ R&D Engineer
          > │ http://narendra.techfandu.org
          > └
          > ─
          > ─
          > ─
          > ──────────────────────┘
          >
          >
          > [Non-text portions of this message have been removed]
          >
          >
          >
          > ------------------------------------
          >
          > -----
          > To unsubscribe send a message to: svg-developers-unsubscribe@yahoogroups.com
          > -or-
          > visit http://groups.yahoo.com/group/svg-developers and click "edit
          > my membership"
          > ----Yahoo! Groups Links
          >
          >
          >
        • Dan Hardison
          Thanks! Is there any way I can change that? Its just a free web page provided by my ISP. I doubt if I have much control over it. But if I can modify my page
          Message 4 of 17 , Feb 5, 2009
          • 0 Attachment
            Thanks! Is there any way I can change that? Its just a free web page provided by my ISP. I doubt if I have much control over it. But if I can modify my page somehow to fix it I will.

            Dan





            ________________________________
            From: G. Wade Johnson <gwadej@...>
            To: svg-developers@yahoogroups.com
            Sent: Friday, 6 February, 2009 12:21:09 AM
            Subject: Re: [svg-developers] SVG in Firefox


            On Thu, 05 Feb 2009 02:52:56 -0000
            "hardisondan" <hardisondan@ yahoo.com> wrote:

            > Hi,
            >
            > Can anyone tell me what I'm doing wrong here?
            >
            > If you click on this link:
            >
            > http://people. aapt.net. au/~AAPT_ 12950709/ index.htm
            > <http://people. aapt.net. au/%7EAAPT_ 12950709/ index.htm>
            >
            > In IE6 and 7, it takes you to the Adobe SVG viewer download and after
            > that seems to work fine.
            >
            > In Firefox, where I thought SVG support was native, it doesnt work. It
            > doesnt seem to find the viewer to download.
            >
            > And if you go straight to the SVG file like this:
            >
            > http://people. aapt.net. au/~AAPT_ 12950709/ graph.svg
            > <http://people. aapt.net. au/%7EAAPT_ 12950709/ graph.svg>
            >
            > it just shows the SVG code and doesnt render the image.
            >
            > I havent tried any other browsers.
            >
            > Any advice appreciated.

            Firefox is correct.

            Your webserver is returning the wrong content type for SVG. It's
            returning "text/plain" instead of "image/svg+xml" .

            G. Wade
            --
            There are 2 possible outcomes: If the result confirms the hypothesis,
            then you've made a measurement. If the result is contrary to the
            hypothesis, then you've made a discovery. -- Enrico Fermi




            Make Yahoo!7 your homepage and win a trip to the Quiksilver Pro. Find out more

            [Non-text portions of this message have been removed]
          • Robert Longson
            ... You don t need any add-ons for this. Tools- Page Info Then look at the Type field. Best regards Robert
            Message 5 of 17 , Feb 5, 2009
            • 0 Attachment
              --- In svg-developers@yahoogroups.com, narendra sisodiya
              <narendra.sisodiya@...> wrote:
              >
              > How you checked that content type is wrong, I use firebug but unable to
              > locate such details,,
              >

              You don't need any add-ons for this.

              Tools->Page Info

              Then look at the Type field.

              Best regards

              Robert
            • Jake Beard
              Haha, that s cool, I didn t know you could do that, Jake
              Message 6 of 17 , Feb 5, 2009
              • 0 Attachment
                Haha, that's cool, I didn't know you could do that,

                Jake

                Robert Longson wrote:
                >
                > --- In svg-developers@yahoogroups.com
                > <mailto:svg-developers%40yahoogroups.com>, narendra sisodiya
                > <narendra.sisodiya@...> wrote:
                > >
                > > How you checked that content type is wrong, I use firebug but unable to
                > > locate such details,,
                > >
                >
                > You don't need any add-ons for this.
                >
                > Tools->Page Info
                >
                > Then look at the Type field.
                >
                > Best regards
                >
                > Robert
                >
                >
              • G. Wade Johnson
                On Thu, 5 Feb 2009 14:16:08 -0800 (PST) ... The SVG Wiki has a page on this: http://wiki.svg.org/MIME_Type. Samuel Dagan already provided it. You can ask your
                Message 7 of 17 , Feb 6, 2009
                • 0 Attachment
                  On Thu, 5 Feb 2009 14:16:08 -0800 (PST)
                  Dan Hardison <hardisondan@...> wrote:

                  > Thanks! Is there any way I can change that? Its just a free web page
                  > provided by my ISP. I doubt if I have much control over it. But if I
                  > can modify my page somehow to fix it I will.

                  The SVG Wiki has a page on this: http://wiki.svg.org/MIME_Type. Samuel
                  Dagan already provided it.

                  You can ask your ISP if they can fix the mime-types for the whole site.
                  It's not likely they would help, but it's worth a try. Otherwise, you
                  can use the advice on the Wiki to set the type for the directory where
                  your SVG lives.

                  HTH,
                  G. Wade

                  > ________________________________
                  > From: G. Wade Johnson <gwadej@...>
                  > To: svg-developers@yahoogroups.com
                  > Sent: Friday, 6 February, 2009 12:21:09 AM
                  > Subject: Re: [svg-developers] SVG in Firefox
                  >
                  >
                  > On Thu, 05 Feb 2009 02:52:56 -0000
                  > "hardisondan" <hardisondan@ yahoo.com> wrote:
                  >
                  > > Hi,
                  > >
                  > > Can anyone tell me what I'm doing wrong here?
                  > >
                  > > If you click on this link:
                  > >
                  > > http://people. aapt.net. au/~AAPT_ 12950709/ index.htm
                  > > <http://people. aapt.net. au/%7EAAPT_ 12950709/ index.htm>
                  > >
                  > > In IE6 and 7, it takes you to the Adobe SVG viewer download and
                  > > after that seems to work fine.
                  > >
                  > > In Firefox, where I thought SVG support was native, it doesnt work.
                  > > It doesnt seem to find the viewer to download.
                  > >
                  > > And if you go straight to the SVG file like this:
                  > >
                  > > http://people. aapt.net. au/~AAPT_ 12950709/ graph.svg
                  > > <http://people. aapt.net. au/%7EAAPT_ 12950709/ graph.svg>
                  > >
                  > > it just shows the SVG code and doesnt render the image.
                  > >
                  > > I havent tried any other browsers.
                  > >
                  > > Any advice appreciated.
                  >
                  > Firefox is correct.
                  >
                  > Your webserver is returning the wrong content type for SVG. It's
                  > returning "text/plain" instead of "image/svg+xml" .
                  >
                  > G. Wade


                  --
                  If a cluttered desk is the sign of a cluttered mind, what is the
                  significance of a clean desk? -- Laurence J. Peter
                • cwflamont
                  ... If my ISP is anything to go by, they will not let you do that either. I came to the conclusion that the problem is that SVG does not yet appear to be an
                  Message 8 of 17 , Feb 6, 2009
                  • 0 Attachment
                    --- In svg-developers@yahoogroups.com, "G. Wade Johnson" <gwadej@...>
                    wrote:

                    > [] Otherwise, you can use the advice on the Wiki to set the type
                    > for the directory where your SVG lives.
                    >
                    > HTH,

                    If my ISP is anything to go by, they will not let you do that either.
                    I came to the conclusion that the problem is that SVG does not yet
                    appear to be an ICAN approved MIME type. Can anyone explain why not? I
                    thought it had been going through the process months ago.
                  Your message has been successfully submitted and would be delivered to recipients shortly.