Loading ...
Sorry, an error occurred while loading the content.
 

External image & xlink problem

Expand Messages
  • Damian
    Erik:I posted this problem, but i had no answers (tested in Opera 9.5):
    Message 1 of 4 , Apr 4, 2008
      Erik:

      I posted this problem, but i had no answers (tested in Opera 9.5):

      <a xlink:href="http://www.google.com">
      <image xlink:href="flower.svg" x="230" width="200" height="200" />
      </a>

      the <a> tag is not works.

      Is this a bug?

      Regards,
      Damian Zulcovsky (WikiDraw project)





      ----- Original Message -----
      From: "Erik Dahlström" <ed@...>
      To: <svg-developers@yahoogroups.com>
      Sent: Thursday, April 03, 2008 8:42 AM
      Subject: Re: [svg-developers] Rgarding use of AJAX with SVG


      > On Wed, 02 Apr 2008 14:51:55 +0200, bharatc86 <bharatc66@...> wrote:
      >
      >> Hi ,
      >> I needed to use SVG in AJAX to communicate wth the server and
      >> retreive data from it. The AJAX calls a python file that performs the
      >> xml-rpc and returns a string to the file with AJAX . Currently we have
      >> created an AJAX page that uses a container created using the DIV tag
      >> to store returned string and saved it as .pt tag. Now i need to use
      >> the AJAX commands in a .svg file .If anyone knows about this please
      >> help us.
      >
      > You can do some reading here:
      > http://wiki.svg.org/index.php?title=XMLHttpRequest
      >
      > And I made an example of using XMLHttpRequests in svg here:
      > http://widgets.opera.com/widget/7370/
      >
      > Hope this helps
      > /Erik
      >
      > --
      > Erik Dahlstrom, Core Technology Developer, Opera Software
      > Co-Chair, W3C SVG Working Group
      > Personal blog: http://my.opera.com/macdev_ed
      >
      > ------------------------------------
      >
      > -----
      > To unsubscribe send a message to:
      > svg-developers-unsubscribe@yahoogroups.com
      > -or-
      > visit http://groups.yahoo.com/group/svg-developers and click "edit my
      > membership"
      > ----Yahoo! Groups Links
      >
      >
      >
      >
      >
      > --
      > No virus found in this incoming message.
      > Checked by AVG.
      > Version: 7.5.519 / Virus Database: 269.22.1/1347 - Release Date:
      > 27/03/2008 07:15 p.m.
      >






      __________________________________________________
      Preguntá. Respondé. Descubrí.
      Todo lo que querías saber, y lo que ni imaginabas,
      está en Yahoo! Respuestas (Beta).
      ¡Probalo ya!
      http://www.yahoo.com.ar/respuestas
    • Erik Dahlström
      ... This mailinglist is a very poor bugtracker, I suggest using http://bugs.opera.com/wizard instead, and please provide the full details and testcase :)
      Message 2 of 4 , Apr 7, 2008
        On Fri, 04 Apr 2008 19:49:53 +0200, Damian <damez77@...> wrote:

        > Erik:
        >
        > I posted this problem, but i had no answers (tested in Opera 9.5):
        >
        > <a xlink:href="http://www.google.com">
        > <image xlink:href="flower.svg" x="230" width="200" height="200"
        > />
        > </a>
        >
        > the <a> tag is not works.
        >
        > Is this a bug?

        This mailinglist is a very poor bugtracker, I suggest using
        http://bugs.opera.com/wizard instead, and please provide the full details
        and testcase :)

        Anyway, this works fine for me "main.svg":

        <svg xmlns="http://www.w3.org/2000/svg"
        xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="100px"
        height="100px" viewBox="0 0 100 100">
        <a xlink:href="http://www.opera.com">
        <image xlink:href="circle.svg" width="100" height="100"/>
        </a>
        </svg>

        And resource document "circle.svg":

        <svg xmlns="http://www.w3.org/2000/svg"
        xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 100 100">
        <circle cx="50" cy="50" r="30" fill="green"/>
        </svg>

        Works as expected in Opera 9.5 build 9864 (public build available at
        http://my.opera.com/desktopteam).

        Cheers
        /Erik

        --
        Erik Dahlstrom, Core Technology Developer, Opera Software
        Co-Chair, W3C SVG Working Group
        Personal blog: http://my.opera.com/macdev_ed
      • Damian
        I have Opera 9.5 (Build 9613) and that not works.The number of build is different.----- Original Message ----- From: Erik Dahlström To:
        Message 3 of 4 , Apr 7, 2008
          I have Opera 9.5 (Build 9613) and that not works.

          The number of build is different.

          ----- Original Message -----
          From: "Erik Dahlström" <ed@...>
          To: <svg-developers@yahoogroups.com>
          Sent: Monday, April 07, 2008 7:51 AM
          Subject: Re: [svg-developers] External image & xlink problem


          > On Fri, 04 Apr 2008 19:49:53 +0200, Damian <damez77@...> wrote:
          >
          >> Erik:
          >>
          >> I posted this problem, but i had no answers (tested in Opera 9.5):
          >>
          >> <a xlink:href="http://www.google.com">
          >> <image xlink:href="flower.svg" x="230" width="200" height="200"
          >> />
          >> </a>
          >>
          >> the <a> tag is not works.
          >>
          >> Is this a bug?
          >
          > This mailinglist is a very poor bugtracker, I suggest using
          > http://bugs.opera.com/wizard instead, and please provide the full details
          > and testcase :)
          >
          > Anyway, this works fine for me "main.svg":
          >
          > <svg xmlns="http://www.w3.org/2000/svg"
          > xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" width="100px"
          > height="100px" viewBox="0 0 100 100">
          > <a xlink:href="http://www.opera.com">
          > <image xlink:href="circle.svg" width="100" height="100"/>
          > </a>
          > </svg>
          >
          > And resource document "circle.svg":
          >
          > <svg xmlns="http://www.w3.org/2000/svg"
          > xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 100 100">
          > <circle cx="50" cy="50" r="30" fill="green"/>
          > </svg>
          >
          > Works as expected in Opera 9.5 build 9864 (public build available at
          > http://my.opera.com/desktopteam).
          >
          > Cheers
          > /Erik
          >
          > --
          > Erik Dahlstrom, Core Technology Developer, Opera Software
          > Co-Chair, W3C SVG Working Group
          > Personal blog: http://my.opera.com/macdev_ed
          >
          > ------------------------------------
          >
          > -----
          > To unsubscribe send a message to:
          > svg-developers-unsubscribe@yahoogroups.com
          > -or-
          > visit http://groups.yahoo.com/group/svg-developers and click "edit my
          > membership"
          > ----Yahoo! Groups Links
          >
          >
          >
          >
          >
          > --
          > No virus found in this incoming message.
          > Checked by AVG.
          > Version: 7.5.519 / Virus Database: 269.22.5/1358 - Release Date:
          > 03/04/2008 06:36 p.m.
          >






          __________________________________________________
          Preguntá. Respondé. Descubrí.
          Todo lo que querías saber, y lo que ni imaginabas,
          está en Yahoo! Respuestas (Beta).
          ¡Probalo ya!
          http://www.yahoo.com.ar/respuestas
        • Erik Dahlström
          ... It might be. Feel free to report it at http://bugs.opera.com/wizard together with a complete testcase (that is: including the referenced svg). Here s an
          Message 4 of 4 , Sep 4, 2008
            On Fri, 04 Apr 2008 19:49:53 +0200, Damian <damez77@...> wrote:

            > Erik:
            >
            > I posted this problem, but i had no answers (tested in Opera 9.5):
            >
            > <a xlink:href="http://www.google.com">
            > <image xlink:href="flower.svg" x="230" width="200" height="200" />
            > </a>
            >
            > the <a> tag is not works.
            >
            > Is this a bug?

            It might be. Feel free to report it at http://bugs.opera.com/wizard together with a complete testcase (that is: including the referenced svg).

            Here's an example that seemed to work just fine for me in Opera 9.5:

            <svg xmlns='http://www.w3.org/2000/svg' xmlns:xlink='http://www.w3.org/1999/xlink' viewBox="50 300 100 320" color="#4096EE" viewport-fill="black">

            <g id="buttons" text-anchor="middle" font-size="7" font-family="sans-serif">
            <a xlink:href="http://www.opera.com">
            <image xlink:href="data:image/svg+xml;charset=utf-8;base64,PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4NCjxzdmcNCiAgIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyINCiAgIHhtbG5zOnhsaW5rPSJodHRwOi8vd3d3LnczLm9yZy8xOTk5L3hsaW5rIg0KICAgdmVyc2lvbj0iMS4wIg0KICAgdmlld0JveD0iLTIgLTIgMTA0IDI0Ij4NCiAgPGRlZnM+DQogICAgPGxpbmVhckdyYWRpZW50IGlkPSJzdG9wcyI+DQogICAgICA8c3RvcCBzdHlsZT0ic3RvcC1jb2xvcjojNDA5NkVFO3N0b3Atb3BhY2l0eToxIiBvZmZzZXQ9IjAiLz4NCiAgICAgIDxzdG9wIHN0eWxlPSJzdG9wLWNvbG9yOiM0MDk2RUU7c3RvcC1vcGFjaXR5OjAiIG9mZnNldD0iMSIvPg0KICAgIDwvbGluZWFyR3JhZGllbnQ+DQogICAgPGxpbmVhckdyYWRpZW50IHgxPSIwIiB5MT0iMCIgeDI9IjAiIHkyPSItMS41IiBpZD0iZmlsbCIgeGxpbms6aHJlZj0iI3N0b3BzIiBzcHJlYWRNZXRob2Q9InJlZmxlY3QiLz4NCgk8bGluZWFyR3JhZGllbnQgeDE9IjAiIHkxPSIwIiB4Mj0iMCIgeTI9Ii0xLjUiIGlkPSJzdHJva2UiIHhsaW5rOmhyZWY9IiNzdG9wcyIgc3ByZWFkTWV0aG9kPSJyZWZsZWN0IiBncmFkaWVudFRyYW5zZm9ybT0ic2NhbGUoMSAtMSkiLz4NCiAgPC9kZWZzPg0KICA8Zw0KICAgICBpZD0ibGF5ZXIxIj4NCiAgICA8cmVjdA0KICAgICAgIHdpZHRoPSIxMDAiDQogICAgICAgaGVpZ2h0PSIyMCINCiAgICAgICByeD0iNiINCiAgICAgICBzdHlsZT0iZmlsbDp1cmwoI2ZpbGwpO3N0cm9rZTp1cmwoI3N0cm9rZSkiDQogICAgICAgaWQ9InJlY3QzNDMxIiAvPg0KICA8L2c+DQo8L3N2Zz4%3D" width="100" height="20" x="50" y="300"/>
            </a>
            <text x="100" y="312" fill="white" pointer-events="none">Click me</text>
            </g>

            </svg>

            Cheers
            /Erik

            --
            Erik Dahlstrom, Core Technology Developer, Opera Software
            Co-Chair, W3C SVG Working Group
            Personal blog: http://my.opera.com/macdev_ed
          Your message has been successfully submitted and would be delivered to recipients shortly.